Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Externe geluidskaart: misvormd geluid  (gelezen 3408 keer)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Externe geluidskaart: misvormd geluid
« Gepost op: 2010/05/22, 11:59:50 »
Ik heb gisteren een simpele externe USB-geluidskaart gekocht om mijn surround system op aan te sluiten, die vandaag bezorgd is en nu wilde ik hem direct in gebruik nemen. Gaat allemaal prima, alleen het geluid klinkt nogal misvormd ??? Het gaat via PulseAudio. Zonder die geluidskaart klinkt het geluid prima via PulseAudio.

Het gaat om een Trust S5500P.

Iemand een idee?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #1 Gepost op: 2010/05/22, 15:25:46 »
Btw, ik vergat nog even de uitkomst te geven van aplay enzo.

vistausss@vistausss-laptop:~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC262 Analog [ALC262 Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 1: HDMI [HDA ATI HDMI], apparaat 3: ATI HDMI [ATI HDMI]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 2: Device [USB Sound Device], apparaat 0: USB Audio [USB Audio]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
vistausss@vistausss-laptop:~$

vistausss@vistausss-laptop:~$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd4a00000 irq 22
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xd0030000 irq 17
 2 [Device         ]: USB-Audio - USB Sound Device
                      USB Sound Device at usb-0000:00:1d.0-1, full speed
vistausss@vistausss-laptop:~$


Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #2 Gepost op: 2010/05/24, 11:29:22 »
Niemand? :(

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #3 Gepost op: 2010/05/24, 12:56:40 »
Zou je ook nog kunnen melden, wat je tot nu toe geprobeerd hebt? Verder zou je de output kunnen posten met de usb geluidskaart ingplugd van lsusb [Enter] Check ook nog of er iets bruikbaars staat in deze hyperlink https://help.ubuntu.com/community/SoundTroubleshooting tenminste zover het van toepassing is. Werkt die usb geluidskaart overigens wel goed op een andere PC? Of onder een andere Linux distributie en/of Windows. 
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #4 Gepost op: 2010/05/24, 13:10:27 »
Ik heb hem nog niet ergens anders getest. Wel heb ik Sound Troubleshooting al doorgenomen. Heb ook al een paar topics op het Engelse forum gevolgd, niks heeft geholpen.

ldconfig deferred processing now taking place
vistausss@vistausss-laptop:~$ lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 046d:c049 Logitech, Inc. G5 Laser Mouse
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 145f:0143 Trust
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 04f2:b14e Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
vistausss@vistausss-laptop:~$

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #5 Gepost op: 2010/05/24, 14:18:51 »
Alleen "Bus 006 Device 002: ID 145f:0143 Trust" dus. Het is in ieder geval iets meer info, dan in dit topic op het Engelstalige Ubuntu forum USB Soundcard not working. Of had je die thread al bekeken? Check eventueel ook nog deze hyperlink Anyone having any distorted sound issues in Ubuntu 10.04 : Do this (remove pulseaudio).
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #6 Gepost op: 2010/05/24, 14:26:24 »
PulseAudio werkt gewoon zonder die geluidskaart aangesloten, dus dat is het probleem niet. Maar ik heb dat topic even doorgenomen (die had ik toevallig nog niet gevonden trouwens), en heb geprobeerd wat er stond. Maar ook dat lukt jammer genoeg niet:

vistausss@vistausss-laptop:~$ cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.22.1 emulation code)
Kernel: Linux vistausss-laptop 2.6.32-22-generic-pae #33-Ubuntu SMP Wed Apr 28 14:57:29 UTC 2010 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
HDA Intel at 0xd4a00000 irq 31
HDA ATI HDMI at 0xd0030000 irq 32
USB Sound Device at usb-0000:00:1d.0-1, full speed

Audio devices:
0: ALC262 Analog (DUPLEX)
2: USB Audio (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Realtek ALC262
1: ATI R6xx HDMI
2: USB Mixer
vistausss@vistausss-laptop:~$ asoundconf set-default-card 2
asoundconf: command not found
vistausss@vistausss-laptop:~$

Misschien bestaat asoundconf niet meer in 10.04?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #7 Gepost op: 2010/05/24, 15:26:10 »
Misschien bestaat asoundconf niet meer in 10.04?
Dat zou kunnen. Ik vind 'm ook niet in Ubuntu 10.04 sudo find / -name asound.conf*
[sudo] password for jolo:
/usr/share/doc/libasound2-plugins/examples/asound.conf_jack
/usr/share/doc/libasound2-plugins/examples/asound.conf_oss
Wellicht ligt het dan gewoon aan de (beperkte) Linux ondersteuning van die externe trust geluidskaart. Er waren zo te zien ook al problemen mee met alsa
https://answers.launchpad.net/ubuntu/+question/25921
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/236465
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #8 Gepost op: 2010/05/24, 15:38:38 »
Dat zou inderdaad best eens kunnen. Ik heb het bug report heropend en aangevuld met de informatie die ze wilden, dus nu is het afwachten..
Tenzij iemand hier ineens met de gouden tip komt.

Jolo, bedankt voor alle hulp tot dusver :)

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Externe geluidskaart: misvormd geluid
« Reactie #9 Gepost op: 2010/05/24, 17:50:42 »
Ik heb het bug report heropend en aangevuld met de informatie die ze wilden, dus nu is het afwachten..
Zou het kunnen dat wellicht alleen de bugreporter zijn/haar bugmelding kan heropenen. Want deze is weer teruggezet naar Incomplete.

Zou je dan niet beter een nieuwe bugmelding kunnen doen.

Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro