Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: kernel parameter CONFIG_SYSFS_DEPRECATED_V2  (gelezen 420 keer)

Offline HvR

  • Lid
  • Steunpunt: Nee
kernel parameter CONFIG_SYSFS_DEPRECATED_V2
« Gepost op: 2010/05/19, 23:32:42 »
Om mijn bebook Neo onder calibre aan het werk te krijgen moet ik blijkbaar de parameter CONFIG_SYSFS_DEPRECATED_V2 aanpassen zie (http://calibre-ebook.com/user_manual/faq.html#why-is-my-device-not-detected-in-linux).

Als ik het commando "grep SYSFS_DEPRECATED /boot/config-`uname -r`" geef, dan is de output:
"# CONFIG_SYSFS_DEPRECATED_V2 is not set"

Ik denk dat ik een nieuwe kernel moet genereren om e.e.a. voor elkaar te krijgen. Ik heb hier geen ervaring mee en heb een heleboel vragen:
1. Wat is de impact op de rest van mijn systeem als ik deze parameter aanpas? Hij zal vast niet toevallig staan zoals ie staat.
2. Hoe pak ik dit het beste aan? Ergens een link naar een stap voor stap documentatie?
3. Als de update manager een nieuwe versie van de kernel heeft, wordt die dan nog automatisch ge√Įnstalleerd?
4. En als dat zo is, blijft mijn aanpassing dan in takt? Lijkt mij niet, want de update manager doet een binary install.
5. Waar moet ik verder nog op letten.

Alvast Dank


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: kernel parameter CONFIG_SYSFS_DEPRECATED_V2
« Reactie #1 Gepost op: 2010/05/20, 15:57:57 »
Even de kromme Google vertaling:
kaliber gebruikt iets genaamd sysfs om apparaten te detecteren in linux. De Linux kernel kan de uitvoer twee uitvoeringen van sysfs, waarvan er een is verouderd. Sommige Linux-distributies nog steeds schip met kernels dat de verouderde versie van sysfs te ondersteunen, zelfs al was het afgekeurde een lange tijd geleden. In dit geval, apparaatdetectie in kaliber zal niet werken. U kunt controleren welke versie van sysfs wordt uitgevoerd door uw kernel met het volgende commando:
 grep SYSFS_DEPRECATED /boot/config-`uname -r`
Je moet zoiets zie CONFIG_SYSFS_DEPRECATED_V2 is niet ingesteld. Als u niet moet je je kernel hercompileren met hetzij de juiste instelling, of een upgrade van je Linux distro naar een meer moderne versie, wanneer dit niet zal worden ingesteld.
Voor jou betekent het dat je de oudere versie van sysf.
Ga naar systeem>Beheer>Updatebeheer en kijk of er een nieuwere kernelversie is, dan kan je deze installeren. Geheel automatisch updates installeren kan je in de updatemanager instellen. Ik weet niet welke versie van Ubuntu je hebt? Het kan nodig zijn om een nieuwere versie met nieuwere kernels te installeren. Zelf een kernel compileren, zou ik alleen doen, als je veel ervaring hebt met linux.
In der Beschränkung zeigt sich der Meister.