Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Zwart beeld na installatie 10.04  (gelezen 1814 keer)

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
Zwart beeld na installatie 10.04
« Gepost op: 2010/05/09, 01:44:08 »
Na een tijd lang 9.x gedraaid te hebben heb ik zonet maar is xUbuntu 10.04 geïnstalleerd...
Maar bij het opstarten lijkt het of m'n beeldscherm(Samsung SyncMaster 245B) ineens geen signaal meer kan vinden.
Ik zie een paar een keer DIGITAL, ANALOG verschijnen, maar het beeld blijft gewoon zwart en gaat vervolgens ook over op standby.
Het lampje van m'n harde schijf blijft ook branden en het lijkt op een goede vastloper, al lukt het nog wel met ctrl+alt+del te rebooten.
Iemand een idee hoe dit op te lossen?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
Re: Zwart beeld na installatie 10.04
« Reactie #1 Gepost op: 2010/05/09, 03:00:04 »
Het lijkt erop dat ik met twee problemen zit.
Via grub booten zonder quiet splash en met nomodeset kreeg ik weer wat te zien, maar zag toen het volgende staan:

fsck from util-linux-ng 2.17.2
fsck from util-linux-ng 2.17.2

/dev/sda2: clean, 97434/6111232 files, 865388/24414783 blocks
home contains a file system with errors, check forced
init: ureadahead-other main process (923) terminated with status 4

En dan na een minuut of 5:
home: Inodesthat were port of a corrupted orphan linked list found.
home: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options)

mountall: fsck /home [432] terminated with status 4
mountall: Filesystem has errors: /home

Snap het niet helemaal, want het is een gewone ext3 partitie waar ik m'n oude home op had staan en die ik gewoon nog vanuit windows kan benaderen.
(home wel naar home.old gewijzigd zodat hij bij het installeren een nieuwe home directory in de partitie kon aanmaken)
« Laatst bewerkt op: 2010/05/09, 03:19:14 door Math. »

www.Open-design.nl - Open your mind. B creative with OSS.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: Zwart beeld na installatie 10.04
« Reactie #2 Gepost op: 2010/05/09, 11:42:20 »
Ubuntu 10.04 heeft problemen met videodrivers met name voor Intel videokaarten i845/855:
https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/370292
Het is ronduit teleurstellend dat een Final Release van Lucid Lynx, een Ubuntu-versie met de aanduiding LTS, dat soort problemen bevat.

Het probleem met de /home-partitie kan veroorzaakt zijn door het mounten vanuit Windows. Ik heb geen idee welk programma je hiervoor gebruikt, maar als het mounten en unmonten niet correct wordt uitgevoerd, dan ontstaan er problemen. Als er bestanden worden geschreven of verwijderd zonder dat deze netjes o.a. in de journal-tabellen worden genoemd, dan worden conflicten gemeld.

De mogelijke oplossing: gebruik een Linux-live-CD (de versie is eigenlijk niet van belang) en repareer je /home.
De partitie mag niet gemount zijn.
Start de live-CD en voer dan het volgende uit in een root-terminal.
Bij de root-terminal van een live-CD wordt je geen wachtwoord gevraagd en is geen "sudo" nodig.
blkidHiermee zie je welke partities op de HD bestaan en welk devicenummer bij de partitie hoort. Hierna kan de controle uitgevoerd worden, bijv.
fsck /dev/sda6
Als je een gewone user-terminal van de live-CD gebruikt, dan moet je deze opdrachten gebruiken:
sudo blkid
sudo fsck /dev/sda6

Xubuntu 16.04; siduction-15.1.0 Xfce

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
Re: Zwart beeld na installatie 10.04
« Reactie #3 Gepost op: 2010/05/09, 22:24:06 »
Vind het ook erg jammer dat deze nieuwe versie problemen geeft. Nooit problemen met 9.04/9.10 gehad.

Ik heb geprobeerd via diverse live CD's (6.x ~ 9.04)op te starten, maar hij loopt ergens vast. Zag iets met tty staan ofzo.
Denk dat deze live CD's misschien te oud zijn voor mijn systeem.

Ik ga nog is kijken of ik een lege CD over heb om Ubuntu 10.04 Live op te zetten.

edit:
Ubuntu 10.04 Desktop CD start gelukkig wel goed op, hij is nu via fsck het een en ander aan het fixen.
Snap alleen niet hoe er fouten op de schijf zijn gekomen. Hopelijk verlies ik nu ook geen data.
ubuntu@ubuntu:~$ sudo fsck /dev/sda3
fsck from util-linux-ng 2.17.2
e2fsck 1.41.11 (14-Mar-2010)
home contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inodes that were part of a corrupted orphan linked list found.  Fix<y>? yes

Inode 11010413 was part of the orphaned inode list.  FIXED.
Inode 11010415 was part of the orphaned inode list.  FIXED.
Inode 11010420 was part of the orphaned inode list.  FIXED.
Inode 11010421 was part of the orphaned inode list.  FIXED.
Inode 11010422 was part of the orphaned inode list.  FIXED.
Inode 11010423 was part of the orphaned inode list.  FIXED.
Inode 12058850 was part of the orphaned inode list.  FIXED.
Inode 12058909 was part of the orphaned inode list.  FIXED.
Inode 12058910 was part of the orphaned inode list.  FIXED.
Deleted inode 12058913 has zero dtime.  Fix<y>? yes

Inode 12058914 was part of the orphaned inode list.  FIXED.
Inode 12058915 was part of the orphaned inode list.  FIXED.
Inode 12058963 was part of the orphaned inode list.  FIXED.
Inode 12058964 was part of the orphaned inode list.  FIXED.
Als alles gefixed is probeer ik wel weer eens een keer Ubuntu i.p.v. xUbuntu.
« Laatst bewerkt op: 2010/05/09, 23:16:32 door Math. »

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
Re: Zwart beeld na installatie 10.04
« Reactie #4 Gepost op: 2010/05/10, 00:35:21 »
Ok, het lijkt erop dat alle fouten nu hersteld zijn. Ubuntu 10.04 draait ook prima nu.
Ik ga er nog wat mee spelen en wellicht nog een poging wagen xUbuntu erop te krijgen.

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
Re: Zwart beeld na installatie 10.04
« Reactie #5 Gepost op: 2010/05/10, 08:09:24 »
Ok, na even met Ubuntu gespeeld te hebben, nu weer xUbuntu erop gezet. Geen echt problemen meer.
Probleem zat hem dus in het feit dat er iets niet goed zat op de partitie, maar omdat hij de grafische mode ook niet kon instellen bleef ik op een zwart beeld hangen.

xUbuntu start dus nu gewoon op, alleen het logo ziet er heel lelijk uit, alsof het maar uit één egale kleur bestaat.
Eenmaal ingelogd, gewoon weer oud en vertrouwd zoals ik xUbuntu ken.

www.Open-design.nl - Open your mind. B creative with OSS.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: resolutie bij het starten aanpassen
« Reactie #6 Gepost op: 2010/05/10, 16:17:37 »
De reden voor de "lelijke" weergave van het log is de resolutie. Je kan de StartUp-Manager installeren via het Software-Center en dan vervolgens de instellingen aanpassen. (Er zitten ook nog meer opties in de StartUp-Manager behalve deze.)
Xubuntu 16.04; siduction-15.1.0 Xfce