Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]Externe media niet zichtbaar op bureaublad  (gelezen 1114 keer)

Offline Roland2

  • Lid
  • Steunpunt: Nee
[OPGELOST]Externe media niet zichtbaar op bureaublad
« Gepost op: 2010/05/08, 18:27:30 »
USB-sticks e.d. worden niet weergegeven op mijn bureaublad, ondanks de m.i. juiste settings in de configuratie-editor.

Wat doe ik verkeerd??

10.04 natuurlijk  :-)

(ik hoop dat de bijlage duidelijk genoeg is; mag maar 100KB gebruiken)
« Laatst bewerkt op: 2010/05/09, 13:48:19 door Roland »

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: Externe media niet zichtbaar op bureaublad
« Reactie #1 Gepost op: 2010/05/08, 23:13:53 »
Open eens een terminal en geef daar in:

tail -f /var/log/messages
Steek dan je USB-stick in je pc, dan kan je zien of die wordt gezien en geconnect wordt.

Als je het stikje dan op je bureaublad ziet, rechtsklikken en kiezen voor "Uitwerpen".

Om in de terminal daarna dat commando te stoppen druk je gewoon op Ctrl+C.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Roland2

  • Lid
  • Steunpunt: Nee
Re: Externe media niet zichtbaar op bureaublad
« Reactie #2 Gepost op: 2010/05/08, 23:37:07 »
Dank je.
Meteen even geprobeerd (de bewuste pc aangezet) en de stick werd nu zonder verder ingrijpen van mij herkend terwijl ik eerder toch ook al een reboot had geprobeerd.

De externe HD (losgekoppeld tijdens de installatieprocedure, dat is wrschlijk de oorzaak) wordt niet automatisch aangekoppeld. ik weet dat dit 'iets' met fstab te maken heeft, maar ja...de klok en de klepel...ik durf daar niet in te gaan wroeten. Ik kan niet grafisch laten automounten?

Hieronder de resultaten van fdisk en fstab, voor als iemand mij zou willen helpen...

Sudo fdisk -l:
Schijf /dev/sda: 250.1 GB, 250059350016 bytes
255 koppen, 63 sectoren/spoor, 30401 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x00025851

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1        2432    19535008+  83  Linux
/dev/sda2            2433        2918     3903795   82  Linux wisselgeheugen
/dev/sda3            2919       30075   218138602+  83  Linux

Schijf /dev/sdf: 250.1 GB, 250059350016 bytes
255 koppen, 63 sectoren/spoor, 30401 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x8f9c798a

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdf1               1       30401   244196001    c  W95 FAT32 (LBA)

Fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
/dev/sda3       /home           ext4    defaults        0       2
# swap was on /dev/sda2 during installation
UUID=670ce3f7-aab6-4cb5-a803-b7eac3e796eb none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Externe media niet zichtbaar op bureaublad
« Reactie #3 Gepost op: 2010/05/09, 11:28:42 »
Een externe schijf moet je niet in /etc/fstab opnemen. Die moet normaal automatisch aankoppelen bij inpluggen. Niet automatisch aankoppelen kan een gevolg zijn van een beschadiging van het bestandssysteem. Controleer in elk geval eerst en vooral het bestandssysteem

sudo umount /dev/sdf1
sudo dosfsck /dev/sdf1

Zijn er foutmeldingen, dan moet je ook gaan repareren: optie -a of -r toevoegen aan het dosfsck commando.

Offline Roland2

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST]Externe media niet zichtbaar op bureaublad
« Reactie #4 Gepost op: 2010/05/09, 13:52:36 »
Lang gezocht naar oplossing, zelfs 10.04 opnieuw geïnstalleerd zonder succes.

Toen ergens, ik geloof op dit forum, de oplossing gevonden: zet in de BIOS de ondersteuning voor floppy-drive uit (ik heb niet eens een floppy-drive!), en ja hoor: ik heb het verschillende keren met herstart en in BIOS de floppy aan/uit geprobeerd.

Dus met floppy-ondersteuning UITgeschakeld in BIOS verschijnen de USB-sticks en USB-HD gewoon weer op je bureaublad. Raar maar waar.