Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Starcraft 2 (Problemen met depedencies van libssl-dev)  (gelezen 1710 keer)

Offline BoudewijnD

  • Lid
  • Steunpunt: Nee
Starcraft 2 (Problemen met depedencies van libssl-dev)
« Gepost op: 2010/05/05, 17:47:57 »
Ik wil graag de beta van starcraft 2 gaan spelen en volgens WineHQ moet dat prima gaan en het lukt ook een heel eind. Maar als ik sudo apt-get build-dep wine invoer, wat moet volgens de website die ik volg: http://appdb.winehq.org/objectManager.php?sClass=version&iId=19376

Dan krijg ik de mededeling dat mijn dependencies van libssl-dev niet kloppen.
boudewijn@boudewijn-desktop:~/wine-git$ sudo apt-get build-dep wine
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages have unmet dependencies:
  libssl-dev: Depends: libssl0.9.8 (= 0.9.8g-16ubuntu3.1) but 0.9.8k-7ubuntu8 is to be installed
E: Build-dependencies for wine could not be satisfied.

Ik heb ook via SPM geprobeerd maar dan krijg ik het zelfde gezeur.
Kan iemand mij even in de goede richting helpen?

Alvast bedankt,

\BoudewijnD
« Laatst bewerkt op: 2010/05/10, 20:51:47 door BoudewijnD »
Desktop: AMD AThlon II X4 630 2.8 GHz, ATI Radeon HD 5450 1 Gb, 4 GB, 1.5 TB. Ubuntu 12.04 LTS
----------------------------------------------------------------------
Linux user number 519529
Registreer als Linux gebruiker op: http://counter.li.org/

Offline BoudewijnD

  • Lid
  • Steunpunt: Nee
Re: Problemen met depedencies van libssl-dev
« Reactie #1 Gepost op: 2010/05/05, 22:34:05 »
niemand die het weet misschien staat hij wel in de verkeerde map kan iemand hem naar Games zetten!
Desktop: AMD AThlon II X4 630 2.8 GHz, ATI Radeon HD 5450 1 Gb, 4 GB, 1.5 TB. Ubuntu 12.04 LTS
----------------------------------------------------------------------
Linux user number 519529
Registreer als Linux gebruiker op: http://counter.li.org/

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Problemen met depedencies van libssl-dev
« Reactie #2 Gepost op: 2010/05/05, 22:51:35 »
Dubbelposten is niet toegestaan binnen 48 uur.

"Breng je eigen topic alleen omhoog indien er na twee dagen geen reactie is geweest. Doe dit hooguit twee keer om vervuiling van het forum te voorkomen."
http://www.ubuntu-nl.org/ubuntunl/richtlijnen#Forum

Offline BoudewijnD

  • Lid
  • Steunpunt: Nee
Re: Starcraft 2 (Problemen met depedencies van libssl-dev)
« Reactie #3 Gepost op: 2010/05/13, 16:20:31 »
Het probleem met libssl-dev heb ik wel kunnen oplossen want je kan in Synaptic zeggen welke versie je geinstaleerd wil hebben via package--> Force Version..

Maar het spel loopt nog steeds niet. Ik krijg het opstart scherm maar daarna een crash.

Heeft iemand anders dit probleem ook??
Desktop: AMD AThlon II X4 630 2.8 GHz, ATI Radeon HD 5450 1 Gb, 4 GB, 1.5 TB. Ubuntu 12.04 LTS
----------------------------------------------------------------------
Linux user number 519529
Registreer als Linux gebruiker op: http://counter.li.org/

slickeel

  • Gast
Re: Starcraft 2 (Problemen met depedencies van libssl-dev)
« Reactie #4 Gepost op: 2010/06/07, 12:12:42 »
boudewijn@boudewijn-desktop:~/wine-git$ sudo apt-get build-dep wine
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages have unmet dependencies:
  libssl-dev: Depends: libssl0.9.8 (= 0.9.8g-16ubuntu3.1) but 0.9.8k-7ubuntu8 is to be installed
E: Build-dependencies for wine could not be satisfied.

Dit is een dependency error die je vooral krijgt bij het gebruik van verschillende repositories of als bijvoorbeeld losse .deb files worden installeerd. Ook kan dit komen door het handmatig compilen van source. Handmatige edits in de repositories kunnen zoiets ook veroorzaken, bijvoorbeeld bij het mengen van pakketten uit verschillende versies van ubuntu.

Check je /etc/apt/sources.list.d/ map gezien daarin extra repos kunnen staan. Ook die kunnen dependency problemen veroorzaken. Kijk ook even je /etc/apt/sources.list na. Wat je verder zou kunnen doen is libssl verwijderen, inclusief alles wat daarop leunt (echter is het vaak zo dat je als je alles daarna weer installeerd je gewoon hetzelfde probleem weer hebt).

aptitude purge libssl0.9.8
Verder zou je kunnen kijken of je naar een nieuwe versie van ubuntu zou kunnen updaten, via:

do-release-upgrade
Wat ik je anders nog kan aanraden is om mijn howto te proberen zodat je starcraft 2 in wine kan draaien. Hij is gemaakt voor de laatste ubuntu versie op dit moment. De howto gaat wel uit van een nieuw geinstalleerd systeem, dus hou daar rekening mee gezien ik zelf dus geen dependency problemen heb. De game draait bij mij prima.

http://slickeel.wordpress.com/2010/06/02/starcraft-2-beta-wings-of-liberty-in-ubuntu-lucid-lynx-with-wine/