Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Pdf's openen in ongewenste vorm  (gelezen 600 keer)

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Pdf's openen in ongewenste vorm
« Gepost op: 2010/05/04, 07:37:12 »
In Evince worden pdf's geopend in een piepklein venstertje met ook nog eens een ongewenste zijbalk. Niet zo leuk, vooral als je er veel achter elkaar moet openen.
Evince heeft niet zoiets als voorkeuren en wat ik ook aan/uitvink, bij de volgende staat het weer net zo verkeerd.

Wie weet hoe de instellingen bewaard kunnen blijven?
« Laatst bewerkt op: 2010/05/04, 07:47:18 door Lexaldo »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #1 Gepost op: 2010/05/04, 07:41:16 »
Je bedoelt de zijbalk met de paginamiaturen? Hoe kun je die nu ongewenst vinden?

Je moet het venster maximaliseren en dan gewoon sluiten. Dan worden de vensterinstellingen opgeslagen, en zal Evince de volgende keer gemaximaliseerd openen.

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #2 Gepost op: 2010/05/04, 07:46:00 »
Die zijbalk gebruik ik nooit.  8)
De instellingen worden per pdf opgeslagen, maar als ik veel (verschillende) pdf's open blijf ik steeds dat scherm vergroten. Bij OpenOffice kun je dat in een keer instellen voor alle bestanden.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #3 Gepost op: 2010/05/04, 11:35:57 »
Ik merk dit ook: de venstergrootte van evince wordt in Ubuntu 10.04 niet "onthouden". Knap vervelend, inderdaad.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #4 Gepost op: 2010/05/04, 11:53:29 »
Dit bugrapport lijkt te suggereren dat er een fix op komst is: https://bugs.launchpad.net/ubuntu/+source/evince/+bug/503372/

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #5 Gepost op: 2012/11/13, 20:20:18 »
We zijn twee jaar verder, en een oplossing voor deze schijnbaar triviale bug is in zicht: https://bugs.launchpad.net/ubuntu/+source/evince/+bug/544639
Fix released op 14 oktober. Nu moet die eerst nog in Proposed terechtkomen, dus het kan nog wel een tijd duren tegen dat die in de normale updates terechtkomt.

Voor Unity (3D) gebruikers is er een mogelijkheid om evince standaard gemaximaliseerd te laten starten: Compiz Config Settings Manager, Window Management, Window Rules: voer in bij maximized
(class=Evince) & !(role=GtkFileChooserDialog)
Heb je compiz niet, dan moet dat ook mogelijk zijn met devilspie.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Pdf's openen in ongewenste vorm
« Reactie #6 Gepost op: 2012/11/19, 13:27:15 »
De oplossing in mijn vorige post is niet ideaal: de print-dialoog wordt ook gemaximaliseerd, en het blijkt niet mogelijk ook voor dat venster een uitzondering te definiƫren. Erger is dat de gemaximaliseerde evince vensters na deze ingreep niet meer kunnen verkleind worden.

Er blijkt echter een andere methode in compiz te zijn te zijn, die het wel helemaal goed doet. Die maakt gebruik van de "Place Windows" plugin, die onder Ubuntu standaard actief is. In de tab "Fixed Window Placement" klik je op de "new" knop. Window: "class=evince", Mode:  Maximize.

De plugin "Window rules" mag natuurlijk terug uitgeschakeld worden.