Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: cups server niet actief in lucid  (gelezen 2832 keer)

Offline summer of 69

  • Lid
  • Steunpunt: Nee
cups server niet actief in lucid
« Gepost op: 2010/05/03, 17:21:16 »
Bij het aansluiten van de printer bleek dat de cups server niet actief was. In firefox : http://localhost:631 bleek dat ook.
Volgens de hulpfiles moest ik naar systeem>beheer>diensten de cups server activeren maar die "Diensten" waren niet te vinden.
Dan maar "sudo apt-get install bum" en nu had ik wel de boot-up-manager. Cups geactiveerd (stond idd niet aan) en de printer werd direkt herkend.
Maar... na een herstart blijkt dat de cups server weer niet actief staat. Is dit een bug en heeft er iemand een gelijkaardige ervaring met cups?
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #1 Gepost op: 2010/05/05, 15:24:13 »
Heeft er echt niemand last van dit cups server probleempje. Op het engelstalig forum blijkbaar wel, alhoewel niemend echt een oplossing aanbiedt. Of gaat het hier over een bug in lucid. Eigenlijk is het wel grappig. Als ik opstart ga ik al automatisch checken of m'n cups server wel actief is  :lol:
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #2 Gepost op: 2010/05/05, 15:43:32 »
Yup, same here. Elke als ik boot moet ik een keer "sudo cupsd" uitvoeren om te kunnen printen... Heb je een linkje naar de thread in het engelstalige forum?
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #3 Gepost op: 2010/05/05, 16:00:37 »
Vreemd, hier geen last met cups op de Linke Lucy.
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #4 Gepost op: 2010/05/05, 16:03:28 »
Vreemd, hier geen last met cups op de Linke Lucy.
Heb in weekend Lucid en xp volledig terug geïnstalleerd op pc van buurvrouw. Printer werkte ook nie, maar usb kabel was niet aangesloten :lol:
Daar geen probleem met de cups server. Al goed.
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #5 Gepost op: 2010/05/05, 16:07:28 »
Yup, same here. Elke als ik boot moet ik een keer "sudo cupsd" uitvoeren om te kunnen printen... Heb je een linkje naar de thread in het engelstalige forum?

http://ubuntuforums.org/showthread.php?t=1473201&highlight=cups+server

http://ubuntuforums.org/showthread.php?t=1473570&highlight=cups+server

Nog even verder zoeken ;)

nog eentje : http://ubuntuforums.org/showthread.php?t=1472168&highlight=cups+server

Eigenaardig dat er hier zo weinig reactie op komt. Er moeten toch meer mensen zijn die dit ondervinden ??
« Laatst bewerkt op: 2010/05/05, 16:09:37 door summer of 69 »
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Passant

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #6 Gepost op: 2010/05/05, 17:09:18 »
Wat krijgen jullie dan als resultaat als je het commando ls /etc/rc?.d/*cups intypt?
« Laatst bewerkt op: 2010/05/05, 17:11:25 door Adriaan L. »

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #7 Gepost op: 2010/05/05, 18:04:20 »
Wat krijgen jullie dan als resultaat als je het commando ls /etc/rc?.d/*cups intypt?

/etc/rc1.d/K80cups  /etc/rc3.d/S50cups  /etc/rc5.d/S50cups
/etc/rc2.d/S50cups  /etc/rc4.d/S50cups
Ondertussen heb ik hier al meerdere keren opgestart en telkens is de cups server actief. Zojuist heb ik een grote update binnengekregen met een kernel update. Maar de cups server functioneerde daarvoor al normaal. Dit is eigenlijk het 2de rare fenomeen. bij het installeren van 10.04 voor de buurvrouw in het weekend kreeg ik bij de 2de reboot de melding "out of disk - grub error". Na 2 maal rebooten geen enkel probleem meer, zonder iets essentieel te veranderen. Raar :)
« Laatst bewerkt op: 2010/05/05, 18:08:34 door summer of 69 »
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #8 Gepost op: 2010/05/05, 23:13:15 »
Wat krijgen jullie dan als resultaat als je het commando ls /etc/rc?.d/*cups intypt?
Zelfde output als hierboven.
En die kernel update heb ik hier ook zien passeren. Heeft heel mijn Xorg server neergehaald. Na drie kwartier modden terug aan de praat gekregen... Lucid een LTS? Die S staat duidelijk niet voor Stable (wat ook zo is, het staat voor Support)
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #9 Gepost op: 2010/05/05, 23:23:31 »
CUPS draait volgens mij in user-space en heeft niets met de kernel te maken.


inaninck@LT9:~$ lsmod | grep -i ups
inaninck@LT9:~$
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #10 Gepost op: 2010/05/06, 08:37:59 »
Wat krijgen jullie dan als resultaat als je het commando ls /etc/rc?.d/*cups intypt?
Zelfde output als hierboven.
En die kernel update heb ik hier ook zien passeren. Heeft heel mijn Xorg server neergehaald. Na drie kwartier modden terug aan de praat gekregen... Lucid een LTS? Die S staat duidelijk niet voor Stable (wat ook zo is, het staat voor Support)
Hier geen problemen gehad met de x server na die kernel update. Maar eigenlijk moet ik je bijtreden wat 10.04 betreft. Heb al enkele bugs ondervonden en dat is volgens mij geleden van Edgy Eft (6.10). Sinds 7.04 heb ik NOOIT een probleem gehad na een clean install. Ik begin me serieus af te vragen of de fout niet bij grub 2 ligt die mijns inziens nog niet volledig op punt staat. Met grub legacy heb ik nooit last gehad. Waar zitten al die ubuntu experts hier op het forum want misschien zie ik dat helemaal verkeerd ;)

CUPS draait volgens mij in user-space en heeft niets met de kernel te maken.


inaninck@LT9:~$ lsmod | grep -i ups
inaninck@LT9:~$


Ok, maar dat lost het probleem met de cups server niet op hé
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Passant

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #11 Gepost op: 2010/05/06, 10:30:32 »
Ik heb dit probleem eens opgezocht op launchpad en kwam deze bug tegen. Ik hoop dat de daar voorgestelde oplossingen soelaas brengen bij jullie.

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #12 Gepost op: 2010/05/06, 17:38:07 »
Ik heb dit probleem eens opgezocht op launchpad en kwam deze bug tegen. Ik hoop dat de daar voorgestelde oplossingen soelaas brengen bij jullie.
Blijkbaar hier ook geen afdoende oplossing :(
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Jarige

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #13 Gepost op: 2010/06/15, 23:15:28 »
Met behulp van de link naar de bug heb ik wel een commandotje gevonden wat voor mij het probleem oplost:

sudo start rc-sysinit

Een verwant probleem is dat vboxvdr (oid) en de tty's niet werken. Ik ben niet zo ontzettend bekend met Linux en hoe het allemaal werkt, maar dit commando hersteld alles weer, dus ik ben weer even tevreden.
In de bug comments staat overigens ook hoe je dit commando elke boot automatisch kan laten uitvoeren zonder het vragen naar een wachtwoord. Dit heb ik maar niet gedaan, dat leek me wat onveilig.

Maar wat jullie ervaren kan net zo goed iets anders zijn natuurlijk...

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #14 Gepost op: 2010/07/04, 17:56:41 »
Bij een verse installatie op een Packard Bell hier ook hetzelfde probleem! Cups is eenvoudig niet gestart zoals blijkt uit de output van ps ax. Met sudo /etc/init.d/cups start lukt het dan om de server te starten en een printer toe te voegen (die het vooralsnog niet doet)

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #15 Gepost op: 2010/07/14, 21:56:14 »
Ook ik heb problemen mijn hp psc-1110 aan de praat te krijgen.
Cups start niet automatisch op,
na het handmatig starten van cups wordt de printer wel gevonden, maar bij het afdrukken van een pagina krijg ik steeds een foutmelding;
cups-server fout er was een fout tijdens de cups-bewerking: "client-error-document-format-not supported".
geen idee wat ik hier aan kan doen...
via http://localhost:631 kan ik wel verbinding maken met de printer, maar elke poging een testpagina af te drukken leverd weer een nieuwe foutmelding op.
als ik dan de probleemoplosser er op los kom er een errorlog uit met de volgende tekst (bijlage)




Helaas wordt ik hier helemaal niks wijzer van....


Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: cups server niet actief in lucid
« Reactie #16 Gepost op: 2010/07/15, 09:46:14 »
Onafhankelijk van het probleem met cups moet voor een hp printer dikwijls nog een prorpietair stuurprogramma geïnstalleerd worden. Tagenwoordig zou dat, denk ik, min of meer automatisch moeten gaan bij installeeren van de printer. Probeer het anders eens aan de commandolijn met "sudo hp-setup". Zorg er wel eerst voor dat je printer aangesloten is en dat cups actief is.

ps. De printer, een Canon MP540, heb ik wel degelijk aan de praat kunnen krijgen: drivers van canon en bovendien nog eens een "transitiepakket" dat bij 9.10 hoort, en niet meer in Synaptic in 10.04, deden het. Niet zo moeilijk, maar ook niet voor Jan modaal. Het moeilijkste hierbij is het te weten komen hoe het kan.