Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 10.4 en ati  (gelezen 5010 keer)

Offline Sentmen

  • Lid
  • Steunpunt: Nee
Ubuntu 10.4 en ati
« Gepost op: 2010/05/03, 00:28:43 »
Sinds ik ubuntu 10.4 heb reageert ubuntu zeer traag. Op 9.10 was dat niet. Heel waarschijnlijk ligt dat aan de video kaart. Ik heb geprobeerd drivers te installeren, maar dat werkt niet. Het gaat hier om een ATI Radeon X1300. Weten jullie hoe ik deze kan installeren?

Ik heb al geprobeerd via de ATI site, en met envyng zonder resultaat.

Offline Alphyton

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #1 Gepost op: 2010/05/03, 09:55:48 »
Hi Sentmen,

Ik heb hetzelfde probleem, mijn Ati-driver die ik met veel moeite aan de praat heb gekregen werkt niet meer. Erg jammer van deze update..
~ Alles hat ein Ende, nur die Wurst hat zwei. ~

Offline Sentmen

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #2 Gepost op: 2010/05/03, 10:12:08 »
Je bedoeld dus met andere woorden dat ik een nieuwe nvidia kaart moet kopen om hem weer te laten werken?

Offline Alphyton

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #3 Gepost op: 2010/05/03, 10:24:11 »
Je bedoeld dus met andere woorden dat ik een nieuwe nvidia kaart moet kopen om hem weer te laten werken?

Nee, helemaal niet. We moeten hopen dat ATI snel een update uitbrengt op haar drivers :)
~ Alles hat ein Ende, nur die Wurst hat zwei. ~

Offline Sentmen

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #4 Gepost op: 2010/05/03, 20:16:55 »
Zou dit lang gaan duren? Want ik heb eerst met 9.10 een ltsp server opgezet. Dit is een terminal server. Het is de bedoeling om voor juli dit af te maken om er volledig mee te werken. Zou voor juni een driver hiervoor zijn?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #5 Gepost op: 2010/05/03, 20:42:39 »
Was er een driver geïnstalleerd in 9.10?
En werkt het niet met 10.04 keer dan terug naar 9.10 (installeer hem gewoon in dual-boot) en laat 10.04 staan om te kijken hoe het evolueerd.

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #6 Gepost op: 2010/05/03, 22:06:52 »
Volgens mij heb ik exact hetzelfde probleem. Gewoon een driver geïnstalleerd (fglrx), maar de grafische weergave is om te huilen. Aan m'n setup ligt het niet.

Wat ik echter niet begrijp, fglrx is toch helemaal niet van ATI? Zou er een algemeen probleem met AMD producten en versie 10.4 zijn?

Offline foxofinfinety

  • Lid
    • foxofinfinety
    • Foxofinfinety.com
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #7 Gepost op: 2010/05/03, 22:39:19 »
ATI is van AMD, er is niks echt "van ATI" want dan is het toch weer van AMD....

maar:
het is niet een algemeen probleem in de driver, want mijn laptop heeft een ATI grafische kaart en die doet het prima.
en ook niet helemaal algemeen, mijn PC en laptop hebben een Athlon X2 en AMD-ATI chipsets, en ik heb nergens last mee.
maar ik heb wel 10.04.


ADSL? nee, neem ADHD, dat is pas snel!

Offline DaPale

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #8 Gepost op: 2010/05/04, 10:03:47 »
Ik heb ook een probleem met mijn laptop voorzien van een ATI 4500 serie kaart in combinatie met Ubuntu 10.4.
Fast User Switch werkt niet goed omdat ik bij het wisselen vaak een zwartscherm krijg. Vooral wanneer ik de restricted drivers van AMD gebruik.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #9 Gepost op: 2010/05/04, 10:08:26 »
Mijn Lap heeft de Radeon xpress 1100 van ATI en lucid gaat uitstekend daarmee.
Asus X51series.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Offline JvH

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #10 Gepost op: 2010/05/04, 17:05:56 »
Mijn Radeon HD4870 werkt ook goed met Lucid. Zelfs met de open source driver heb ik nu desktop effects. Voor 3D-accelleratie in spellen heb ik nog wel de closed source driver nodig, maar die lijkt ook goed te werken.

Offline Alphyton

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #11 Gepost op: 2010/05/17, 19:47:19 »
Wel jammer dat dit zo moet gaan bij de update, ik heb er volgende keer weinig zin meer in  :|
~ Alles hat ein Ende, nur die Wurst hat zwei. ~

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #12 Gepost op: 2010/05/17, 20:25:36 »
Bij een upgrade van 9.10 naar 10.04 kan er een en ander misgaan als er al dan niet een driver geïnstalleerd werd in 9.10

Een driver die moet geïnstalleerd worden word weergegeven via Systeem>Beheer>Stuurprogramma's
Als daar geen driver vermeld word hoef je geen driver te installeren. Alles zou zo moeten werken.
Dus niet zomaar een driver installeren.

Doe eens een verse install met 10.04. Dan kan je zien of het aan de upgrade ligt of het toch nog iets anders is wat dit veroorzaakt.

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #13 Gepost op: 2010/05/17, 20:32:39 »
Sinds ik ubuntu 10.4 heb reageert ubuntu zeer traag. Op 9.10 was dat niet. Heel waarschijnlijk ligt dat aan de video kaart. Ik heb geprobeerd drivers te installeren, maar dat werkt niet. Het gaat hier om een ATI Radeon X1300. Weten jullie hoe ik deze kan installeren?


Als die driver van 9.10 goed werkte dan installeer hem toch in 10.04.

Als je nog een 9.10 installatie hebt staat die in: /var/cache/apt/archives.
Verwijder eerst met Synaptic de 10.04 driver en installer dan de 9.10 driver uit de archives. En zet hem daarna met Synaptic op "pinned".
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Emil

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #14 Gepost op: 2010/05/17, 21:21:54 »
Sinds ik ubuntu 10.4 heb reageert ubuntu zeer traag. Op 9.10 was dat niet. Heel waarschijnlijk ligt dat aan de video kaart. Ik heb geprobeerd drivers te installeren, maar dat werkt niet. Het gaat hier om een ATI Radeon X1300. Weten jullie hoe ik deze kan installeren?


Als die driver van 9.10 goed werkte dan installeer hem toch in 10.04.

Als je nog een 9.10 installatie hebt staat die in: /var/cache/apt/archives.
Verwijder eerst met Synaptic de 10.04 driver en installer dan de 9.10 driver uit de archives. En zet hem daarna met Synaptic op "pinned".
Je kunt geen oude drivers met een nieuwe kernel en een nieuwe Xorg server gebruiken. Oude drivers met Ubuntu 10.04 is dus onmogelijk.

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #15 Gepost op: 2010/05/17, 21:48:29 »

Je kunt geen oude drivers met een nieuwe kernel en een nieuwe Xorg server gebruiken. Oude drivers met Ubuntu 10.04 is dus onmogelijk.

U dwaalt ! De xorg-xserver-video-xxxx drivers hebben niets te maken met de kernel, absoluut niets, nada.

Om 10.04 draaiende te krijgen heb ik zelfs experimentele drivers gebruikt van xorg.org. En op dit ogenblik een aangepaste .i915 driver, die overigens perfect werkt.

Om in 9.10 hibernate/suspend aan de gang te krijgen heb ik een driver "geleend" van Debian Lenny.

In Linux is bijna alles mogelijk  =D
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Emil

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #16 Gepost op: 2010/05/18, 15:34:53 »
Ik doelde meer op de binairy driver van ATi, die moeten elke keer aangepast worden voor een nieuwere kernel en de oudere versies zullen niet op een nieuwere kernel werken.

Maar ook voor de xorg-xserver-video-xxxx drivers heb je een nieuwere kernel of een nieuwere kernel module (een deel van de kernel dat je apart kunt compileren/installeren en laden zodat je niet voor elke driver update een nieuwe kernel nodig hebt) nodig.

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #17 Gepost op: 2010/05/18, 15:53:06 »

Maar ook voor de xorg-xserver-video-xxxx drivers heb je een nieuwere kernel of een nieuwere kernel module (een deel van de kernel dat je apart kunt compileren/installeren en laden zodat je niet voor elke driver update een nieuwe kernel nodig hebt) nodig.

Wat je daar schrijft is doodgewoon niet juist  ??? Je kan zonder meer een xserver-xorg-video-xxxx driver verwijderen en een andere installeren zonder aan de kernel te komen of wat voor kernelmodule ook.

Dat heb ik nu wel tientallen keren gedaan om de 845/855GME drivers draaiende te krijgen. Het enigste wat eventueel moet gebeuren is een update van initramfs.

Op een bepaald ogenblik had ik op mijn testmachine zelfs tien kernels staat uit de series 2.6.26, 2.6.31, 2.6.32, 2.6.33, 2.6.34RC6
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Emil

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #18 Gepost op: 2010/05/18, 17:44:26 »
Hoe het precies in elkaar zit met videodrivers weet ik ook niet meer, want die zitten voor het grootste deel niet in de kernel maar in X zelf.

Ik heb in ieder geval al verschillende keren een nieuwe kernel moeten installeren (of een kernel module moeten compileren) om nieuwere video drivers te kunnen installeren. Ook moeten de binairy drivers voor elke kernel aangepast worden.

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #19 Gepost op: 2010/05/19, 12:08:50 »
Aah blijkbaar zijn er dus meer mensen met dit probleem. Ben de laatste dagen al op zoek geweest naar oplossingen maar tot nu toe nog geen resultaat.

Ik heb hierover al een aantal topics geopend maar tot nu toe niemand met het verlossende antwoord. Hieronder de 2 links naar mijn topics:

http://forum.ubuntu-nl.org/hardware-en-drivers/problemen-om-fglrx-te-installeren
http://forum.ubuntu-nl.org/hardware-en-drivers/fglrx-kan-niet-worden-ingeschakeld

Mocht je nog een mogelijk oplossing weten laat het dan weten. Op dit moment wil ik allereerst het volgende proberen.

1. Closed-source driver verwijderen
2. Open-source verwijderen
3. Alle config files enz verwijderen zodat ik een met schone lei begin
4. De open-source driver installeren

Mochten de opensource driver werken dan kan ik altijd nog uitbreiden naar closed-source.

Kan iemand mij met bovenstaande punten helpen?

Edit:

Mijn setup:

Mobo: GA-EX58-UD4P
Video kaart: Sapphire Radeon 4870 1 GB
Processor: Intel Core I7 920
« Laatst bewerkt op: 2010/05/19, 12:13:43 door Regeditor22 »

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #20 Gepost op: 2010/05/21, 00:17:56 »
Anyone??

Offline Emil

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #21 Gepost op: 2010/05/21, 16:53:16 »
Welke open source drivers installeer je?

Toen ik upgrade van 9.10 naar 10.04 werkten mijn grafische effecten niet meer, uiteindelijk heb ik het kunnen oplossen door alle drivers te deïnstalleren (xserver-xorg-video-radeon, xserver-xorg-video-radeonhd en xserver-xorg-video-ati) en daarna xserver-xorg-video-ati te installeren.
Wel een erg bizarre oplossing, want xserver-xorg-video-ati installeert gewoon xserver-xorg-video-radeon en verwijst daar dan naar.

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
[Opgelost] Re: Ubuntu 10.4 en ati
« Reactie #22 Gepost op: 2010/05/21, 22:35:38 »
Exact, deze oplossing wil ik dus ook proberen. Alleen ik weet dus niet hoe ik alle drivers moet deïnstalleren en daarna een open-source installeren.

Welke open source driver ik wil installeren? Ik wist eigenlijk niet dat er meerdere waren, alleen ATI geeft open source drivers uit toch? Als ik kijk naar welke driver bij jou gewerkt heeft dan ga ik voor xsever-xorg-video-ati.

Maar ik weet dus niet met welke commands ik die andere kan verwijderen en alleen xsever-xorg-video-ati kan installeren. Weet jij hoe dit moet?

EDIT: Heb via Synaptic alle drivers verwijderd, PC gereboot, fglrx geinstalleerd, nogmaals een reboot en hoppa het werkt weer!!!

Bedankt voor je hulp!
« Laatst bewerkt op: 2010/05/21, 23:29:39 door Regeditor22 »

Offline Tjibba

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #23 Gepost op: 2010/05/22, 12:03:59 »
Ik heb het probleem met een ATI x1950gt

Met desktop effects aan, blijft het systeem om de paar seconden even hangen. D.w.z. Slepen met vensters of scrollen op een pagina.
De muis blijft wel gewoon werken.

Gister de hele dag bezig geweest om het aan de praat te krijgen maar het zit er gewoon niet in schijnbaar :'(

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.4 en ati
« Reactie #24 Gepost op: 2010/05/22, 13:06:22 »
Ik weet niet precies wat die videokaart "aan kan" als die normaal werkt. Wat ik dus gedaan heb is het volgende. Via Synaptic heb ik alle mogelijk drivers volledig verwijderd, alleen fglrx geinstalleerd tweemaal een reboot en het werkte. In stappen dus het volgende:

1. Verwijder via Synaptic alles van "xserver-xorg-video-radeon", "xserver-xorg-video-radeonhd", "xserver-xorg-video-ati" en "fglrx"
2. Reboot je systeem, ik kreeg een foutmelding dat er geen drivers geinstalleerd waren (dûh), je kunt dan verder gaan in grafisch veilige modus.
3. Installeer via Synaptic alleen "fglrx" (als dit goed gaat dan vind die dit als stuurprogramma via Systeem => Beheer => Stuurprogramma's. Hij geeft dan aan dat het "niet vrije stuurprogramma" wel ingeschakeld is maar niet in gebruik. (vreemd maar waar)
4. Reboot je systeem nogmaals en alles liep weer als een zonnetje!

Succes!