Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Ubuntu 10.04 i.c.m. fglrx  (gelezen 2615 keer)

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
[Opgelost] Ubuntu 10.04 i.c.m. fglrx
« Gepost op: 2010/05/02, 14:15:38 »
Hallo beste mensen,

Ik heb het volgende probleem. Als Ubuntu boot dan geeft die direct een foutmelding die er als volgt uitziet:

(EE) Unable to initialize PCS database
(EE) Missing PCS defaults file (etc/ati/amdpcsdb.default)
(EE) No devices detected

Vervolgens kreeg ik een scherm met een aantal opties, o.a. dat Ubuntu alleen kan draaien in low-graphics. Ga ik daarna naar Synaptic pakketbeheer dan geeft die aan dat er 2 pakketten gebroken zijn en dat ik deze kan vinden met de filter "Gebroken". Volgens de foutmelding houd dit in dat er 1 of meerdere pakketten niet kunnen werken omdat ze afhankelijk zijn van andere (niet geïnstalleerde) pakketten.

Nu heb ik al het één en ander opgezocht en blijkbaar heb ik de fglrx driver niet geïnstalleerd. Dus in Synaptic fglrx intikken, markeren en installeren. Echter dan krijg ik de volgende foutmelding:

"E: /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb: subproces nieuw pre-installation script gaf een foutwaarde 1 terug"

Als ik in de terminal kijk, dan ziet het er zo uit:



(Zo dat ziet er beter uit..  ;))

Er zijn best wel veel mensen die problemen hiermee hebben, o.a. op een engelstalig forum vond ik het volgende draadje:

http://ubuntuforums.org/showthread.php?t=1012957&page=2

Maar de oplossing die daarin genoemd wordt (drivers verwijderen, mappen verwijderen, alles weer opnieuw aanmaken en installeren) werkt bij mij niet.

Kunnen jullie me hiermee helpen, alvast bedankt!
« Laatst bewerkt op: 2010/05/22, 12:59:19 door Regeditor22 »

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Problemen om fglrx te installeren
« Reactie #1 Gepost op: 2010/05/02, 22:46:15 »
Ik had het zelfde probleem en vond dit, wat tevens bij mij de oplossing was.
Je moet even omlaag scrollen naar het stappenplan van MrStark.
Stap 3 en stap 5 heb ik niet uitgevoerd, na een reboot werkt alles.

http://ubuntuforums.org/showthread.php?t=1466085&page=2

There are only 10 types of people in the world; those who understand binary and those who don't.

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Problemen om fglrx te installeren
« Reactie #2 Gepost op: 2010/05/02, 23:35:24 »
Thanks, dat werkt voor mij ook. Nu krijg ik geen foutmeldingen meer, alleen heb ik nog niet uitgevonden hoe ik mijn desktop resolutie kan veranderen. Deze staat nu erg laag ingesteld, heb meer de voorkeur voor een hoge resolutie.

EDIT: Aanpassen van de resolutie is al gelukt, stond laag ingesteld omdat ik nog een TV met bepaalde beperkingen verbonden heb. Deze disabled en hoppa de resolutie naar 1600 x 1200.

Nu zit ik echter met een ander probleem, namelijk dat het beeld erg hakkerig gaat. De videokaart of processor lijkt het allemaal niet te kunnen bolwerken aangezien ik een Intel i7 920 heb, met Sapphire Radeon 4870, 1 GB kaart. Voor het simpel tonen van een desktop en een btje wild schuiven met schermen mag dat geen probleem zijn.

Staat mijn configuratie verkeerd of moet ik mis nog bepaalde pakketten?
« Laatst bewerkt op: 2010/05/02, 23:55:24 door Regeditor22 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Problemen om fglrx te installeren
« Reactie #3 Gepost op: 2010/05/03, 20:39:36 »
Word er in Systeem>Beheer>Stuurprogramma's een driver voorgesteld?

En hier een progje om je resolutie van je scherm en andere schermen in te stellen. Werkt met intel en ati.

http://projects.dvdmeer.nl/python-randr/
(dvdmeer is één van de forumleden)

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Problemen om fglrx te installeren
« Reactie #4 Gepost op: 2010/05/03, 22:01:37 »
Word er in Systeem>Beheer>Stuurprogramma's een driver voorgesteld?

En hier een progje om je resolutie van je scherm en andere schermen in te stellen. Werkt met intel en ati.

http://projects.dvdmeer.nl/python-randr/
(dvdmeer is één van de forumleden)

Ja er wordt aangegeven dat er een "niet vrije" driver is gevonden namelijk FGLRX en dat deze is ingeschakeld. Dus dat werkt als het goed is..

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Problemen om fglrx te installeren
« Reactie #5 Gepost op: 2010/05/05, 00:41:55 »
Even een kick want volgens mij ben ik zelf een stap verder gekomen met dit probleem. Als ik namelijk

fglrxinfo
intyp in de terminal dan geeft die de volgende output:



Schijnbaar komen er veel meer problemen voor met ATI drivers als er een upgrade van Ubuntu plaats vind, getuige de vele topics. Ik kan eigenlijk voor dit probleem 2 mogelijk oorzaken vinden, namelijk een verkeerde kernel (module?). Deze zou dan niet goed werken i.c.m. de fglrx driver. De tweede mogelijkheid is dat er "iets" in de cionfiguratie bestanden niet goed staat.

Wat me ook opviel is dat Catalyst Control Center dubbel te zien is via Systeem => Voorkeuren. Zowel de normale als de beheer versie, in totaal staat die er dus 4 keer.

Hebben jullie een idee hoe ik de driver goed werkend kan krijgen?

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 i.c.m. fglrx
« Reactie #6 Gepost op: 2010/05/05, 10:45:51 »
Ik weet niet of je hier wat aan hebt. Je zou kunnen proberen de fglrx-kernel-source er bij te zetten.
Geen idee of dat nut heeft, maar dat is in ieder geval een verschil met mijn installatie.


inaninck@LT9:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 4300 Series
OpenGL version string: 3.2.9756 Compatibility Profile Context

inaninck@LT9:~$ dpkg -l | grep fglrx
ii  fglrx                                      2:8.723.1-0ubuntu3                                   Video driver for the ATI graphics accelerato
ii  fglrx-amdcccle                             2:8.723.1-0ubuntu3                                   Catalyst Control Center for the ATI graphics
ii  fglrx-dev                                  2:8.723.1-0ubuntu3                                   Video driver for the ATI graphics accelerato
ii  fglrx-kernel-source                        2:8.723.1-0ubuntu3                                   Transitional package for fglrx-kernel-source
ii  fglrx-modaliases                           2:8.723.1-0ubuntu3                                   Identifiers supported by the ATI graphics dr
ii  xorg-driver-fglrx                          2:8.723.1-0ubuntu3                                   Transitional package for xorg-driver-fglrx
inaninck@LT9:~$

inaninck@LT9:~$ lspci
01:00.0 VGA compatible controller: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series]

« Laatst bewerkt op: 2010/05/05, 10:49:11 door ivo »
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu 10.04 i.c.m. fglrx
« Reactie #7 Gepost op: 2010/05/05, 11:42:54 »
Schakel de visuele effecten eens uit:
http://sites.google.com/site/computertip/geenbeeld#TOC-Slecht-beeld

Zou eigenlijk niet nodig moeten zijn, maar voorlopig kun je dan vooruit, tot er updates komen....

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 i.c.m. fglrx
« Reactie #8 Gepost op: 2010/05/05, 13:02:31 »
fglrx kernel source geïnstalleerd. ==> Geen resultaat

Visuele effecten staan al uitgeschakeld!  ;)

Nog andere opties?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 i.c.m. fglrx
« Reactie #9 Gepost op: 2010/05/21, 15:36:29 »
Visuele effecten staan al uitgeschakeld!  ;)

Om zeker te zijn:
Zijn ze zeker uit geschakeld? Ik heb een ati en als ik compiz gebruik dan staat geen enkel van de keuzes aangeduid. Dus staat naast 'Geen' een zwart puntje in het witte cirkeltje?
Staat er geen aangeduid dan zijn de visuele effecten nog altijd aan.

Offline Regeditor22

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 i.c.m. fglrx
« Reactie #10 Gepost op: 2010/05/22, 12:58:42 »
Het probleem is ondertussen opgelost door via Synaptic alle mogelijke drivers volledig te verwijderen en daarna alleen fglrx te installeren!

Zie: http://forum.ubuntu-nl.org/hardware-en-drivers/ubuntu-10-4-en-ati/15/
« Laatst bewerkt op: 2010/05/22, 13:08:10 door Regeditor22 »