Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: computer sluit niet af  (gelezen 7703 keer)

Offline heian

  • Lid
  • Steunpunt: Nee
computer sluit niet af
« Gepost op: 2010/05/01, 22:15:02 »
Hoi,
Het volgende probleem:
Mijn computer blijft hangen tijdens het afsluiten, kan
alleen maar met de hand worden uitgeschakelt.

Hier wat gegevens:

Ubuntu 10.04  LTS 
HP Pavilion T3000 
moederbord:    MS 6577  ver 4.1

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=bph07843

AwardBIOS  core version V6.0
Bios revision 3.24    03/09/2005

bios is erg gelimiteerd, bij power staan (maar) twee opties mbt power failure en wol in S4.
via microstar geprobeerd het bios te updaten, maar dat gaat niet.

Er is niets in het bios te vinden over APM  of ACPI

Is er toch nog een mannier om de pc goed af te sluiten?

Bij voorbaat mijn dank,

heian

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: computer sluit niet af
« Reactie #1 Gepost op: 2010/05/02, 00:36:00 »
Type eens in een terminalscherm:
sudo shutdown now
en voer je password in, gaat hij nu wel uit ?
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #2 Gepost op: 2010/05/02, 02:26:51 »
sudo shutdown now geprobeerd: ubuntu met de rode balletjes blijven
op het scherm en pc sluit niet af

Offline Suns

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #3 Gepost op: 2010/05/02, 08:19:20 »
sudo shutdown now geprobeerd: ubuntu met de rode balletjes blijven
op het scherm en pc sluit niet af

bij mij deed die precies het zelfde "sudo shutdown now "heeft bij mij ook niks geholpen ik heb toen sudo reboot gedaan en naar het opstarten kon ik hem wel afsluiten.

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #4 Gepost op: 2010/05/02, 09:42:20 »
sudo reboot  zorgt bij mij alleen voor een reboot.
na het opstarten probeer ik op de gewone mannier af te sluiten,
maar de pc sluit zichzelf niet af. Ubuntu logo op het scherm blijft staan

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #5 Gepost op: 2010/05/02, 10:02:14 »
Ik heb ooit dit gevonden:

Citaat
Automatisch power-off:

Bij oudere systemen wil het nog wel eens gebeuren dat na afsluiten van het systeem de computer toch niet automatisch uitschakelt.

Dit is een probleem dat zich soms moeilijk laat oplossen. Probeer in elk geval    onderstaande oplossingen en lees de handleiding van je computer waar het gaat over BIOS-instellingen voor Power Management.

Plaats in het bestand /etc/modules de volgende regel: apm power_off=1

Als je grub gebruikt als bootloader dan kan je ook de volgende regel toevoegen aan de betreffende regel in /boot/grub/menu.lst:

   apm=power_off

ps. Achter deze regel toevoegen, wel eerst een spatie, zo dus:

   title Ubuntu 9.04, kernel 2.6.28-11-generic apm=power_off

Misschien heb jij er iets aan.  :D
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #6 Gepost op: 2010/05/02, 10:57:56 »
Bedankt voor alle reacties zo ver,

In het bestand   /etc/modules de volgende regel: apm power_off=1  toegevoegd, maar dit
had geen resultaat bij het afsluiten. (ook niet na enkele keren afsluiten)

Het bestand  /boot/grub menu.lst   is niet aanwezig in die map. (misschien niet omdat er een
volledige installatie op een schone schijf gedaan is?)

Het bios is zeer beperkt, staat niets over apm of acpi. Ook niet in de manual van het moederbord.
Via msi geprobeerd het bios te updaten, werd zonder melding afgesloten.

(Het bios is zeer waarschijnlijk overwrite protected)
« Laatst bewerkt op: 2010/05/02, 11:43:09 door heian »

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: computer sluit niet af
« Reactie #7 Gepost op: 2010/05/02, 11:06:55 »
Het bestand  /boot/grub menu.lst   is niet aanwezig in die map.
Dat moet zijn /boot/grub/menu.lst
Wanneer je die file heb, kan je ook proberen om aan de opstart regel het volgende toe te voegen:
acpi=force
Dit heeft mij ooit geholpen op een oude P3.
Dit werkte goed tot 9.04, hoe het met latere versies moet, heb ik helaas geen ervaring mee.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #8 Gepost op: 2010/05/02, 11:41:36 »
Dat moet zijn /boot/grub/menu.lst

Idd, ik had het verkeerd getypt.  Maar het gekke is dat dat er geen
menu.lst staat in de directory grub.  Ook al control-h gebruikt, maar het
is er gewoon niet.
sudo gedit /boot/grub/menu.lst geeft ook een lege (nieuwe) file aan.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: computer sluit niet af
« Reactie #9 Gepost op: 2010/05/02, 12:49:26 »
Dan denk ik, dat je de file /etc/default/grub moet hebben, je zult ff moeten zoeken naar aanpassingen.
Hierna zal je in een terminalscherm wel sudo update-grub moeten geven om te wijzigingen door te voeren.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #10 Gepost op: 2010/05/02, 13:16:13 »
Hier een uitdraai van de aangepaste /etc/default/grub  file

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
acpi=force
apm power_off=1

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


sudo update-grub  geeft:  /etc/default/grub: 12: apm: not found

is er nog iets dat we kunnen proberen?

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #11 Gepost op: 2010/05/02, 13:21:27 »
Wat krijg je als je in de terminal ingeeft:

apmd
apmd is heden vervangen door acpi, is acpi wel geïnstalleerd?
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #12 Gepost op: 2010/05/02, 13:40:30 »
edit: in  etc/default/grub  apm power_off=1  verandert in  apm=power_off
updaten ging nu wel, maar hielp niets

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #13 Gepost op: 2010/05/02, 13:43:46 »
apmd geeft:

~$ apmd
The program 'apmd' is currently not installed.  You can install it by typing:
sudo apt-get install apmd
robby@mediaPC:~$
ik ga het installeren en testen of ie goed afsluit

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #14 Gepost op: 2010/05/02, 13:55:32 »
apmd en acpi geinstalleerd, maar het afsluiten gaat nog niet goed

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #15 Gepost op: 2010/05/02, 14:26:17 »
Wanneer je die file heb, kan je ook proberen om aan de opstart regel het volgende toe te voegen:
acpi=force
Dit heeft mij ooit geholpen op een oude P3.
Dit werkte goed tot 9.04, hoe het met latere versies moet, heb ik helaas geen ervaring mee.

Ron, dank je, dit heeft mij geholpen op mijn 9.04 servertje (1999 BIOS, cut-off is 2000). Ik heb er een hele tijd geleden naar gezocht. Vond het vooral vreemd dat FreeBSD (FreeNAS) dezelfde machine wel helemaal kon afsluiten.
In 9.04 ging de harddisk wel uit, maar de fan en moederbord bleven aan. Na acpi=force toevoegen sluit 'ie helemaal af. Tenks.

@heian
Ik weet het niet helemaal zeker, maar aangezien je toch vanalles aan het proberen bent: in je /etc/default/grub bestand moet je de opties niet 'los' invoegen maar tussen de quotes in de regel GRUB_CMDLINE_LINUX="" of achter GRUB_CMDLINE_LINUX_DEFAULT="quiet splash".
Ik vermoed dat update-grub die parameters achter de kernel regel zet.
Ofwel (bijvoorbeeld): GRUB_CMDLINE_LINUX="acpi=force"
Je kan controleren wat 'ie ervan maakt door /boot/grub/grub.cfg te bekijken, dat is het bestand dat grub2 uiteindelijk gebruikt.
« Laatst bewerkt op: 2010/05/02, 14:29:40 door Wiley »

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #16 Gepost op: 2010/05/02, 17:02:51 »
ik heb alle twee de opties geprobeerd, acpi=force  en  amp=power_off

het enige verschil was dat bij acpi=force er een heleboel tekst op het scherm
kwam, met als laatste:  will now halt

Dit is mijn grub.cfg file:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=69f51c81-65d5-4118-88e9-1ade27020397 ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-21-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-21-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
   echo   'Loading Linux 2.6.32-21-generic ...'
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=69f51c81-65d5-4118-88e9-1ade27020397 ro single
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 69f51c81-65d5-4118-88e9-1ade27020397
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ ${timeout} != -1 ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

Het is een test pc, dus kan wat stoeien hiermee  =D

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #17 Gepost op: 2010/05/02, 17:12:41 »
Je grub.cfg laat geen optie 'acpi=force' zien. Heb je na het toevoegen wel update-grub gedaan of is dit de cfg nadat je alles weer weggehaald hebt?
Wat was de strekking van die tekst? Iets over ACPI?

Probeer acpi=force anders eens zo (of bedoelde je dat met 'allebei de opties'):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #18 Gepost op: 2010/05/02, 18:35:38 »
ik had zowel acpi=force  en apm=power_off,
een voor een in GRUB_CMDLINE_LINUX=""  
en  achter GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" gezet
(dus vier keer gedaan, en grub geupdate via de terminal)
daarna alles weer origineel gemaakt en de grub.cfg geplaatst.
Het gaf geen resultaat.

Okies, ik probeer het nog een keer, na een nieuwe schone install.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"  verandert
grub geupdate

hier de grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=8a0b169c-f761-4f3c-9e64-e8cf3a9cd572 ro   quiet splash acpi=force
   initrd   /boot/initrd.img-2.6.32-21-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-21-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
   echo   'Loading Linux 2.6.32-21-generic ...'
   linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=8a0b169c-f761-4f3c-9e64-e8cf3a9cd572 ro single
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 8a0b169c-f761-4f3c-9e64-e8cf3a9cd572
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ ${timeout} != -1 ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

Het ziet er indrukwekkend uit, maar dit gaat me ver boven mijn pet  :rolleyes:
« Laatst bewerkt op: 2010/05/02, 18:37:11 door heian »

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #19 Gepost op: 2010/05/02, 20:56:53 »
het ging mij om deze regel:
linux   /boot/vmlinuz-2.6.32-21-generic root=UUID=8a0b169c-f761-4f3c-9e64-e8cf3a9cd572 ro   quiet splash acpi=forcemaar die klopt nu dus. Als het toch niet helpt (laatste suggestie: acpi èn apm toevoegen) dan ben ik ook überfragt, sorry.

Offline heian

  • Lid
  • Steunpunt: Nee
Re: computer sluit niet af
« Reactie #20 Gepost op: 2010/05/03, 18:37:49 »
Hoi,

Heb de laatste suggestie ook nog geprobeerd, maar ook zonder resultaat.

Vermoedelijk ondersteunt het moederbord het niet, of is het een door HP
dichtgetimmerd bios, non-overwriteable. We hebben ons best gedaan. 

Iedereen hartelijk dank voor de hulp!

heian