Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]na upgrade 9.10->10.04 boot in console  (gelezen 4811 keer)

Offline wova

  • Lid
  • Steunpunt: Nee
[OPGELOST]na upgrade 9.10->10.04 boot in console
« Gepost op: 2010/04/30, 11:49:35 »
nadat gisteren m'n ubuntu was herstart tijdens de installatie van een programma, werkte het niet meer.
ik heb dan via de console de upgrade kunnen doen naar 10.04, wat gelukt. toen had ik een probleem met de fglrx driver, is ondertussen ook opgelost!
Het enige probleem is nu dat als ik boot, ik het paarse scherm van ubuntu te zien krijg en dan laden de vierkantjes zo en dan verspringt die naar de console en vraagt die om username enz..
Hoe kan ik ervoor zorgen dat die terug normaal boot met loginscreen?

bedankt voor de hulp!

:)
« Laatst bewerkt op: 2010/05/13, 11:57:09 door wova »

Offline kloempe

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #1 Gepost op: 2010/04/30, 12:01:13 »
je kunt beter 10.04 downloaden en installeren.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #2 Gepost op: 2010/04/30, 12:49:19 »
Het lijkt mij niet nodig om direct met een herinstallatie te beginnen. Als je alleen een terminal/tty sieht, dan kan dat aan een onbruikbare configuratie/driver voor je xserver liggen.
Je had een probleem met je fglrx driver - hoe kan dat "opgelost" zijn als je niet meer normaal kan inloggen?

Misschien helpt het ook anderen als je "het probleem" en je "oplossing" hier omschrijft. Een paar details over je systeem zijn overigens ook zinvol, anders moet iemand zijn glazen bol van zolder halen om je te kunnen helpen.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #3 Gepost op: 2010/04/30, 13:01:41 »
Het lijkt mij niet nodig om direct met een herinstallatie te beginnen. Als je alleen een terminal/tty sieht, dan kan dat aan een onbruikbare configuratie/driver voor je xserver liggen.
Je had een probleem met je fglrx driver - hoe kan dat "opgelost" zijn als je niet meer normaal kan inloggen?

Misschien helpt het ook anderen als je "het probleem" en je "oplossing" hier omschrijft. Een paar details over je systeem zijn overigens ook zinvol, anders moet iemand zijn glazen bol van zolder halen om je te kunnen helpen.

het probleem met mijn fglrx driver was er omdat ik de ati driver had geïnstalleerd in 9.10 maar door de upgrade naar 10.04 werd die onbruikbaar. dit was een bug in 10.04. op internet heb ik uitleg gevonden voor  de driver te verwijderen en opnieuw te installeren.

en het is ubuntu 10.04 64bit en radeon 3xxx reeks
welke informatie moet je nog hebben?

Offline kloempe

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #4 Gepost op: 2010/04/30, 13:18:25 »
Het lijkt mij niet nodig om direct met een herinstallatie te beginnen. Als je alleen een terminal/tty sieht, dan kan dat aan een onbruikbare configuratie/driver voor je xserver liggen.
Je had een probleem met je fglrx driver - hoe kan dat "opgelost" zijn als je niet meer normaal kan inloggen?

Misschien helpt het ook anderen als je "het probleem" en je "oplossing" hier omschrijft. Een paar details over je systeem zijn overigens ook zinvol, anders moet iemand zijn glazen bol van zolder halen om je te kunnen helpen.

Een herinstallatie duurt maar 20 minuten bij mij.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #5 Gepost op: 2010/04/30, 13:57:46 »
Ik heb nvidia en kan dus niet veel verder helpen, maar hier staat e.e.a.
Volgens mij moet helemaal geen driver geïnstalleerd worden.
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get purge xorg-driver-fglrx fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx-dev
sudo apt-get --reinstall install libgl1-mesa-glx xserver-xorg-core
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #6 Gepost op: 2010/04/30, 14:13:55 »
Ik heb nvidia en kan dus niet veel verder helpen, maar hier staat e.e.a.
Volgens mij moet helemaal geen driver geïnstalleerd worden.
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get purge xorg-driver-fglrx fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx-dev
sudo apt-get --reinstall install libgl1-mesa-glx xserver-xorg-core

heb dit gedaan maar helaas verandert dit er niets aan... zou het misschien kunnen dat ubuntu ingesteld staat om de console op te starten ?
en hoe verander ik dit?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #7 Gepost op: 2010/04/30, 16:38:35 »
Log gewoon in met je gebruikersnaam en dan zal je wachtwoord gevraagd worden. Je zal niets zien, ook geen sterretjes.
Dan zal je de prompt zien. gebruikersnaam@computernaam:~$
Hier tik je in: startx
Nu zou de grafische schil moeten opstarten.
Herstart dan eens vanuit de grafische omgeving. Nu zou alles terug goed moeten zijn.

Laat iets weten of dit gelukt is.

Met vriendelijke groet,
heir4c

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #8 Gepost op: 2010/04/30, 17:32:02 »
Log gewoon in met je gebruikersnaam en dan zal je wachtwoord gevraagd worden. Je zal niets zien, ook geen sterretjes.
Dan zal je de prompt zien. gebruikersnaam@computernaam:~$
Hier tik je in: startx
Nu zou de grafische schil moeten opstarten.
Herstart dan eens vanuit de grafische omgeving. Nu zou alles terug goed moeten zijn.

Laat iets weten of dit gelukt is.

Met vriendelijke groet,
heir4c


dit had ik ook al gevonden via google. als ik dit doe krijg ik gewoon een grafisch terminalvenster... en daaronder een zwartscherm

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #9 Gepost op: 2010/04/30, 17:53:43 »
Start eens op in de recovery mode (tweede regel in het grubmenu) en kies in het menu dat je te zien krijgt de optie met de gebroken pakketten repareren. (zoiets in die zin, even uit het hoofd)
En daarna kies je de optie met het openen van een root-shell met internet aansluiting.
Tik daar in:
sudo apt-get update && sudo apt-get upgrade(vergeet die tweede keer sudo niet)

Wat zegt dat?

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #10 Gepost op: 2010/04/30, 18:03:40 »
Start eens op in de recovery mode (tweede regel in het grubmenu) en kies in het menu dat je te zien krijgt de optie met de gebroken pakketten repareren. (zoiets in die zin, even uit het hoofd)
En daarna kies je de optie met het openen van een root-shell met internet aansluiting.
Tik daar in:
sudo apt-get update && sudo apt-get upgrade(vergeet die tweede keer sudo niet)

Wat zegt dat?


heb dit al verschillende malen geprobeerd en telkens opnieuw hetzelfde. 0 pakketten geinstalleerd, 0 opgewaardeerd, ...
en bij gebroken pakketten wordt er geen foutmelding weergeven, voor zover ik zie

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #11 Gepost op: 2010/04/30, 18:23:09 »
Probeer via de rootshell met internet het volgende:
apt-get install ubuntu-desktop
En hier nog een linkje naar iets dat ik net gevonden heb, weet niet of dit op jouw probleem van toepassing is maar je kan het altijd eens testen. Zie antwoord 2 van Cumulus007

(Ik zoek ook nog wat verder)

Edit: blijkbaar ben ik het linkje vergeten erbij te zetten en nu weet ik niet meer welk topic het is. mijn excuses)

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #12 Gepost op: 2010/04/30, 18:24:26 »
Hoe waren de beschikbare sources geregeld voor de upgrade? Er zijn namelijk pakketten die niet (meer) passen bij de laatste versie van Ubuntu. Die moeten dan vervangen worden door alternatieven.

Je schreef aan het begin dat je een programma ging installeren. Dat programma vereiste een herstart, hierna werkte het niet meer en je ging vanuit de console upgraden naar 10.04.

De volgende stappen kan je nog proberen:
1. verwijder het programma wat de oorzaak van de problemen was met de console
sudo apt-get remove probleempakketX2. hierna kan je proberen met de optie -f(ix) de installatie te repareren en kijken welke meldingen verschijnen
sudo apt-get install -f3. als je dan na een "startx" weer normaal kan inloggen, kan je de normale actualisatie uitvoeren of in een terminal typen
sudo apt-get update && sudo apt-get dist-upgrade
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #13 Gepost op: 2010/04/30, 18:30:17 »
Hoe waren de beschikbare sources geregeld voor de upgrade? Er zijn namelijk pakketten die niet (meer) passen bij de laatste versie van Ubuntu. Die moeten dan vervangen worden door alternatieven.

Je schreef aan het begin dat je een programma ging installeren. Dat programma vereiste een herstart, hierna werkte het niet meer en je ging vanuit de console upgraden naar 10.04.

De volgende stappen kan je nog proberen:
1. verwijder het programma wat de oorzaak van de problemen was met de console
sudo apt-get remove probleempakketX2. hierna kan je proberen met de optie -f(ix) de installatie te repareren en kijken welke meldingen verschijnen
sudo apt-get install -f3. als je dan na een "startx" weer normaal kan inloggen, kan je de normale actualisatie uitvoeren of in een terminal typen
sudo apt-get update && sudo apt-get dist-upgrade

nee, je hebt me verkeerd begrijpen in m'n openingspost, of ik ben te onduidelijk geweest!  =D

ik was programma aan het installeren, en plots herstart m'n laptop vanzelf en vanaf toen is het misgelopen!

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #14 Gepost op: 2010/05/03, 12:35:10 »
na nog lang vanalles geprobeerd te hebben, toch maar besloten voor een nieuwe installatie.
nu werkt bijna alles zoals het hoort..

alleen heb ik nog een klein vraagje: ik heb wat eye candy dinge opstaan, maar als ik venster wil minimaliseren of maximaliseren blijft dit seconde of 3 hangen
(het beeld bevriest eventjes en dan doet hij het pas)
maw het gaat niet vlot zoals ik het graag zou willen.

nieuwste ati driver geinstalleerd
ati radeon hd 3650 256mb
4gb ram
intel core 2 duo p8600

mijn laptop zou toch krachtig genoeg moeten zijn voor dit vlot te doen, niet?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #15 Gepost op: 2010/05/03, 18:56:37 »
Hoe staan de visuele effecten? Op 'Geen', 'Normaal' of 'Extra'? (rechts klikken op bureaublad en kiezen voor: Werkbladachtergrond wijzigen (onderaan), dan tabblad: Visuele effecten)

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #16 Gepost op: 2010/05/05, 21:01:56 »
Hoe staan de visuele effecten? Op 'Geen', 'Normaal' of 'Extra'? (rechts klikken op bureaublad en kiezen voor: Werkbladachtergrond wijzigen (onderaan), dan tabblad: Visuele effecten)

op geen enkel van de 3. Ik heb namelijk zelf gekozen welke effecten ik wil en niet wil met compiz. En 1 van die effecten is bijvoorbeeld als ik een venster mini/maximaliseer, het zo flubbert. Als ik nu echter op mini/maximaliseren klikken happert het even. ligt dit dan aan de driver of aan de pc? want mijn laptop lijkt me toch krachtig genoeg..?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #17 Gepost op: 2010/05/06, 18:05:16 »
Volgens een voorgaand bericht van HarzG moet je dus geen driver installeren want je kaart staat in de lijst waardoor het out of the box moet werken.
En dat het iets minder gaat hier en daar kan aan het iets minder samengaan van de driver en de kaart. Toch nog juist geen 100%. Misschien dat 'Wobbly' (of ander effect) eens uitzetten en nog eens testen. Ik weet het is een leuk iets maar als het niet gaat of het geeft wat storingen, tja, het blijft mensenwerk die hard- en software.
Het kan altijd aan je scherm (reactietijd) of PC liggen maar hij is krachtig genoeg.

Offline walterav

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #18 Gepost op: 2010/05/06, 19:02:09 »
alleen heb ik nog een klein vraagje: ik heb wat eye candy dinge opstaan, maar als ik venster wil minimaliseren of maximaliseren blijft dit seconde of 3 hangen
(het beeld bevriest eventjes en dan doet hij het pas)
maw het gaat niet vlot zoals ik het graag zou willen.

mijn laptop zou toch krachtig genoeg moeten zijn voor dit vlot te doen, niet?

Helaas is dit een BUG die al gemeld is, zodra je de ATI proprietary drivers installeerd is Compiz, dus enorm traag met het mini en maximaliseren van vensters. Helaas bestaat die BUG al een jaar.
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/568988
Ik heb ooit handmatig een ppa van XORG toegevoegd maar daar zaten weer memory leaks in. Op een dag zal ATI de HD2X en HD3X serie netals de vorige X1XXX serie ook uit de proprietary serie gooien en ben je aangewezen op de opensource driver. Hopelijk fixen ze het voor die tijd!

Als je niet gamed, en niet veel met OPENGL werkt, kan je waarschijnlijk prima de standaard drivers "sinds Ubuntu 10.04" gebruiken. Daar draait Compiz met effecten wel vloeiend in "ATI HD2600XT". Tevens mini en maximaliseren van vensters verloopt snel. En het afspelen van HD films gaat ook prima.
« Laatst bewerkt op: 2010/05/06, 19:15:26 door walterav »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #19 Gepost op: 2010/05/06, 19:49:16 »
Volgens een voorgaand bericht van HarzG moet je dus geen driver installeren want je kaart staat in de lijst waardoor het out of the box moet werken.
...
Dus wova, je hoeft normaal gezien geen driver te installeren voor je kaart, het zou dus oob moeten werken. Welke driver heb je geïnstalleerd en hoe? Via Systeem>Beheer>Stuurprogramma's of via... ??

Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #20 Gepost op: 2010/05/12, 16:41:58 »
Volgens een voorgaand bericht van HarzG moet je dus geen driver installeren want je kaart staat in de lijst waardoor het out of the box moet werken.
...
Dus wova, je hoeft normaal gezien geen driver te installeren voor je kaart, het zou dus oob moeten werken. Welke driver heb je geïnstalleerd en hoe? Via Systeem>Beheer>Stuurprogramma's of via... ??

euhm, via de website van ati heb ik die driver gedownload en geinstalleerd. Hoe verwijder ik die dan? want gamen doe ik niet op pc

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #21 Gepost op: 2010/05/12, 18:12:02 »
Als je die driver geactiveerd hebt via Systeem>Beheer>Stuurprogramma's kan je die daar weer afvinken en terug opstarten of Ctrl+Alt+Backspace doen om de Xserver te herstarten.
Zo kan je alles nog eens testen voor je die driver verwijderd.
Normaal gezien zou die in Synaptic terecht moeten gekomen zijn.
Zoeken op de naam van de driver die je gedownload hebt.


Offline wova

  • Lid
  • Steunpunt: Nee
Re: na upgrade 9.10->10.04 boot in console
« Reactie #22 Gepost op: 2010/05/12, 18:22:10 »
Als je die driver geactiveerd hebt via Systeem>Beheer>Stuurprogramma's kan je die daar weer afvinken en terug opstarten of Ctrl+Alt+Backspace doen om de Xserver te herstarten.
Zo kan je alles nog eens testen voor je die driver verwijderd.
Normaal gezien zou die in Synaptic terecht moeten gekomen zijn.
Zoeken op de naam van de driver die je gedownload hebt.



driver heb ik kunnen verwijderen. heb gevonden op de site van amd-ati hoe het moest. xserver opnieuw opgestart en compiz opnieuw geinstalleerd en alles werkt nu perfect!

bedankt allemaal