Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] "klikkend" geluid  (gelezen 1835 keer)

Offline bms230

  • Lid
  • Steunpunt: Nee
[opgelost] "klikkend" geluid
« Gepost op: 2010/04/30, 10:18:47 »
Beste allemaal,

Ik heb onlangs een netbook gekocht. De asus eee pc 1005p. Hierop heb ik ubuntu geïnstalleerd (10.04!!)
Het valt me op dat als de laptop niet op netstroom draait, deze af en toe een soort klikkend geluid maakt.
Eerst was ik bang dat het de harde schijf was. Aangezien dit geluid niet veroorzaakt wordt wanneer de netbook op het netstroom is aangesloten denk ik dat dit de stroomtoevoer is. Daarnaast werkt het command sudo hdparm -B 254 /dev/sda niet (lost de klik niet op) wat erop wijst dat het niet een parkeerklik is (dus iets met de harde schrijf) http://sites.google.com/site/computertip/fouten#TOC-Sommige-laptops:-parkeerklik-slijta
Dus toch de stroomvoorziening?
Kan iemand mij hierin bevestigen?

Alvast bedankt!

« Laatst bewerkt op: 2010/05/13, 21:47:24 door bms230 »

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #1 Gepost op: 2010/05/01, 11:02:51 »
Ik denk dat het de harde schijf is.

Kijk hier eens naar: http://sites.google.com/site/computertip/fouten#TOC-Sommige-laptops:-parkeerklik-slijta

Is weliswaar voor de acer, maar misschien helpt het ook bij jouw.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #2 Gepost op: 2010/05/01, 13:53:29 »
top, ik ben een stukje verder;
Met karmic werkte: udo hdparm -B 254 /dev/sda  niet (bleef klikken).
et 10.04 werkt het wel!! dus toch de harde schijf;

Nog een vraag:
In 9.10 schijn je de code te kunnen automatiseren, dit kan nog niet bij 10.04. Is deze fout al hersteld?

Alvast bedankt!!

Offline foxofinfinety

  • Lid
    • foxofinfinety
    • Foxofinfinety.com
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #3 Gepost op: 2010/05/01, 14:47:10 »
een cron job zou toch gewoon moeten werken met 10.04? of is de bug juist dat die niet werken?


ADSL? nee, neem ADHD, dat is pas snel!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #4 Gepost op: 2010/05/01, 15:07:43 »
Nog een vraag:
In 9.10 schijn je de code te kunnen automatiseren, dit kan nog niet bij 10.04. Is deze fout al hersteld?

Helaas nog niet....  :(

Help mee om de foutmelding te ondersteunen, des te eerder komt de reparatie:
https://bugs.launchpad.net/ubuntu/+source/hdparm/+bug/568120

Kan sowieso nog wel even duren, die reparatie. Want de ontwikkelaars hebben nu, vlak na de uitgifte van Lucid, de handen vol met het verhelpen van de gebruikelijke kinderziektes....
« Laatst bewerkt op: 2010/05/01, 15:12:06 door Pjotr »

Offline foxofinfinety

  • Lid
    • foxofinfinety
    • Foxofinfinety.com
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #5 Gepost op: 2010/05/01, 18:56:11 »
Ow was geen cron job.
maareh, zolang die bug er nog is, is een cron job dan een idee?
of via het standaard login of opstart script?


ADSL? nee, neem ADHD, dat is pas snel!

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: "klikkend" geluid
« Reactie #6 Gepost op: 2010/05/02, 18:14:21 »
Bedankt voor alle antwoorden!
Ik zat even te denken; Die klik treedt op als de computer (opnieuw) is opgestart of wanneer deze uit de slaapstand komt. Logischerwijs zou ik dan kiezen voor crontab (Opstartscript kan ook, maar dan zou ik de slaapstand moeten uitzetten.. en dan iets rommelen in /etc/rc.local. geen idee hoe ik die command toevoeg).

In Crontab zou t iets worden van:
crontab -e  optie 2 (nano)
(is nog leeg bij mij)
* * * * * /usr/bin/somedirectory  (??)/sudo hdparm -B 254 /dev/sda
Alleen lijkt mij dit wat overdreven omdat de command nu continu uitgevoerd zal worden. Er zal dus een opstartregel moeten komen en een regel als ie uit de slaapstand komt.

Klopt het was ik denk? En als het klopt zou iemand mij kunnen helpen met de juiste commands (zo ver ben ik nog niet in deze materie).

Naja het irritante getik ben ik tenminste kwijt!

Alvast ontzettend bedankt voor jullie hulp!

Groetjes,

bms230
« Laatst bewerkt op: 2010/05/03, 11:14:04 door bms230 »

Offline bms230

  • Lid
  • Steunpunt: Nee
Re: [opgelost] "klikkend" geluid
« Reactie #7 Gepost op: 2010/05/13, 21:55:38 »
Zo heb er even [opgelost] voor de titel van het topic gezet omdat in principe het probleem van het klikken (de harde schijf) is opgelost. Alleen het automatiseren (via een andere manier dan hdparm) wil nog niet lukken.
Ik heb de boel geprobeerd (voorlopig) te automatiseren met scheduled tasks (dus cron job), maar dat wilde niet lukken. Ik ben er niet uit of het aan een foutief command command lag of dat het ├╝berhaupt niet werk via scheduled task. Ik heb het dan over de code sudo hdparm -B 254 /dev/sda
Is er iemand die hier wel een succeservaring mee heeft? Dan ben ik erg benieuwd!
Groetjes,