Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid uit hoofdtelefoon  (gelezen 1040 keer)

Offline Sandertje

  • Lid
  • Steunpunt: Nee
Geen geluid uit hoofdtelefoon
« Gepost op: 2010/04/28, 23:03:20 »
Hallo,

Ik heb een probleem met geluid uit hoofdtelefoons. Op windows werkt alles perfect, maar zodra ik op Ubuntu (10.04) mn hoofdtelefoon insteek, valt het geluid van de interne speakers weg (zoals bedoeld), maar komt er ook 0.0 geluid uit mn hoofdtelefoons. Ik heb een dell laptop van ongeveer 4 maanden oud, met twee jacks voor hoofdtelefoons naast elkaar. Bij de ene hoor ik nog wel even een milliseconde geluid terwijl ik de hoofdtelefoon erin steek, dus ergens merkt ie toch wat op. Hoe krijg ik dit opgelost?


Offline Sandertje

  • Lid
  • Steunpunt: Nee
Re: Geen geluid uit hoofdtelefoon
« Reactie #1 Gepost op: 2010/04/28, 23:17:34 »
Nog even voor de volledigheid, dit is de output van lspci:

lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series]
01:00.1 Audio device: ATI Technologies Inc RV710/730
08:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
14:00.0 FireWire (IEEE 1394): O2 Micro, Inc. Device 10f7 (rev 01)
14:00.1 SD Host controller: O2 Micro, Inc. Device 8120 (rev 01)
14:00.2 Mass storage controller: O2 Micro, Inc. Device 8130 (rev 01)
20:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

Offline Ward De Ridder

  • Lid
    • http://leerubuntu.org
  • Steunpunt: Nee
Re: Geen geluid uit hoofdtelefoon
« Reactie #2 Gepost op: 2010/04/29, 12:36:13 »
je moet eens op je geluid icoon links boven klikken en kiezen voor volume control (ik vermoed in het nederlands iets als mixer), kijk daar eens of het balkje van de hoofdtelefoon niet per ongeluk dicht staat.
http://leerubuntu.org (ubuntu zonder moeilijke woorden)
VoidWarranties (Hackerspace) Antwerpen
Microsoft isn't evil, they just make really crappy operating systems. - Linus Torvalds

Offline Sandertje

  • Lid
  • Steunpunt: Nee
Re: Geen geluid uit hoofdtelefoon
« Reactie #3 Gepost op: 2010/04/29, 14:51:59 »
Ik heb hier sowieso maar 1 schuifbalkje, maar heb zowat al alle settings uitgeprobeerd en het werkt nog steeds niet. Onder Sound Prefenrences --> Output, staat er wel een drop down menutje "connector", die staat standaard op "Analog speakers". Ik kan ook kiezen voor "Analog Headphones" maar dan hoor ik helemaal niets meer (ook niet meer uit de speakers, en er komt nog steeds geen geluid uit de hoofdtelefoon). Ik heb van dat menutje even een screenshot gemaakt ;-).


Offline Sandertje

  • Lid
  • Steunpunt: Nee
Re: Geen geluid uit hoofdtelefoon
« Reactie #4 Gepost op: 2010/05/02, 17:05:27 »
Ik heb het uiteindelijk kunnen oplossen; het was een probleem met alsa-base.conf
Dat bestandje voor mijn dell studio 1745 was blijkbaar niet goed ingesteld.
Het volgende regeltje toevoegen aan /etc/modprobe.d/alsa-base.conf fixed het probleem:
options snd-hda-intel model=dell-m6