Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Kan permissions niet veranderen  (gelezen 5369 keer)

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Kan permissions niet veranderen
« Gepost op: 2010/04/27, 14:40:43 »
Heb een nieuwe WD USB harddisk aangesloten op een ASUS WiFi router WL500W (op de onderste USB poort).
Deze router ondersteunt het ftp protocol.

Als ik verbinding probeer de maken met de HD m.b.v. Krusader gaat dat prima, maar ik kan niet schrijven naar de HD. De permissions van iedere folder staan op r-x
(ook als ik vanaf een pc met Windows XP verbinding maak met de HD (via WinSCP) staan de permissions op r-xr-xr-x  )


Op de site http://fixunix.com/ubuntu/126884-usb-hard-drive-mount-root-permission-only.html vond ik het volgende:
    Linux does not come with write support for NTFS drives. You need to
    add it...   (met Mint en Ubuntu 9.10 kan ik wel direct schrijven naar de (NTFS) HD   :rolleyes:  als die rechtstreeks op de pc is aangesloten )

    Open a terminal
    Applications -> Accesories -> Terminal and type the follwoing after
    the prompt.

    $ sudo apt-get install ntfs-config

    Once installed, mount the drive (if it already isn't) then go to
    Applications -> System Tools -> NTFS Configuration Tools.

    Enable read/write on your external drive.

    That should do the trick.


Heb het bovenstaande toegepast, maar helaas blijft het resultaat hetzelfde.    ???    Het geldt waarschijnlijk niet voor een external drive op een andere pc (of router in mijn geval)


Ligt het misschien aan de router configuratie?  :
    Network Neighborhood Mode: Share all partitions on disk
    Device Name: WL500W
    Work Group: WORKGROUP
    FTP Mode: Login to first partition
    ...
    ...


Ben er na een hele dag zoeken nog niet uit. 
Het probleem is dus dat ik de permissions van r-x niet kan veranderen in rwx.   ???
Wie kan een hint geven.   ;)



(Als ik de HD direct aansluit op een Windows pc of een Linux pc (Ubuntu 9.10 en Mint 8) kan ik wel schrijven. )
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Kan permissions niet veranderen
« Reactie #1 Gepost op: 2010/04/27, 17:06:35 »
Open een terminal en type gksudo nautilus Nu navigeer je naar de externe schijf, normaal onder Media, weergegeven als een map. Klik rechts op het mapje, klik op Eigenschappen, klik op het tabblad rechten, zet de eigenaar op bijv nobody en pas de lees en schrijf rechten aan, verander de groep bijv in nogroup en pas hier ook de schrijf en lees rechten aan. Klaar? Sluit alles af, nu zou je de harde schijf kunnen benaderen.
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #2 Gepost op: 2010/04/27, 23:13:37 »
Open een terminal en type gksudo nautilus Nu navigeer je naar de externe schijf, normaal onder Media, weergegeven als een map. Klik rechts op het mapje, klik op Eigenschappen, klik op het tabblad rechten, zet de eigenaar op bijv nobody en pas de lees en schrijf rechten aan, verander de groep bijv in nogroup en pas hier ook de schrijf en lees rechten aan. Klaar? Sluit alles af, nu zou je de harde schijf kunnen benaderen.

Met Nautilus kan ik niet via Network de HD benaderen die aan de USB van de router gekoppeld is. (Foutmelding: Could not display "network:///". Nautilus cannot handle "network" locations.)    :rolleyes:
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #3 Gepost op: 2010/04/27, 23:25:47 »
Moet je in een netwerk niet tot de zelfde workgroup behoren om verbinding te kunnen maken?
Heb geen ervaring met en weinig kennis over een (eigen) netwerk maar dacht dat zo moet, zeker om schrijfrechten te hebben. ???
Weet ook niet direct hoe je de workgroup van de computer direct kan aanpassen.
Standaard is dat voor windows dat de groep 'workgroup' noemt, dacht ik toch. (Zag ik wanneer ik eens windows installeerde)

Hopelijk komt alsnog iemand met de oplossing. Ook voor anderen en mijzelf lijkt dit interessant om weten.

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #4 Gepost op: 2010/04/27, 23:36:22 »
je moet 'm niet via Network benaderen, maar zoals Gijsbert zei met gksudo Nautilus en dan naar (bv) /mnt/WD of /media/WD of zoiets. Zie je 'm dan?

https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #5 Gepost op: 2010/04/27, 23:39:38 »
Als hij via usb in de router zit kan hij toch niet anders dan via netwerk gaan? Of zie ik dit verkeerd?

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #6 Gepost op: 2010/04/27, 23:57:45 »
Als hij via usb in de router zit kan hij toch niet anders dan via netwerk gaan? Of zie ik dit verkeerd?


Volgens mij zie je dat goed.   ;)
Maar via Nautilus lukt het niet. Met Krusader kan ik de HD wel zien. Kan ook kopieeren van de HD maar niet naar de HD.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #7 Gepost op: 2010/04/27, 23:59:08 »
je moet 'm niet via Network benaderen, maar zoals Gijsbert zei met gksudo Nautilus en dan naar (bv) /mnt/WD of /media/WD of zoiets. Zie je 'm dan?

Nee, want de HD is niet aan de pc gekoppeld, maar aan de router.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #8 Gepost op: 2010/04/28, 00:00:40 »
Weet ik niet precies, Netwerk geeft bij mij nooit iets, ik zie nooit andere Linux-pc's in mijn lan, volgens mij is dat een Windows-ding/erfenis, vandaar denk ik ook dat Workgroup-gedoe, wat des Windows' is en waar ik mij al jaren rot aan erger. Als ik op Netwerk klik, verschijnt er een icoon met Windows-netwerk maar ik heb hier helemaal geen Windows dus klik ik daar nooit meer op, flauwecompatibiliteitskul, wat een leuk woord. Ik benader pc's of andere apparaten in mijn lan via ssh of ftp of 192.168.x.x, of via /mnt/xx of /media/xx, of via Bureaublad op afstand.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #9 Gepost op: 2010/04/28, 11:21:16 »
Weet ik niet precies, Netwerk geeft bij mij nooit iets, ik zie nooit andere Linux-pc's in mijn lan, volgens mij is dat een Windows-ding/erfenis, vandaar denk ik ook dat Workgroup-gedoe, wat des Windows' is en waar ik mij al jaren rot aan erger. Als ik op Netwerk klik, verschijnt er een icoon met Windows-netwerk maar ik heb hier helemaal geen Windows dus klik ik daar nooit meer op, flauwecompatibiliteitskul, wat een leuk woord. Ik benader pc's of andere apparaten in mijn lan via ssh of ftp of 192.168.x.x, of via /mnt/xx of /media/xx, of via Bureaublad op afstand.

Ik kan met ftp de HD op de router wel benaderen, maar de rechten van r-x niet veranderen in rwx.
Ook met Windows XP staan de rechten op r-x.  (terwijl ik verwacht had dat het hier wel direct zou lukken. Maar nee dus.... :'(
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #10 Gepost op: 2010/04/28, 16:52:42 »
Moet je in een netwerk niet tot de zelfde workgroup behoren om verbinding te kunnen maken?
...........................
..........................

Verbinding maken lukt wel.
Ook als de router en de (Windows) pc tot dezelfde group behoren (WORKGROUP) lukt schrijven naar de HD niet. De 'permissions' blijven hetzelfde.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #11 Gepost op: 2010/04/28, 17:00:09 »
En als je Krusader nu eens opent met rootrechten, dus via gksudo (dus klik Alt+F2 en tik: gksudo krusader (krusader zal wel het commando zijn om Krusader op te starten veronderstel ik)
Zo benader je alles via root en zou je de rechten moeten kunnen veranderen.


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Kan permissions niet veranderen
« Reactie #12 Gepost op: 2010/04/28, 17:39:57 »
En mocht dat niet gaan:
First, that's the way it was designed to mount. Every external USB drive will mount with you as owner and permissions set read/write to you only.

Second, you can't change ownership or permissions on a FAT32 or NTFS partition from linux because there are no ownership or permission "bits" to set.

However, you can set a mount point with the ownership and permissions you desire in /etc/fstab

Something like this:

UUID=04EE-ABFE /home/tim/usb_hdd_name vfat user,umask=022,utf8,flush,noauto 0 0

So the general procedure is to:

(1) Insert the usb device

(2) Issue a sudo blkid in the terminal to get the correct UUID number

(3) Create a directory in your home directory to mount the usb device: mkdir /home/tim/usb_hdd_name

(4) Add an entry like the one I have above in fstab

(5) unmount the usb drive and remove the device from the system

(6) issue a sudo mount -a in the terminal

(7) Insert the usb device into the system and see if I'm full of hooey :wink:
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #13 Gepost op: 2010/04/28, 21:44:46 »
En als je Krusader nu eens opent met rootrechten, dus via gksudo (dus klik Alt+F2 en tik: gksudo krusader (krusader zal wel het commando zijn om Krusader op te starten veronderstel ik)
Zo benader je alles via root en zou je de rechten moeten kunnen veranderen.

Helaas gaat dat ook niet. (Can not change permissions for /filename) (terwijl ik toch rootrechten heb (gksudo krusader) )
Het vreemde is dat het ook met Windows XP niet lukt.
Waarom zie ik r-xr-xr-x terwijl het filesysteem NTFS is?

Als ik de HD op een USB poort van m'n Ubuntu pc aansluit, dan kan ik wel schrijven naar de HD vanaf een windows pc.
Kan het liggen aan de settings van de router?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #14 Gepost op: 2010/04/29, 00:40:04 »
En mocht dat niet gaan:
First, that's the way it was designed to mount. Every external USB drive will mount with you as owner and permissions set read/write to you only.

Second, you can't change ownership or permissions on a FAT32 or NTFS partition from linux because there are no ownership or permission "bits" to set.

However, you can set a mount point with the ownership and permissions you desire in /etc/fstab

Something like this:

UUID=04EE-ABFE /home/tim/usb_hdd_name vfat user,umask=022,utf8,flush,noauto 0 0

So the general procedure is to:

(1) Insert the usb device

(2) Issue a sudo blkid in the terminal to get the correct UUID number

(3) Create a directory in your home directory to mount the usb device: mkdir /home/tim/usb_hdd_name

(4) Add an entry like the one I have above in fstab

(5) unmount the usb drive and remove the device from the system

(6) issue a sudo mount -a in the terminal

(7) Insert the usb device into the system and see if I'm full of hooey :wink:

Geen idee hoe ik dit doe op een HD die op een router is aangesloten.   ???
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #15 Gepost op: 2010/04/29, 00:56:58 »
Als ik een USB stick (MSDOS file systeem) op de router aansluit, dan lukt wel alles. (lezen en schrijven)
Zowel met Windows als met Ubuntu.

Een oplossing lijkt mij om het NTFS file systeem op de WD harddisk te veranderen in MSDOS(?)   (ext3 ?)    ???  Wat vinden we hiervan ?

Zo ja:
a. Hoe formatteer ik de HD in MSDOS?
b. Of kan ik ext3 gebruiken? Kan ik dan nog met Windows er naar toe schrijven (en lezen) ?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Sandertje

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #16 Gepost op: 2010/04/29, 11:17:24 »
Windows kan helaas alleen FATxx en NTFS filesystemen herkennen. Door te formatteren naar ext3, zul je die schijf vanaf windows niet meer kunnen lezen/schrijven. (dat is ook de reden waarom je bij een dual boot tussen bijv. Ubuntu en Windows, wél de windows-schijf ziet als je in Ubuntu bent ingelogd, maar niét de Ubuntu-schijf ziet als je op windows bent ingelogd).

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #17 Gepost op: 2010/04/29, 11:27:06 »
Heb je al in de instellingen van de router gekeken?
Dat is ten slotte het apparaat waar je de schijf op aansluit en de data beschikbaar maakt via het netwerk.
Je router bepaalt dus welke rechten er gelden.
Pak de handleiding van de router er dus maar bij :)

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #18 Gepost op: 2010/04/29, 11:51:46 »
Heb je al in de instellingen van de router gekeken?
Dat is ten slotte het apparaat waar je de schijf op aansluit en de data beschikbaar maakt via het netwerk.
Je router bepaalt dus welke rechten er gelden.
Pak de handleiding van de router er dus maar bij :)

Ik heb alle waarden van de router (wat USB / FTP betreft) op default laten staan.
(het blijft voor mij een raadsel waarom een USB stick het wel doet en een USB HD niet. Het enigste verschil is het filesysteem)
(het lijkt erop dat Linux wel naar NTFS kan schrijven als de HD direct aan de pc gekoppeld is, maar dat dit niet gaat via netwerk. Of sla ik hiet de plank mis?)
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #19 Gepost op: 2010/04/29, 11:55:49 »
Het hangt vooral af van het filesysteem.
Voor FAT is er goede ondersteuning aanwezig, lezen én schrijven.
Voor NTFS is extra software nodig die wel in Ubuntu zit, maar misschien niet in een Linux-router.
Zonder die software gaat lezen meestal wel, maar is schrijven niet mogelijk.

USB of intern maakt niks uit als het goed is.
Het is of een missende driver, of een foute instelling in waarschijnlijk de FTP instellingen.

En het bestandssysteem maakt alleen uit voor het apparaat waar je schijf direct op aangesloten zit.
Voor een andere computer die via FTP de data wil benaderen is de schijf zelf helemaal onzichtbaar. Die ziet alleen wat de router aanbiedt.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #20 Gepost op: 2010/04/29, 14:28:25 »
Het hangt vooral af van het filesysteem.
Voor FAT is er goede ondersteuning aanwezig, lezen én schrijven.
.................
.................

Dus zou ik de HD opnieuw kunnen formateren naar FAT en dan zou het moeten werken ?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #21 Gepost op: 2010/04/29, 14:34:03 »
Intrigerende draad. Uit een review door cnet.com:

"The special features--dubbed USB Applications--of the router, unfortunately, are much more difficult to figure out. Because the features are new, we found that there's not enough help within both the Web interface and the manual. For example, it's fairly clear how to connect a USB device to the router and how to enable a function--say the Media server--but you are then left on your own to figure out how to use that function with a computer. An experienced network user will be about to navigate through eventually, but a novice is likely to get frustrated quickly. After quite a bit of time fiddling with the Web interface, we were able to hook a USB-powered external hard drive to one of the USB ports and get it running with networked PCs in the labs. In the end, it worked really well; we were able to transfer files and stream video and audio via Windows Explorer and Windows Media Player."

http://reviews.cnet.com/routers/asus-wl-500w-802/4505-3319_7-32076385.html#cnetReview

Bovenstaande is dus geschreven door pc-specialisten!

Ik zou, zoals Johan al suggereerde, nu eerst eens met de ftp-settings gaan spelen.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #22 Gepost op: 2010/04/29, 14:56:28 »
Intrigerende draad. Uit een review door cnet.com:

"The special features--dubbed USB Applications--of the router, unfortunately, are much more difficult to figure out. Because the features are new, we found that there's not enough help within both the Web interface and the manual. For example, it's fairly clear how to connect a USB device to the router and how to enable a function--say the Media server--but you are then left on your own to figure out how to use that function with a computer. An experienced network user will be about to navigate through eventually, but a novice is likely to get frustrated quickly. After quite a bit of time fiddling with the Web interface, we were able to hook a USB-powered external hard drive to one of the USB ports and get it running with networked PCs in the labs. In the end, it worked really well; we were able to transfer files and stream video and audio via Windows Explorer and Windows Media Player."

http://reviews.cnet.com/routers/asus-wl-500w-802/4505-3319_7-32076385.html#cnetReview

Bovenstaande is dus geschreven door pc-specialisten!

Ik zou, zoals Johan al suggereerde, nu eerst eens met de ftp-settings gaan spelen.

Ja Paul, dit had ik ook al gelezen. 
Heb geen idee wat ik in de ftp-settings zou kunnen (moeten veranderen)
De settings in de router als volgt: zie bijlage.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: LinuxMInt18.2.  Radio Amateur callsign: PA2HO

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Kan permissions niet veranderen
« Reactie #23 Gepost op: 2010/04/29, 19:21:28 »
Als er toch niets opstaat zou ik hem formatteren naar FAT32 en dan nog eens proberen.
Werkt het dan nog niet dan moet je blijkbaar andere instellingen hebben.
Probeer/kontroleer het dan ook via Linux én Windows.