Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache2 doet het niet  (gelezen 1310 keer)

Offline daanmidd

  • Lid
  • Steunpunt: Nee
Apache2 doet het niet
« Gepost op: 2010/04/26, 20:59:03 »
Beste Forumleden,

Ik ben al een tijdje aan het stoeien met Apache2.

Wat ik zo ongeveer gedaan heb:
apt-get install apache2(reboot)
w3m http://localhost
w3m: Can't load http://localhost.
/etc/init.d/apache2 start
 * Starting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName [ OK ]
w3m http://127.0.1.1
w3m: Can't load http://127.0.1.1

Verder heb ik nog wat andere dingen gedaan, maar het helpt niet.

Lighttpd werkt overigens wel gewoon, maar ik heb toch liever apache.

Hoe krijg ik apache2 aan de praat?
You are Unique, Just like Everyone Else

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #1 Gepost op: 2010/04/26, 21:44:28 »
Sorry hoor, maar "doet het niet" kunnen wij niets mee.
Wat doe je precies om te testen of "hij het doet" ?
Oh, ik zie dat je w3m (text browser) gebruikt.

Wat krijg je te zien als je naar http://localhost gaat in je browser?

Ik zou het nu niet weten, maar wat ik zou proberen:
apache ff killen. En dan checken dat er echt geen apache process meer draait. En ervoor zorgen dat echt alles is afgesloten. bijv: ps -ef | grep apache
En dan apache weer starten.
« Laatst bewerkt op: 2010/04/26, 21:49:25 door Wazzzaaa »
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline daanmidd

  • Lid
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #2 Gepost op: 2010/04/26, 22:06:03 »
Het lijkt er nu op dat apache helemaal niet draait.
Nadat ik hem gestart heb zie ik in het lijstje van "ps aux" geen apache staan :|

Terwijl hij na het opstarten wel [OK] geeft.

Wat kan ik nog meer proberen?
You are Unique, Just like Everyone Else

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #3 Gepost op: 2010/04/26, 22:41:15 »
Hij geeft wel een melding tijdens het opstarten, maar dat is het probleem niet.
Je kunt kijken of de configuratie oke is met: apache2ctl -S

Wat ik me nu ineens bedenk is dat apache misschien niet goed is installed. Zelf installeer ik altijd gelijk LAMP (Apache, MySQL, php).
Dat kan met: sudo tasksel 
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #4 Gepost op: 2010/04/27, 10:27:45 »
Wazzzaaa

Kun je mij ook aangeven waarom in ubuntu en debian zo veel anders is als in de andere linux distro's - wat is er de reden om alles wat met de Apache server te maken heeft op verschillende plaatsen onder te brengen en niet onder var/www/localhost/ ?    Want in andere distro's heb ik cgi-bin en mod_perl en mod_python direct werkend en juist in Ubuntu niet.

Citaat
Zelf installeer ik altijd gelijk LAMP (Apache, MySQL, php).
Dat kan met: sudo tasksel  

Er verschijnt een keuze menu - wanneer ik enter op LAMP-server - dan gebeurt er niets en kom ik terug in de promt. Zo ook bij andere keuzes zoals E-mail-server.


Gr Ayla
« Laatst bewerkt op: 2010/04/27, 10:33:01 door ayla »

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #5 Gepost op: 2010/04/27, 11:01:58 »
Er verschijnt een keuze menu - wanneer ik enter op LAMP-server - dan gebeurt er niets en kom ik terug in de promt. Zo ook bij andere keuzes zoals E-mail-server.
Je moet op de spatiebalk drukken. Dan komt er een sterretje voor het onderdeel wat je wil installeren. Ga dan met de Tab-toets naar <OK> en druk dan pas op Enter.
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #6 Gepost op: 2010/04/27, 12:22:56 »
Kun je mij ook aangeven waarom in ubuntu en debian zo veel anders is als in de andere linux distro's - wat is er de reden om alles wat met de Apache server te maken heeft op verschillende plaatsen onder te brengen en niet onder var/www/localhost/ ?    Want in andere distro's heb ik cgi-bin en mod_perl en mod_python direct werkend en juist in Ubuntu niet.
Ik heb vooral ervaring met debian achtige distro's. En weet niet precies waarom dat zo is. Elke distro kan het op zijn eigen manier indelen. Als je LAMP heb installed kun je je php bestanden wel in /var/www/ zetten en werkt het direct. Hoe het met de perl module zit weet ik niet.
Dit is wat ik zou doen: http://www.google.nl/search?q=ubuntu+apache+perl+mod De 2e hit ziet er interessant uit.
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline daanmidd

  • Lid
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #7 Gepost op: 2010/04/27, 18:01:42 »
Nee, het lukt niet:

Tasksel -> lamp-server aanvinken -> tasksel: aptitude failed (100)

En als ik het tar.gz bestand van lampp download, en ik pak het uit en ik voer het uit krijg ik:
Cannot execute binary file o.i.d.
Maar dat heeft er denk ik mee te maken dat het hier om een arm-processor gaat.

Weet iemand waar ik de source van lampp kan downloaden, zodat ik hem zelf kan compileren?

apache2ctl -S geeft:
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server localhost (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost localhost (/etc/apache2/sites-enabled/000-default:1)
Syntax OK


Iemand nog een suggestie?
You are Unique, Just like Everyone Else

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #8 Gepost op: 2010/04/27, 18:45:08 »
Nee, het lukt niet:

Tasksel -> lamp-server aanvinken -> tasksel: aptitude failed (100)
Heb je geprobeerd de pakketbronnen te updaten?
sudo apt-get update

Je hebt al een deel iets geprobeerd te installeren. Misschien is die installatie niet goed verlopen? Als de update niet heeft geholpen kan je proberen deze eerst afronden met de opdracht:
sudo dpkg --configure -a
Welke versie van Ubuntu gebruik je?
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline daanmidd

  • Lid
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #9 Gepost op: 2010/04/27, 19:08:06 »
Nee, het lukt niet:

Tasksel -> lamp-server aanvinken -> tasksel: aptitude failed (100)
Heb je geprobeerd de pakketbronnen te updaten?
sudo apt-get update
Ja, dat heb ik gedaan
Citaat

Je hebt al een deel iets geprobeerd te installeren. Misschien is die installatie niet goed verlopen? Als de update niet heeft geholpen kan je proberen deze eerst afronden met de opdracht:
sudo dpkg --configure -a
Gebeurt niets.
Citaat
Welke versie van Ubuntu gebruik je?
Jaunty
You are Unique, Just like Everyone Else

Offline daanmidd

  • Lid
  • Steunpunt: Nee
Re: Apache2 doet het niet
« Reactie #10 Gepost op: 2010/04/27, 19:27:24 »
Nee, het lukt niet:

Tasksel -> lamp-server aanvinken -> tasksel: aptitude failed (100)
Heb je geprobeerd de pakketbronnen te updaten?
sudo apt-get update
Ja, dat heb ik gedaan
Citaat

Je hebt al een deel iets geprobeerd te installeren. Misschien is die installatie niet goed verlopen? Als de update niet heeft geholpen kan je proberen deze eerst afronden met de opdracht:
sudo dpkg --configure -a
Gebeurt niets.
Citaat
Welke versie van Ubuntu gebruik je?
Jaunty

Edit: Het is me inmiddels gelukt om Lighttpd i.c.m. php aan de praat te krijgen, dit maakt apache overbodig.

Bedankt voor jullie hulp.
You are Unique, Just like Everyone Else