Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mounten Harddisks cq Partities  (gelezen 2788 keer)

Offline flyerman

  • Lid
  • Steunpunt: Nee
Mounten Harddisks cq Partities
« Gepost op: 2010/04/25, 11:32:18 »
Ik weet niet of ik het hier moet posten of in test forum.  Ik heb 10.04 RC geïnstalleerd en dat werkt op zich goed.

Alleen heb ik een probleem met het mounten van mijn drives. Ik heb verschillende partities voor foto's, muziek en video's. Ik heb dit in fstab ook aangegeven met UUID.

bv:  #Entry for /dev/sda3 :
       UUID=7583ba58-f236-4742-8c2b-6aa96cc510a4     /home/martin/Foto   ext3   defaults,auto,relatime   0   0

Als ik opstart dan moet ik alle drives handmatig mounten en het probleem is ook dat Ubuntu 10.04 de volgorde van mijn drives elke keer anders zet. De ene keer is drive 1 sda en dan weer sdd en dat ook met drive 3. Het wisselt elke keer en er is geen pijl op te trekken wanneer drive 1 sda is en wanneer sdd. Op 9.10 heb ik dit probleem niet.

Iemand bekent hiermee?
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #1 Gepost op: 2010/04/25, 11:49:39 »
Ik laat ze automatisch mounten met deze aanpassing.

In de terminal: gksu gedit /usr/share/polkit-1/actions/org.freedesktop.devicekit.disks.policy

zoek onder " <action id="org.freedesktop.devicekit.disks.filesystem-mount-system-internal">" naar "<allow_active>auth_admin_keep</allow_active>" en verander het in " <allow_active>yes</allow_active>".

Sla op en log opnieuw in.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #2 Gepost op: 2010/04/25, 12:06:04 »
Dat bestand heb ik niet. Wel /usr/share/polkit-1/actions/org.freedesktop.udisks.policy. Daar kan ik wel de auth_admin_keep in vinden. Is dat hem soms?

En hoe komt het dat steeds mijn drives verwisseld worden?
« Laatst bewerkt op: 2010/04/25, 12:08:13 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #3 Gepost op: 2010/04/25, 12:35:19 »
Dat bestand heb ik niet. Wel /usr/share/polkit-1/actions/org.freedesktop.udisks.policy. Daar kan ik wel de auth_admin_keep in vinden. Is dat hem soms?
Ik zou het proberen. Als het niet werkt kun je het altijd weer ongedaan maken. Ik heb de 9.10, vandaar het verschil.
Citaat
En hoe komt het dat steeds mijn drives verwisseld worden?
Geen idee.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #4 Gepost op: 2010/04/25, 13:01:10 »
Nee dat werkte niet.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #5 Gepost op: 2010/04/25, 13:09:21 »
Heb even verder gezocht. Ben niet de enige die dat heeft. Iemand heeft er een bug over gepost. Komt voor in 10.04 RC
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #6 Gepost op: 2010/04/25, 14:10:09 »
Dit soort dingen kun je instellen in /etc/fstab
Met het programma 'pysdm' kun je het klikkend instellen.
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #7 Gepost op: 2010/04/25, 14:14:16 »
Heb je al de rechten?
Ga naar Systeem>Beheer>Gebruikers en Groepen en kies je account.
Klik op de knop met Advanced Settings (uitgebreide instellingen in het nederlands als ik me niet vergis.
Tik je wachtwoord.
Ga naar tabblad 'gebruikersrechten' en vink daar alles aan en druk op OK.

Eventueel uitloggen/herstarten.

Mounten ze nu auto aan?

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #8 Gepost op: 2010/04/25, 15:20:08 »
@Wazzzaaa, zoals je in mijn eerste post kon lezen heb ik alles in fstab ingesteld. Dit werkt ook onder 9.10.

@heir4c . Ik heb alle rechten ingesteld.

Helaas geen verschil.
« Laatst bewerkt op: 2010/04/25, 16:35:42 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #9 Gepost op: 2010/04/25, 18:11:58 »
Nou, voorlopig geen 10.04 voor mij. Zolang dit niet is opgelost.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #10 Gepost op: 2010/05/02, 16:16:16 »
Ik heb eens met pysdm gekeken. Er gebeuren rare dingen.

Als ik op sdax klik dan zegt het programma sddx is niet geconfigurrerd. En andersom net zo. Configureer ik nu bv sda1 en mount dat aan Muziek, dan gebeurd hetzelfde op sddx.

Het lijkt op een of andere manier dat die twee partities aan elkaar zitten op een of andere manier.

Voor de duidelijkheid, op 9.10 heb ik dat dus niet, daar werkt het prima.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #11 Gepost op: 2010/05/02, 16:19:59 »
Plaats de inhoud van /etc/fstab eens hier, en ook het resultaat van het commando "sudo blkid".

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #12 Gepost op: 2010/05/02, 16:34:04 »
fstab:

  • # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>

    #proc                                      /proc                proc         defaults                    0  0  

    #Entry for /dev/sde1 :
    UUID=d686d81c-d79b-4d27-abc3-3fc00b815325  /home/martin/Download  ext3    defaults                   0  0  

    #Entry for /dev/sda3 :
    UUID=7583ba58-f236-4742-8c2b-6aa96cc510a4  /home/martin/Foto    ext3         defaults,                   0  0  

    #Entry for /dev/sda2 :
    UUID=447e5fa4-2efe-4454-b7ca-8932484b4c33  /home/martin/Muziek  ext3        defaults,                   0  0  

    #Entry for /dev/sdd1 :
    UUID=d29485c6-7c00-4019-b350-b1c827fea1d3  /home/martin/Video   ext3        defaults                    0  0  

    #Entry for/dev/sdb2
    UUID=2038687538684C3A                      /media/Video_Files   ntfs-3g      defaults,locale=nl_NL.utf8     0  0  

    #Entry for /dev/sdd1 :
    UUID=7970E7D87EAC12CB                      /media/Windows_7     ntfs-3g      defaults,locale=nl_NL.utf8  0  0  

    #Entry for /dev/sdb1 :
    UUID=7F820C804F74E594                      /media/Windows_XP    ntfs-3g      defaults,locale=nl_NL.utf8   0  0  

    UUID=680a7667-0d1a-4b69-bd2e-de901ce36536  /                    ext3         relatime,errors=remount-ro  0  1  

    UUID=80997bd4-8cf9-4bf9-b90f-b3ba0ae53f67  none                 swap         sw                          0  0  

    /dev/scd0                                  /media/cdrom0        udf,iso9660  user,noauto,exec,utf8       0  0  

    /dev/fd0                                   /media/floppy0       auto         rw,user,noauto,exec,utf8    0  0  





blkid:

/dev/sda1: LABEL="Windows 7" UUID="7970E7D87EAC12CB" TYPE="ntfs"
/dev/sda5: UUID="1e7731fc-110e-4516-9a4e-acac5a12bed0" TYPE="ext4"
/dev/sda6: UUID="8cc38ec0-e5bc-4507-9a38-e8877260127a" TYPE="swap"
/dev/sdb1: LABEL="Windows XP" UUID="7F820C804F74E594" TYPE="ntfs"
/dev/sdb2: LABEL="Video Files" UUID="2038687538684C3A" TYPE="ntfs"
/dev/sdc2: LABEL="Muziek" UUID="447e5fa4-2efe-4454-b7ca-8932484b4c33" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdc3: LABEL="Foto" UUID="7583ba58-f236-4742-8c2b-6aa96cc510a4" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdc5: UUID="ff97f43e-2f4c-47a8-94e7-ef39bd81723d" TYPE="ext4"
/dev/sdc6: UUID="40dd329f-68a1-4544-a379-007e6a7ba3db" TYPE="swap"
/dev/sdd1: LABEL="Video" UUID="d29485c6-7c00-4019-b350-b1c827fea1d3" SEC_TYPE="ext2" TYPE="ext3"
/dev/sde1: LABEL="Download" UUID="d686d81c-d79b-4d27-abc3-3fc00b815325" SEC_TYPE="ext2" TYPE="ext3"
« Laatst bewerkt op: 2010/05/02, 16:45:11 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #13 Gepost op: 2010/05/02, 16:50:48 »
In de regels voor je muziek- en foto- partities staat een komma achter defaults.
Haal die eens weg en probeer het nog eens.

Verder is de regel die begint met #proc ook raar, daar zou namelijk helemaal geen hekje voor moeten staan.

De UUID voor je swap partitie lijkt ook al niet te kloppen.

Verander dus dit:
UUID=80997bd4-8cf9-4bf9-b90f-b3ba0ae53f67  none                 swap         sw                          0  0 
in dit:
UUID=40dd329f-68a1-4544-a379-007e6a7ba3db  none                 swap         sw                          0  0 

Ten slotte is de volgorde ook nogal overhoop gehaald, zo lijkt het. Maar dat zou voor de werking geen probleem moeten zijn.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #14 Gepost op: 2010/05/02, 16:55:48 »
Die komma's heb ik totaal niet gezien. Het proc lijntje had ik zelf even een # voorgezet om te kijken of dat het probleem was.

De uuid voor de swap klopt wel, deze is van de 9.10 versie, de andere moet ik even terug zetten, Had ik er even tijdelijk uitgehaald, en vergeten terug te zetten.

Ik ga het allemaal veranderen en laat het weten.

Bedankt zover
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #15 Gepost op: 2010/05/02, 17:10:33 »
Nee werkt nog niet. sda3 en sdd6 geven problemen met elkaar.
sda2 en sdc1 ook.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #16 Gepost op: 2010/05/02, 17:16:02 »
Eh?
In de uitvoer van blkid die je net hebt geplaatst komen die partities helemaal niet voor...
Waarschijnlijk zit pysdm dus gewoon te prutsen.

Maar waarom gebruik je nu nog een keer pysdm? Was het nog niet volledig opgelost? In dat geval kan je het beter handmatig zelf oplossen in /etc/fstab.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #17 Gepost op: 2010/05/02, 17:26:30 »
Het probleem is dat bij het opstarten de drives door elkaar gegooid worden. sda wordt sdc etc, alles wisselt steeds.

Ik dacht dat dit met UUID te gebruiken opgelost zou worden.

Ik wordt er gek van. Ik denk dat ik voorlopig 9.10 blijf gebruiken.
« Laatst bewerkt op: 2010/05/02, 17:29:28 door flyerman »
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #18 Gepost op: 2010/05/02, 17:50:18 »
Dat wisselen tussen sda, sdc enz. is niet zo interessant, normaal gesproken.
In principe zou je alles gewoon moeten kunnen mounten door het mountpoint te gebruiken:
sudo mount /home/martin/Foto bijvoorbeeld zal gewoon werken.

Verder zou ik programma's als pysdm helemaal niet gebruiken, ze gooien de configuratie door elkaar en in het geval van wisselende aanduidingen gaan ze compleet de mist in.

Het commentaar (#Entry for... regels) zou ik weghalen, ze zijn niet nuttig en zouden een onderdeel van het probleem kunnen zijn als die programma's die regels gebruiken.

Wat je ook nog zou kunnen proberen is de volgorde weer goed zetten.
Eerst de proc regel, daarna die voor / en swap. En daarna pas de rest.


En nog iets, wat ik nu pas zie :)
Van alle ext3 partities behalve de / moet je de laatste 0 vervangen door een 2.
Anders worden die partities nooit gecontroleerd door fsck.

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #19 Gepost op: 2010/05/02, 18:49:49 »
Werkt nog steeds niet.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04

Offline flyerman

  • Lid
  • Steunpunt: Nee
Re: Mounten Harddisks cq Partities
« Reactie #20 Gepost op: 2010/05/15, 10:35:27 »
Heeft even geduurd om te posten. Maar het werkt nog steeds niet.
Server: Ubuntu 14.04 server edition
1 x Desktop: Mint 17.1
Netbook: Acer Aspire One Xubuntu 12.04.
Laptops: 1 x Asus Linux Mint 17.1, 1 x Acer XUbuntu 12.04