Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: hda5 zichtbaar maken  (gelezen 2414 keer)

PdK

  • Gast
hda5 zichtbaar maken
« Gepost op: 2006/11/24, 20:43:05 »
Ik heb Kubuntu geinstalleerd op een harde schijf waarop ook nog enkele NTFS partities zitten.
Daarvan is er nu 1 (hda5) geconverteerd naar ex3 in Gparted maar ik zie die partitie niet in KInfoCenter.
Hoe koppel ik deze HD aan zodat ik er data op kan zetten?

Als ik kijk in sysyem:/media in Konqueror zie ik de partitie wel staan maar als ik dan met mijn rechtermuisknop erop klik en kies voor aankoppelen krijg ik de volgende foutmelding:
mount: kan /dev/hda8 niet vinden in /etc/fstab of /etc/mtab
Maar beide mappen heb ik niet.

breukkie

  • Gast
hda5 zichtbaar maken
« Reactie #1 Gepost op: 2006/11/24, 21:06:32 »
Open een terminal en geef het volgende commando mkdir /media/ntfs (of een andere naam die je er aan wil geven.
Als gedit niet werkt moet je deze nog even instaleren via sudo apt-get install gedit  .
vervolgens je wachtwoord opgeven en gedit word geinstalleerd

Geef het volgende commando in je terminal sudo gedit /etc/fstab je krijgt nu je fstab te zien .
De mijne ziet er zo uit


# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=927d599b-ff85-4016-acf0-60c86241756f /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=48427487-6f23-4e0a-947f-796b9a57203e none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/           /media/floppy0  auto    rw,user,noauto  0       0
/dev/hda6        /media/hda6   ntfs    nls=utf8,umask=0222    0    0


maak de laatste regel aan in je fstab als deze er nog niet staat
   /dev/hda6        /media/hda6   ntfs    nls=utf8,umask=0222    0    0  uiteraard maak jij hier /dev/ naam van je  map die je via mkdir /media/ ???? heb aangemaakt  dan /media/hda? nummer van je schijf aanpassen zodat de regel eruit ziet met de naam van jou map en jou schijf.
Vervolgens klikken op opslaan.
in je terminal intypen sudo mount -a  en als het goed is krijg je de schijf te zien op je buroblad.
Werkt het niet dan  toch rebooten moest ik ook en daarna zag ik mn schijf.
werkt het niet horen we het graag
succes

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #2 Gepost op: 2006/11/25, 13:33:40 »
aankoppelingspunt /media/ntfs/hda5 bestaat niet.
Heb ik een fout gemaakt in de laatste regel in fstab?



piet@kubuntu:~$ mkdir /media/ntfs
mkdir: kan map `/media/ntfs' niet aanmaken: Toegang geweigerd
piet@kubuntu:~$ sudo su
Password:
root@kubuntu:/home/piet# mkdir /media/ntfs
root@kubuntu:/home/piet#



# /etc/fstab: static file system information.
#
#            
proc            /proc            proc    defaults        0       0
/dev/hda9       /                ext3    defaults,errors=remount-ro 0       1
/dev/hda10      none             swap    sw              0       0
/dev/hdd        /media/cdrom0    udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0   auto    rw,user,noauto  0       0
/dev/hda5       /media/ntfs/hda5 ext3    nls=utf8,umask=0222    0    0


piet@kubuntu:~$ sudo mount -a
mount: aankoppelingspunt /media/ntfs/hda5 bestaat niet
piet@kubuntu:~$

breukkie

  • Gast
hda5 zichtbaar maken
« Reactie #3 Gepost op: 2006/11/26, 03:16:56 »
Sorry voor de late reactie.
Haal in de regel /dev/hda5       /media/ntfs/hda5 ext3    nls=utf8,umask=0222    0    0  
ext3 eens weg.
Er van uitgaande dat je via mkdir /media/ntfs/hda5  hebt aangemaakt
Dus terug naar je  sudo gedit  /etc/fstab: en die ext3  weghalen

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #4 Gepost op: 2006/11/26, 08:49:59 »
Citaat van: breukkie
Sorry voor de late reactie.
Haal in de regel /dev/hda5       /media/ntfs/hda5 ext3    nls=utf8,umask=0222    0    0  
ext3 eens weg.
Er van uitgaande dat je via mkdir /media/ntfs/hda5  hebt aangemaakt
Dus terug naar je  sudo gedit  /etc/fstab: en die ext3  weghalen
Helaas, dan krijg je dus dit:

proc            /proc            proc    defaults        0       0
/dev/hda9       /                ext3    defaults,errors=remount-ro 0       1
/dev/hda10      none             swap    sw              0       0
/dev/hdd        /media/cdrom0    udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0   auto    rw,user,noauto  0       0
/dev/hda5       /media/ntfs/hda5     nls=utf8,umask=0222    0    0

piet@kubuntu:~$ sudo mount -a
mount: aankoppelingspunt /media/ntfs/hda5 bestaat niet

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #5 Gepost op: 2006/11/26, 09:05:20 »
Je hoeft geen excuses te maken voor een late reactie hoor, ik ben allang blij dat je mij wilt helpen.
Er staat hier een Windows PC, compleet met web- en FTP server dus ik red me wel.
Het willen leren van Kubuntu is dus puur een hobby :-)

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #6 Gepost op: 2006/11/26, 22:52:51 »
Als ik de eigenschappen opvraag van de partitie waar Kubuntu op staat lees ik dat de locatie /media is maar als ik als Root een ls commando in die map geef kan ik niks terugvinden.
In /media/ntfs staat mijn nieuwe partitie ook niet.
Kan ik dit nog op een andere manier controleren?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
hda5 zichtbaar maken
« Reactie #7 Gepost op: 2006/11/27, 00:25:06 »
Citaat van: PdK
piet@kubuntu:~$ sudo mount -a
mount: aankoppelingspunt /media/ntfs/hda5 bestaat niet
Betekent simpelweg dat je de lege map /media/ntfs/hda5 nog moet aanmaken (bijvoorbeeld d.m.v. sudo mkdir /media/ntfs/hda5)

Maar... volgens mij zit je helemaal in de knoop nu...

En je spreekt over hda5, maar in Konqueror komt er een melding over hda8 ? dus er klopt daar al iets niet...

Kan je even de structuur van je partities kopi
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

breukkie

  • Gast
hda5 zichtbaar maken
« Reactie #8 Gepost op: 2006/11/27, 08:13:26 »
/dev/hda5       /media/ntfs/hda5     nls=utf8,umask=0222    0    0  .
De regel is niet compleet.

/dev/hda5       /media/ntfs/hda5    ntfs  nls=utf8,umask=0222    0    0   ..

Ik zie dat ik dit in mijn reactie niet heb vermeld.

Als je heb uitgevonden met welke hda? je wilt mounten kun je de regel in je fstab aanpassen door er ntfs aan toe te voegen.

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #9 Gepost op: 2006/11/27, 16:48:55 »
Citaat
Betekent simpelweg dat je de lege map /media/ntfs/hda5 nog moet aanmaken

Kan je even de structuur van je partities kopi

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #10 Gepost op: 2006/11/27, 17:01:02 »
Citaat van: breukkie
/dev/hda5       /media/ntfs/hda5     nls=utf8,umask=0222    0    0  .
De regel is niet compleet.

/dev/hda5       /media/ntfs/hda5    ntfs  nls=utf8,umask=0222    0    0   ..
Nu krijg ik met sudo mount -a de volgende foutmelding:
mount: slecht soort bestandssysteem, slechte optie, slecht superblok op /dev/hda5,
       ontbrekende codepagina of andere fout
       In sommige gevallen wordt er nuttige informatie gevonden in syslog
- probeer dmesg | tail ofzo



piet@kubuntu:~$ dmesg | tail
[17180436.216000] NTFS driver 2.1.25 [Flags: R/O MODULE].
[17180436.248000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180436.248000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180436.248000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.
[17180654.952000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180654.952000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180654.952000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.
[17180680.432000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180680.432000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180680.432000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.


Hij zegt dus dat het geen ntfs is en dat klopt want volgens Gparted is het een ext3
Waar haalt hij vandaan dat hij van een ntfs_boot_sector moet lezen?
Als ik in de laatste regel van fstab het woordje ntfs verander in ext3 krijg ik met dmesg | tail de volgende melding:

[17180436.248000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180436.248000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180436.248000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.
[17180654.952000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180654.952000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180654.952000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.
[17180680.432000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
[17180680.432000] NTFS-fs error (device hda5): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
[17180680.432000] NTFS-fs error (device hda5): ntfs_fill_super(): Not an NTFS volume.
[17180777.464000] EXT3-fs: Unrecognized mount option "nls=utf8" or missing value


Wie snapt het nog?
Ik als Kubuntu-leek niet meer.

breukkie

  • Gast
hda5 zichtbaar maken
« Reactie #11 Gepost op: 2006/11/27, 21:29:12 »
Hmm ik heb een gedeelte niet goed gelezen zie ik, je gaf al aan in je eerste topic dat je van ntfs naar ext3 was gegaan.
Dan is die foutmelding ook wel logisch die je krijgt  wat gebeurd er als je  via  sudo gedit /etc/fstab   /dev/hda5       /media/ntfs/hda5    ntfs  nls=utf8,umask=0222    0    0   ..  ntfs weghaald  en dit weer aangeeft  als ext3 en dit opslaat ?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
hda5 zichtbaar maken
« Reactie #12 Gepost op: 2006/11/28, 01:31:51 »
Verander deze lijn

Citaat
/dev/hda5       /media/ntfs/hda5    ntfs  nls=utf8,umask=0222    0    0
naar:

Citaat
/dev/hda5       /media/hda5    ext3  defaults,errors=remount-ro   0   2
en om alles netjes te houden, verwijder deze map:
sudo rm -R /media/ntfs/hda5
en maak deze map aan in de plaats:
sudo mkdir /media/hda5

nota: in plaats van "/media/hda5" mag je ook iets anders nemen, meestal worden partities in een submap in /media of /mnt aangekoppeld om alles duidelijk te houden, bijvoorbeeld "/media/willekeurige-naam-van-map"

en nu alles proberen aan te koppelen:
sudo mount -a

edit: ik had een klein foutje gemaakt :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #13 Gepost op: 2006/11/28, 01:35:06 »
Citaat van: breukkie
Hmm ik heb een gedeelte niet goed gelezen zie ik, je gaf al aan in je eerste topic dat je van ntfs naar ext3 was gegaan.
Dan is die foutmelding ook wel logisch die je krijgt  wat gebeurd er als je  via  sudo gedit /etc/fstab   /dev/hda5       /media/ntfs/hda5    ntfs  nls=utf8,umask=0222    0    0   ..  ntfs weghaald  en dit weer aangeeft  als ext3 en dit opslaat ?
Dat maakt niet uit, dan krijg ik dezelfde foutmelding.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
hda5 zichtbaar maken
« Reactie #14 Gepost op: 2006/11/28, 01:38:49 »
(In het geval je het niet gezien hebt: Ik had een klein foutje gemaakt in mijn uitleg van een aantal minuten geleden... is nu verbeterd...)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #15 Gepost op: 2006/11/28, 01:46:18 »
Citaat van: profoX
(In het geval je het niet gezien hebt: Ik had een klein foutje gemaakt in mijn uitleg van een aantal minuten geleden... is nu verbeterd...)
Ik heb net jouw commando's ingevoerd en na een reboot wil hij niet meer opstarten.

GRUB loading, please wait.
Error 17

Volgens Google komt dat omdat er nu helemaal geen HD meer gemount is.
Even verder lezen voor de oplossing.

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #16 Gepost op: 2006/11/28, 12:44:14 »
Ik heb de boel opnieuw ge

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #17 Gepost op: 2006/11/28, 16:46:49 »
H

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
hda5 zichtbaar maken
« Reactie #18 Gepost op: 2006/11/28, 18:47:03 »
Citaat van: PdK
Citaat van: profoX
(In het geval je het niet gezien hebt: Ik had een klein foutje gemaakt in mijn uitleg van een aantal minuten geleden... is nu verbeterd...)
Ik heb net jouw commando's ingevoerd en na een reboot wil hij niet meer opstarten.

GRUB loading, please wait.
Error 17

Volgens Google komt dat omdat er nu helemaal geen HD meer gemount is.
Even verder lezen voor de oplossing.
Dat was wel erg vreemd. Heb je niet per ongeluk iets op de lijn van /dev/hda9 aangepast dan? Anders ligt de oorzaak volgens mij niet bij het fstab bestand

Maar goed... het werkt nu en dat is het belangrijkste
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

PdK

  • Gast
hda5 zichtbaar maken
« Reactie #19 Gepost op: 2006/11/28, 20:07:21 »
Citaat van: profoX
Dat was wel erg vreemd. Heb je niet per ongeluk iets op de lijn van /dev/hda9 aangepast dan? Anders ligt de oorzaak volgens mij niet bij het fstab bestand

Maar goed... het werkt nu en dat is het belangrijkste
Het zou heel goed kunnen dat ik bij het proberen met verschillende instellingen een fout gemaakt heb.
Tenslotte ben ik een echte Windows-man maar langzaam begin ik ook een beetje iets van de structuur van Kubuntu te kennen.
Tot nu toe bevalt het me wel.
Als ik straks ook het wireless aan de gang kan krijgen ben ik helemaal tevreden.