Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (OPGELOST) Alleen geluid via koptelefoon  (gelezen 9869 keer)

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
(OPGELOST) Alleen geluid via koptelefoon
« Gepost op: 2010/04/14, 21:46:05 »
dag! Wie van jullie wil mee kijken/denken?
Ik heb alleen geluid als ik de koptelefoon gebruik (zowel van de CD via Rhytmbox als van Youtube) en heb al wat rondgekeken binnen de topics maar voel me nog te onzeker als nieuweling om van alles uit te voeren.

Via systeem-geluid-geluidsvoorkeuren heb ik al bekeken dat er nergens 'dempen' aangevinkt staat. Bij de tab hardware staan 2 opties waar ik zonder resultaat al mee gewisseld heb: HDA ATI HDMI (1 output) en intern geluid (1 output/1 input). De HDA kan alleen uit of aan, intern geluid kan ik kiezen uit/output/input/duplex.

Na de installatie heb ik de tips m.b.t. 'installatie afronden' allemaal uitgevoerd.
Voor de installatie van 9.10 had ik eerst even de 8.04 versie geïnstalleerd; toen had ik bij het openen van Ubuntu steeds keihard geluid via de laptop, de kaart zou dus wel moeten werken denk ik.

Dit heb ik wel aangedurfd maar zonder resultaat:
gksudo gedit /etc/modprobe.d/alsa-base.conf
en toevoegen: options snd-hda-intel probe_mask=1
en opslaan en dan opnieuw opstarten.

Verder heb ik gekeken bij Alsamixer: Master en Headphone staan aan (want groen 00), PCM staat niet op groen maar ook geen MM,
PC Beep en Speaker staat MM bij, hier kan ik echter niets aan veranderen. Betekent dit dat de speaker uit staat? En zo ja: enig idee waar/hoe ik dit aan kan zetten?


lspci | grep -i "aud"
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc Device 970f

aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: SB [HDA ATI SB], apparaat 0: STAC92xx Analog [STAC92xx Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: HDMI [HDA ATI HDMI], apparaat 3: ATI HDMI [ATI HDMI]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0

groet, Jacqueline
« Laatst bewerkt op: 2010/04/20, 22:12:18 door Jacqueline Beettjer »
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #1 Gepost op: 2010/04/17, 21:19:57 »
Hallo

Wat voor merk/type laptop is dit precies, misschien staat er al iets kant en klaar bij
linux-on-laptops.

Het lijkt trouwens op een jack sensing (een soort schakelaartje) gevalletje.
Als je de gewone gnome mixer openmaakt(volumeregeling), wat staat er dan bij het tabblad
schakelaars? (als dat tabblad er al bij staat) er moet een vinkje in headphone staan.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #2 Gepost op: 2010/04/18, 10:29:53 »
Dag Gerrit, dank voor je reactie.
Bij Gnomemixer staat geen tabblad schakelaars, wel: geluidseffecten, hardware, invoer, uitvoer, toepassingen. De mogelijkheden tot dempen staan hier allemaal uit.
Laptop: Presario CQ 61-405ED (verdere specificaties zie hieronder).
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #3 Gepost op: 2010/04/18, 13:28:27 »
Hallo

Ok, je laptop duikt zo niet op en ik heb zelf even niet goed opgelet :rolleyes:; in 9.10
ziet de volumeregeling er wezenlijk anders uit (ik zit zelf in 9.04)
Maar misschien als je dit eerst doet;

Open synaptic (software pakketbeheer) en type daar bij
het zoekvenster ; linux-backports
Installeer de; linux-backports-modules-alsa-karmic-generic

Machine herstarten en controleren, check voor de zekerheid ook
even je mixersettings na de herstart.

Lijkt op dit moment de simpelste oplossing zonder direct onder de motorkap
van je systeem te moeten duiken.
En heel misschien, moet je als dit niet lukt, ook nog even die wijziging in je alsa-base.conf
ongedaan maken en machine herstarten

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #4 Gepost op: 2010/04/18, 14:08:24 »
Ai, nu doet ook de koptelefoon het niet meer...
In Gnomemixer staan alle geluidsmogelijkheden nog steeds aan (dus dempen uit).
De wijziging in alsa-base.conf staat er niet meer  ??? wordt dit overruled door de linux-backport? Kan ik de linux-backport maar weer beter verwijderen?
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #5 Gepost op: 2010/04/18, 15:02:41 »
Hmmm

Das, een raar neven verschijnsel, heb je trouwens nu helemaal geen geluid meer?
Dus; en niet van je hoofdtelefoon en niet van je speakers?
Het kan inderdaad geen kwaad om hem dan maar te deïnstalleren, maar ik
heb dat tot op heden nog niet hoeven doen, die backports hebben tal van
microfoon en headphone probleempjes opgelost (zoek maar er maar eens op in
dit forum)
Is er trouwens een soort van alsa-base.conf backup aangemaakt, na de backport
installatie?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #6 Gepost op: 2010/04/18, 16:21:32 »
Nee, alle geluid is 'verdwenen', geen hoofdtelefoon, geen speakers.
Waar/ hoe ik kan zien of er een backup is gemaakt van alsa-base.conf?
Ik heb de backports er weer afgehaald en de machine laten herstarten. Het geluid is echter niet hersteld.
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #7 Gepost op: 2010/04/18, 22:15:39 »
Hallo

Een lastige dus, zeker op afstand, maar om te kijken of er meerdere
alsa-base.conf's zijn aangemaakt (denk ik trouwens niet);
Start je  bestandsbeheerder en reis even naar /etc/modprobe.d/
en kijk wat je daar allemaal ziet, daar woont je alsa-base.conf ook.

Voeg anders even je originele regel weer toe of anders dit;
options snd-pcsp index=-2
options snd-hda-intel enable_msi=1
en test na een restart of er tenminste weer iets werkt.

Ik denk dat als je op stac92xx zoekt je tal van andere extra opties
voorbij ziet drijven voor in die alsa-base.conf, als je die allemaal wilt gaan
testen heb je daar wel een dagtaak aan vrees ik. Misschien kun je ergens een
succesverhaal via www.google.nl/linux vinden icm. met stac92xx

Probeer anders eens je 9.10 als live cd te draaien en hoor of die dan wel werkt.
Soms heb je nl. geen geluid meer na een kernelupdate en misschien heb je het 1 en
ander aan updates al binnengehaald.

Groeten Gerrit



-- = >  simplify if you can   -- = >

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #8 Gepost op: 2010/04/19, 19:51:48 »
Fijn dat je nog steeds met opties komt! Deze werkt in ieder geval gedeeltelijk dus dat is mooi:

options snd-pcsp index=-2
options snd-hda-intel enable_msi=1

De hoofdtelefoon geeft nu weer geluid (kan ik in ieder geval Kate Bush weer luisteren, héél prettig  :D).

/etc/modprobe.d/ geeft dit te zien (zie bijlage; ik weet niet of dit de juiste manier is om e.e.a. weer te geven?)

stac92xx zoeken, bedoel je via synaptic pakketbeheer? Daar zie ik niets.

De live CD probeer ik morgenavond rustig uit, ik heb nu niet veel tijd.
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #9 Gepost op: 2010/04/19, 21:49:52 »
Hallo

Ik (we) kunnen even niets met je bijlage; laat deze maar even zitten.
Ik wacht even de uitslag van het live gebeuren af.
Dat zoeken op stac92xx is niet in synaptic maar in; www.google.nl/linux
vervelend is dat je veel opties na moet gaan en moet uitproberen, laat
dit ook maar even zoals het is.
Ik heb daar al wel even op gezocht icm. het woord karmic en kom gek genoeg
toch weer die linux backport modules tegen als zijnde de oplossing.
Kun je misschien even een terminal openen (Toepassingen-Hulpmiddelen-Terminalvenster)
en daar dit;
uname -sr
intikken (met aansluitend een enter)
en dat hier posten.

Groeten Gerrit
« Laatst bewerkt op: 2011/08/14, 10:37:09 door mrGee »
-- = >  simplify if you can   -- = >

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #10 Gepost op: 2010/04/20, 10:37:13 »
Even een aanvulling,

Waarschijnlijk kom je toch weer op die backports uit, ik zat net even in het forum
te neuzen;
http://forum.ubuntu-nl.org/internet-en-draadloos/onstabiel-draadloos-op-compaq-cq61/msg563517/#msg563517
Gaat weliswaar over een wireless kaartje maar geluid wordt ook even genoemd;
daar staat dat hij met de nieuwe 10.4 (alpha) ineens ook geen backports meer nodig heeft; ergo
op zijn 9.10 kennelijk dus wel en had hij kennelijk toch wel geluid.
Misschien is het nodig om na de backports installatie om zelf even die opties in je
alsa-base.conf te zetten.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Jacqueline Beettjer

  • Lid
  • Steunpunt: Nee
Re: Alleen geluid via koptelefoon
« Reactie #11 Gepost op: 2010/04/20, 22:11:51 »
Dag Gerrit: het is opgelost!!

Ik heb de live CD uitgetest maar daar had ik (ook) geen geluid behalve de koptelefoon.
Daarom toch weer jouw advies voor installatie van de backports uitgevoerd (en gisteren dus al je andere advies opgevolgd) en voila: Kate schalt door de kamer, super!!  =D 
Ontzettend bedankt, ik ben hier écht heel blij mee.

(het blijft voor mij wel raadselachtig waarom de installatie van de backports de 1e keer niet gewerkt heeft?! Of heeft dat te maken met options snd-pcsp index=-2
options snd-hda-intel enable_msi=1 ??)
Nog even om het rond te maken: de uitkomst van de opdracht uname -sr in het terminalvenster: Linux 2.6.31-20-generic

groet, Jacqueline
Samsung Series 3; Intel® Core™ i3-2370M CPU @ 2.40GHz × 4; 32-bit
Ubuntu 12.04.2 LTS (Dual boot met Windows 7)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: (OPGELOST) Alleen geluid via koptelefoon
« Reactie #12 Gepost op: 2010/04/20, 23:24:32 »
Bedankt voor het terugmelding, kan ik tenminste ook weer
rustig slapen  =D

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline uuuu

  • Lid
  • Steunpunt: Nee
Re: (OPGELOST) Alleen geluid via koptelefoon
« Reactie #13 Gepost op: 2010/07/03, 21:39:49 »
dag! Wie van jullie wil mee kijken/denken?
Ik heb alleen geluid als ik de koptelefoon gebruik (zowel van de CD via Rhytmbox als van Youtube) en heb al wat rondgekeken binnen de topics maar voel me nog te onzeker als nieuweling om van alles uit te voeren.

Hallo,
Ik heb een MSi EX 620 notebook en na de installatie van Ubuntu kwam ik precies hetzelfde probleem tegen. Ik heb veel ondergezocht maar omdat mijn ubuntu kennis niet zoveel is, kan ik de probleem niet oplossen. Kan iemand mij helpen?

mvg.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: (OPGELOST) Alleen geluid via koptelefoon
« Reactie #14 Gepost op: 2010/07/03, 22:21:51 »
Hallo

Het vervelende is dat we met die informatie niet zoveel kunnen,
en voor een beginnende gebruiker kan een terminal best wel
afschrikken, toch hebben we die nodig.

Ga via Toepassingen-Hulpmiddelen naar Terminalvenster
type daar in;
aplay -l  (l= kleine letter L)
en druk op enter
vermeld hier even wat voor model
alc  chipset er zo opduikt.

terminal kun je daarna gewoon afsluiten of; exit in typen en enteren

Groeten Gerrit

edit; en ik denk dat het handiger is, afhankelijk van de gevonden chipset, om dan een nieuwe
topic te starten, aangezien deze eigenlijk al is opgelost, alleen als dezelfde chipset opduikt blijven we hier
 
« Laatst bewerkt op: 2010/07/03, 22:24:24 door mrGee »
-- = >  simplify if you can   -- = >

Offline uuuu

  • Lid
  • Steunpunt: Nee
Re: (OPGELOST) Alleen geluid via koptelefoon
« Reactie #15 Gepost op: 2010/07/03, 22:53:17 »
Ik weet al sommige dingen over Ubuntu. Ik heb al eerder geinstalleerd en gebruikt. En om het probleem te kunnen oplossen heb ik ook veel dingen zelf gedaan. Ondertussen bedankt voor het snelle reactie.

umut@umut:~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC1200 Analog [ALC1200 Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: ALC1200 Digital [ALC1200 Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: HDMI [HDA ATI HDMI], apparaat 3: ATI HDMI [ATI HDMI]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

Offline uuuu

  • Lid
  • Steunpunt: Nee
Re: (OPGELOST) Alleen geluid via koptelefoon
« Reactie #16 Gepost op: 2010/07/04, 02:09:30 »
Ik heb het probleem opgelost.
eerst in terminal
sudo gedit /etc/modprobe.d/alsa-base.conf
daarna voeg ik toe
options snd-hda-intel model=targa-dig

http://forum-en.msi.com/index.php?topic=138622.0
http://doc.ubuntu-fr.org/audio_intel_hda

Nogmaals bedankt.