Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Ubuntu start niet op na opnieuw installeren van GRUB 2  (gelezen 878 keer)

Offline Robertos

  • Lid
  • Steunpunt: Nee
Ik heb GRUB opnieuw moeten installeren aangezien deze overschreven was door de bootloader van Vista.
Het resultaat was dat ik Ubuntu 9.10 niet kon opstarten, het lijkt erop dat de home partitie en swap niet gevonden kunnen worden.
Aangezien er blijkbaar iets verkeerd is met fstab heb ik een back-up teruggeplaatst, jammer genoeg zonder het gewenste resultaat.

Deze melding krijg ik:

One or more of the mounts listed in /etc/fstab cannot yet be mounted:
/home: waiting for UUID=91ee524a-0bde-49b1-b702-1c2522a33e3b
swap: waiting for UUID=1fd42c84-55e7-4edb-b30d-d889d834f2d5
Press ESC to enter a recovery shell


Via een live cd heb ik nog wat gegevens bemachtigd:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
138 heads, 12 sectors/track, 141571 cylinders
Units = cylinders of 1656 * 512 = 847872 bytes
Disk identifier: 0x4c2cd691

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               2        6185     5120000   1c  Hidden W95 FAT32 (LBA)
/dev/sda2   *        6185       64373    48179196    7  HPFS/NTFS
/dev/sda3           64374      141570    63919116    f  W95 Ext'd (LBA)
/dev/sda5           87418      127600    33270784    7  HPFS/NTFS
/dev/sda6          127601      141570    11567154   83  Linux
ubuntu@ubuntu:~$

Blijkbaar worden sda7 (swap) en sda8 (/home) dus niet meer gezien?

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda6 during installation
UUID=56f48702-2e4a-4c2f-a9d1-0cc43e1f3cd3 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=91ee524a-0bde-49b1-b702-1c2522a33e3b /home           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=1fd42c84-55e7-4edb-b30d-d889d834f2d5 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0


Ik vraag hier toch liever even advies voor voordat dadelijk alles in puin ligt. Weet iemand misschien hoe dit op te lossen valt?

Edit: Home en swap lijken gewoon verwijderd te zijn? Link naar screenshot: http://i42.tinypic.com/33ttgyd.png


« Laatst bewerkt op: 2010/04/04, 00:43:52 door Robertos »

Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op na opnieuw installeren van GRUB 2
« Reactie #1 Gepost op: 2010/04/04, 00:43:24 »
Probleem opgelost.

Nieuwe home partitie en swap aangemaakt, /etc/fstab aangepast en een backup teruggezet.
Het is nog steeds een vraagteken waarom die twee partities verwijderd zijn, maar met MS verbaast me eigenlijk niets meer.