Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 10.04 beta 1 start alleen met 'nomodeset'  (gelezen 1893 keer)

Offline itavero

  • Lid
    • Find me on several social networks (using DandyID)
  • Steunpunt: Nee
Ubuntu 10.04 beta 1 start alleen met 'nomodeset'
« Gepost op: 2010/03/29, 11:36:22 »
Hoi allemaal,

Na een tijd alleen nog maar met Mac OSX gewerkt te hebben, besloot ik om toch weer eens een Ubuntu machine neer te zetten.
Daarvoor heb ik de nieuwste 64-bits installatie DVD (dus niet de CD) gedownload en heb hem vannacht geïnstalleerd..
Een paar keer zelfs, omdat het systeem steeds niet wilde starten; er kwam een knipperende cursor linksboven in het scherm en 5 uur later stond die daar nog steeds.

Na wat Google'n zag ik dat iemand anders ongeveer hetzelfde probleem had en dit had "opgelost" door nomodeset in GRUB toe te voegen.
Als ik het goed begrijp gebruikt het systeem dan oudere/generic drivers, die dus wellicht ook zorgen voor minder functionaliteit en langzamer werken?

Wat ik me nu afvraag is hoe ik er achter kan komen welke driver dan precies het probleem geeft dat het systeem niet boot.

Ik heb de volgende hardware (zo uit het hoofd):
  • Moederbord: ASUS Maximus II Formula
  • Geheugen: 4 * 2GB Patriot DDR2 1066Mhz
  • CPU: Intel Core 2 Quad Q9550
  • HDD's: WD Raptor 36GB / WD Raptor 74GB / WD 300GB
  • DVD: Samsung CD/DVD writer (SATA) -geen idee welk type precies-
  • Grafische kaart: Sapphire HD3850 512MB
Ik heb ook een lshw dump gemaakt, die staat hier:
http://dl.dropbox.com/u/2246482/hardware.html

Hopelijk kunnen jullie me wat verder helpen.
Alvast bedankt!

Arno

PS: Ik heb net alle updates laten installeren en het boot-screen is nu veranderd van 'ubuntu' naar 'lubuntu', is dat normaal?
« Laatst bewerkt op: 2010/03/29, 11:41:05 door itavero »

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 beta 1 start alleen met 'nomodeset'
« Reactie #1 Gepost op: 2010/03/29, 14:13:08 »
Eerst en vooral welkom op dit forum.  ^-^

Een paar keer zelfs, omdat het systeem steeds niet wilde starten; er kwam een knipperende cursor linksboven in het scherm en 5 uur later stond die daar nog steeds.
Dat is inderdaad niet het gewenste gedrag van Ubuntu. :)

Na wat Google'n zag ik dat iemand anders ongeveer hetzelfde probleem had en dit had "opgelost" door nomodeset in GRUB toe te voegen.
Als ik het goed begrijp gebruikt het systeem dan oudere/generic drivers, die dus wellicht ook zorgen voor minder functionaliteit en langzamer werken?
'nomodeset' zou niet gezien mogen worden als een oplossing, maar eerder als een work-around om daarna een oplossing toe te passen. Meestal wordt er 'nomodeset' meegegeven om het systeem toch geboot te krijgen zonder dat de desbetreffende problematische driver wordt geladen om die daarna in het gebootte systeem te vervangen. Zo zie je dat er nu veel mensen last hebben met de nieuwe nouveau driver -> mensen booten met 'nomodeset', verwijderen nouveau, installeren de gesloten driver van nvidia zelf, herbooten met default opties en werkt terug.
Dus als je 'nomodeset' toevoegt aan je boot-line wat krijg je dan? Boot het systeem dan inderdaad, of heeft dit geen effect? (Ikzelf heb wat grafische problemen met de lucid beta 1 en nomodeset helpt bij mij voor geen meter... dus het is niet gegarandeerd dat het werkt ;) )

Wat ik me nu afvraag is hoe ik er achter kan komen welke driver dan precies het probleem geeft dat het systeem niet boot.
Wel dat is inderdaad het lastige natuurlijk. Wat je dan proberen te doen is hem booten zonder 'nomodeset' en van zodra hij "vast zit" proberen van virtuele terminal te switchen. Dit doe je door de toestencombinatie Ctrl+Alt+F[2-6] te drukken (dus kies F2 of F3 of F4 of F5 of F6 maakt niet uit welke). Je zou dan mogelijks een commandline te zien krijgen waarin je commando's kan uitvoeren. Als je dat krijgt kan je bijvoorbeeld met het commando dmesg al een groot deel van je boot log bekijken.

En vermits het booten niet werk, ga je dus iets moeten veranderen aan de boot-opties om de nodige aanpassingen te kunnen doen. Ubuntu Documentation - Bootoptions is rijkelijk gevuld met een heleboel mogelijkheden. Neem ze eens rustig door en probeer uit te zoeken welke relevant voor jou zijn. Voor nog meer opties zie de Kernel Documentation - Kernel parameters.

En misschien nog een tip. Je zou het testen ook kunnen doen tijdens een live-sessie. Bespaart je de installatie tijd ;)

Ik heb de volgende hardware (zo uit het hoofd):
  • Moederbord: ASUS Maximus II Formula
  • Geheugen: 4 * 2GB Patriot DDR2 1066Mhz
  • CPU: Intel Core 2 Quad Q9550
  • HDD's: WD Raptor 36GB / WD Raptor 74GB / WD 300GB
  • DVD: Samsung CD/DVD writer (SATA) -geen idee welk type precies-
  • Grafische kaart: Sapphire HD3850 512MB
Ik heb ook een lshw dump gemaakt, die staat hier:
http://dl.dropbox.com/u/2246482/hardware.html
Dat is een mooi high-end systeempje. Als ik mag vragen, waarom geen SSD als bootschijf erin gestoken?

PS: Ik heb net alle updates laten installeren en het boot-screen is nu veranderd van 'ubuntu' naar 'lubuntu', is dat normaal?
Het is nog steeds in ontwikkelings-fase. Vanalle scheve dingen zijn normaal dan :)
BTW: Lubuntu is een light-weight versie van Ubuntu met LXDE.
« Laatst bewerkt op: 2010/03/29, 14:14:56 door ShadowDragon »
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline itavero

  • Lid
    • Find me on several social networks (using DandyID)
  • Steunpunt: Nee
Re: Ubuntu 10.04 beta 1 start alleen met 'nomodeset'
« Reactie #2 Gepost op: 2010/03/29, 15:25:45 »
Eerst en vooral welkom op dit forum.  ^-^

Dank je! :D

Wat ik me nu afvraag is hoe ik er achter kan komen welke driver dan precies het probleem geeft dat het systeem niet boot.
Wel dat is inderdaad het lastige natuurlijk. Wat je dan proberen te doen is hem booten zonder 'nomodeset' en van zodra hij "vast zit" proberen van virtuele terminal te switchen. Dit doe je door de toestencombinatie Ctrl+Alt+F[2-6] te drukken (dus kies F2 of F3 of F4 of F5 of F6 maakt niet uit welke). Je zou dan mogelijks een commandline te zien krijgen waarin je commando's kan uitvoeren. Als je dat krijgt kan je bijvoorbeeld met het commando dmesg al een groot deel van je boot log bekijken.

En vermits het booten niet werk, ga je dus iets moeten veranderen aan de boot-opties om de nodige aanpassingen te kunnen doen. Ubuntu Documentation - Bootoptions is rijkelijk gevuld met een heleboel mogelijkheden. Neem ze eens rustig door en probeer uit te zoeken welke relevant voor jou zijn. Voor nog meer opties zie de Kernel Documentation - Kernel parameters.

En misschien nog een tip. Je zou het testen ook kunnen doen tijdens een live-sessie. Bespaart je de installatie tijd ;)

Als ik me niet vergis dien je die opties, zoals nomodeset, toch iedere boot opnieuw in te geven als je, net als ik dit via het GRUB menu hebt toegevoegd (via de 'e'-toets). De opties werken dan toch alleen die 'sessie'?
Want gek genoeg heb ik het net niet opgegeven en start de machine nu wel gewoon op (de vorige keer had ik het er dus wel bij staan)?

Ik heb als nog dmesg > dmesgdump.txt even uitgevoerd en ben de file nu aan het bekijken.. Dusver ziet alles er normaal uit.

Ik heb de volgende hardware (zo uit het hoofd):
  • Moederbord: ASUS Maximus II Formula
  • Geheugen: 4 * 2GB Patriot DDR2 1066Mhz
  • CPU: Intel Core 2 Quad Q9550
  • HDD's: WD Raptor 36GB / WD Raptor 74GB / WD 300GB
  • DVD: Samsung CD/DVD writer (SATA) -geen idee welk type precies-
  • Grafische kaart: Sapphire HD3850 512MB
Ik heb ook een lshw dump gemaakt, die staat hier:
http://dl.dropbox.com/u/2246482/hardware.html
Dat is een mooi high-end systeempje. Als ik mag vragen, waarom geen SSD als bootschijf erin gestoken?
Nou, ik draaide er eerst Windows 7 Pro op, die heeft nogal wat schijfruimte nodig en dan werd dat nogal een duur grapje (en de pc was al duur genoeg).
Ongeveer een half jaar later heb ik een MacBook Pro gekocht en sindsdien lag dit systeempje voornamelijk stof te happen (zonde eigenlijk!).
Dus ik dacht ach, laat ik hem maar om toveren tot back-up pc / multimedia center (hopelijk krijg ik straks Boxee geinstalleerd).
Ik denk dat ik Windows 7 o.i.d. nog wel als virtual machine ga draaien, is wel ooit handig als ik wat voor Windows moet programmeren.
Wellicht dat ik in de toekomst nog wel een SSD koop, Ubuntu is gelukkig iets kleiner dan Windows 7.

Offline ShadowDragon

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04 beta 1 start alleen met 'nomodeset'
« Reactie #3 Gepost op: 2010/03/29, 16:15:57 »
Als ik me niet vergis dien je die opties, zoals nomodeset, toch iedere boot opnieuw in te geven als je, net als ik dit via het GRUB menu hebt toegevoegd (via de 'e'-toets). De opties werken dan toch alleen die 'sessie'?
Op die manier is die optie enkel van kracht tijdens die 'sessie', inderdaad. Maar je kan het ook permanent maken door je /etc/default/grub aan te passen, als je dat wilt.

Want gek genoeg heb ik het net niet opgegeven en start de machine nu wel gewoon op (de vorige keer had ik het er dus wel bij staan)?
Dus, je systeem start nu wel op, zonder de 'nomodeset'. Dat is mooi, zo hoort het :)

Ik heb als nog dmesg > dmesgdump.txt even uitgevoerd en ben de file nu aan het bekijken.. Dusver ziet alles er normaal uit.
Als jouw systeem gewoon bootte, ga je daar waarschijnlijk niet veel in vinden. Maar er kan natuurlijk altijd wel een kleine hint in zitten wie weet. :)

Nou, ik draaide er eerst Windows 7 Pro op, die heeft nogal wat schijfruimte nodig en dan werd dat nogal een duur grapje (en de pc was al duur genoeg).
Ongeveer een half jaar later heb ik een MacBook Pro gekocht en sindsdien lag dit systeempje voornamelijk stof te happen (zonde eigenlijk!).
Dus ik dacht ach, laat ik hem maar om toveren tot back-up pc / multimedia center (hopelijk krijg ik straks Boxee geinstalleerd).
Ik denk dat ik Windows 7 o.i.d. nog wel als virtual machine ga draaien, is wel ooit handig als ik wat voor Windows moet programmeren.
Wellicht dat ik in de toekomst nog wel een SSD koop, Ubuntu is gelukkig iets kleiner dan Windows 7.
Ah kijk daar is dus duidelijk over nagedacht. De kost blijft inderdaad nog een issue, hoewel een volledige Windows 7 Pro + wat applicaties wel op een 30-40 GB schijf zou moeten kunnen passen, en de data op een HDD.
Xubuntu 11.04 - Xfce 4.8 - SSD Vertex 2 (Extended) 60 GB

Offline itavero

  • Lid
    • Find me on several social networks (using DandyID)
  • Steunpunt: Nee
Re: Ubuntu 10.04 beta 1 start alleen met 'nomodeset'
« Reactie #4 Gepost op: 2010/03/29, 21:09:42 »
Als ik me niet vergis dien je die opties, zoals nomodeset, toch iedere boot opnieuw in te geven als je, net als ik dit via het GRUB menu hebt toegevoegd (via de 'e'-toets). De opties werken dan toch alleen die 'sessie'?
Want gek genoeg heb ik het net niet opgegeven en start de machine nu wel gewoon op (de vorige keer had ik het er dus wel bij staan)?

Ik heb als nog dmesg > dmesgdump.txt even uitgevoerd en ben de file nu aan het bekijken.. Dusver ziet alles er normaal uit.

Na nog wat updates en installaties blijft hij nu weer op een knipperende cursor hangen.
Switchen naar een terminal met Ctrl + Alt + Functietoets werkt helaas niet.
De Live CD boot overigens wel gewoon; welke mogelijkheden heb ik nu om te debuggen?

Arno

Edit (1):
Het probleem zit 'm duidelijk ergens anders in.
Als ik via het Boot Device Selection menu van mijn BIOS expliciet aangeef de Ubuntu schijf te willen starten, start het systeem wel op.
Lijkt er op dat ie, ondanks wat ik in de BIOS heb ingesteld, toch een andere schijf probeert te booten.
Ik ga m'n BIOS instellingen maar eens doorspitten!

Edit (2):
Zal wel een 'glitch' van de BIOS geweest zijn; na het veranderen van de volgorde en hem vervolgens weer goed gezet te hebben werkt het nu prima.
Systeem start in minder dan 30 seconden volledig op (en ik heb al wat meuk geinstalleerd)..
Ben benieuwd of de definitieve release nog sneller wordt, zou mooi zijn!
« Laatst bewerkt op: 2010/03/29, 21:44:50 door itavero »