Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [SOLVED] Toshiba T130-10V  (gelezen 3574 keer)

Offline nicorp

  • Lid
  • Steunpunt: Nee
[SOLVED] Toshiba T130-10V
« Gepost op: 2010/03/19, 14:23:28 »
Goede middag!

Na vele uren zoeken en honderden pagina's te hebben gelezen, leg ik mij er maar bij neer dat ik hier niet zelf uitkom...
Ik heb onlangs een Toshiba T130-10V aangeschaft, welke een Atheros AR8132 / L1c Gigabit Ethernet Adapter heeft voor bedraad internet en een Realtek RTL819SE-VA2 Wireless voor draadloos internet.

Momenteel heb ik Ubuntu 9.10 Karmic Koala 32bit op deze laptop staan en wat ik ook probeer, ik krijg geen van de netwerkkaarten werkend! :-(

Wat ik uiteindelijk voor elkaar heb gekregen is het volgende:
- Systeem > Beheer > Hardwarestuurprogramma's > toont het volgende: "Linux driver for Realtek RTL819x WiFi cards". Deze staat als "geactiveerd en in gebruik" gemarkeerd.
- Systeem > Beheer > Netwerkhulpmiddelen > bij de netwerkapparaten verscheen uiteindelijk de optie "Wireless interface (wlan2)". Het merkwaardige is dat het "wlan" nummer voortdurend oploopt.

Van mijn Atheros kaart zie ik helemaal niets terug, behalve in de terminal met commando "lshw -c network". Deze geeft "network UNCLAIMED" aan. Verdere info wil ik op verzoek wel even overnemen, maar omdat ik niet online kan moest ik dit bericht even vanaf een andere machine tikken...

Ik ben begonnen met een 64 bit versie van CentOS 5.4. Daar kreeg ik de Atheros prima aan de praat, maar het draadloos bleek een ramp. En vrijwel alle oplossingen die er op internet hangen bleken voor Ubuntu te zijn, waardoor ik de overstap maakte naar Ubuntu 9.10 64 bit.
Uiteindelijk kwam ik allemaal berichten tegen dat mensen het eens moesten proberen op een 32 bit distro, omdat daar betere ondersteuning voor zou zijn. Later werd beweerd dat er op de Karmic Koala versie meer ondersteuning was ingebouwd. Afijn, ik weer gaan zoeken naar die distro. Bleek op een DVD te staan in plaats van een CD, maar het enige verschil dat ik tot nu toe heb opgemerkt is dat de installatie wat langer duurt...

Helemaal ten einde raad toch maar op dit forum aangeklopt, in de hoop dat hier iemand is die aan iets denkt wat ik al de hele tijd over het hoofd zie. ;-)

Momenteel gewijzigd na de kale installatie:
- rtl8192se_linux_2.6.0015.0127.2010.tar.gz geïnstalleerd volgens bijgeleverde "readme" (gaf wel fouten)
- AR81Family-linux-v1.0.1.6.tar.gz geïnstalleerd volgens bijgeleverde "readme", tot zover deze klopte... (niet afgerond?)

Alvast heel erg bedankt voor de hulp!
« Laatst bewerkt op: 2010/03/23, 02:17:23 door nicorp »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
In der Beschränkung zeigt sich der Meister.

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #2 Gepost op: 2010/03/19, 14:38:13 »
Die pagina's ben ik gaandeweg tegengekomen, maar hebben mij ook niet kunnen helpen.

De eerste is voor mij niet van toepassing, Windows is volledig van die laptop vertrokken.
De tweede kan ik pas uitvoeren als internet via een draad werkt en ik heb stiekem de hoop dat draadloos dan een kwestie is van die stappen doorlopen...

Er branden overigens ook geen lampjes op mijn switch als ik de laptop er op aansluit. Voor de zekerheid heb ik de kabel verwisseld, maar dat veranderde niets.

--- EDIT

Bij CentOS was het overigens een kwestie van "kmod-atl1e-1.0.1.0-3.el5.elrepo.i686.rpm" installeren, toen werkte de Atheros adapter. Is er een mogelijkheid om met de basistools van Ubuntu een .RPM bestand te gebruiken?
« Laatst bewerkt op: 2010/03/19, 15:08:10 door nicorp »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Toshiba T130-10V
« Reactie #3 Gepost op: 2010/03/19, 19:00:54 »
Ja, dan moet je alien installeren, deze kan een rpm omzetten naar een deb, of gelijk installeren.
Het werkt met de terminal bijv alien - i naampakket.rpm installeert direct het pakket. Zie voor andere opties
man alien

Wat is de uitkomst van lspci | grep Ethernet

« Laatst bewerkt op: 2010/03/19, 19:08:30 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #4 Gepost op: 2010/03/20, 11:20:14 »
Is er een manier om aan Alien te komen buiten "apt-get" om?
Dan kan ik het via mijn andere computer downloaden en via USB op de laptop zetten.

En is dit een poging waard, of zal een Red Hat driver niet omgezet worden naar een werkende variant voor Ubuntu?

Zit nu ff mobiel online op een verjaardag, ik zal z.s.m. de resultaten van dat commando doorgeven. :-)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Toshiba T130-10V
« Reactie #5 Gepost op: 2010/03/20, 14:10:45 »
Je kan ook via http://packages.ubuntu.com/ alien verkrijgen. Een stukje naar beneden scrollen. Daar alien invullen en de juiste distributie kiezen.
In der Beschränkung zeigt sich der Meister.

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #6 Gepost op: 2010/03/22, 08:38:37 »
lspci | grep Ethernet:
07:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)

Ben intussen druk bezig met die Alien, maar die heeft steeds weer een ander pakket nodig voordat ik hem kan installeren...
Net "debhelper", nu "kpkg-dev", ben benieuwd wat de volgende is.  =D

--- EDIT

Op die "kpkg-dev" loop ik helaas vast.
Citaat
Sorry, your search gave no results
« Laatst bewerkt op: 2010/03/22, 08:40:20 door nicorp »

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #7 Gepost op: 2010/03/22, 09:35:29 »
Hier een Asus Eee 1101AH met Ubuntu 9.10 en een
Citaat
03:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)
Werkt direct.

groet,

Theo

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #8 Gepost op: 2010/03/22, 13:41:43 »
@softbart

Als ik klompen had, zouden ze nu breken.  ???
Draait op jouw ASUS een 32bit of 64bit Ubuntu?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Toshiba T130-10V
« Reactie #9 Gepost op: 2010/03/22, 14:20:17 »
lspci | grep Ethernet:
07:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)

Ben intussen druk bezig met die Alien, maar die heeft steeds weer een ander pakket nodig voordat ik hem kan installeren...
Net "debhelper", nu "kpkg-dev", ben benieuwd wat de volgende is.  =D

--- EDIT

Op die "kpkg-dev" loop ik helaas vast.
Citaat
Sorry, your search gave no results
Als je het pakket alien installeert via Synaptic, worden automatisch alle benodigde pakketten geïnstalleerd. Dat gebeurt dus niet als je een pakket van Ubuntu packages haalt, dan zal je de benodigde pakketten, daar ook op moeten halen. Je ziet geen kans om ergens op een bekabeld internet te komen? Zou het makkelijkst zijn.
In der Beschränkung zeigt sich der Meister.

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #10 Gepost op: 2010/03/22, 16:06:34 »
Als het internet via een draad zou werken zou ik inderdaad een stuk verder komen.  :-[
Ik installeer nu weer even CentOS om te kijken of die kaart wel echt werkt, of dat deze misschien 'ineens' defect is o.i.d., mocht dat werken probeer ik het toch maar weer eens met Ubuntu 64bit.

Keep you informed, in ieder geval bedankt voor alle hulp tot nu toe!  =D

--- EDIT

Goed, in CentOS werkt de netwerkkaart naar behoren, dus deze is niet defect. Blijft raar dat deze helemaal geen lampjes geeft op de switch als ik de kabel verbindt met een Ubuntu machine, maar ik ga nu de 64bit versie er eens overheen gooien.
En dan maar hopen dat die laptop een keer gaat werken, haha.
« Laatst bewerkt op: 2010/03/22, 16:47:38 door nicorp »

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #11 Gepost op: 2010/03/22, 17:38:06 »
@softbart

Als ik klompen had, zouden ze nu breken.  ???
Draait op jouw ASUS een 32bit of 64bit Ubuntu?
32bit

groet,

Theo

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #12 Gepost op: 2010/03/22, 17:47:56 »
@softbart/Theo

Thnx. Ik gebruikte ook 32bit, maar krijg de Atheros kaart met geen mogelijkheid werkend.  ???

Heb nu de 64bit draaien, werkt de kaart ook totaal niet. Systeem is ook aanzienlijk minder snel, dus ik gooi toch maar weer die 32bit erop... Was te proberen...  :'(

--- EDIT

Is er een alternatief voor dit geintje? Drivers die niet werken zijn vermoeiend.  ;)
« Laatst bewerkt op: 2010/03/22, 17:51:34 door nicorp »

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #13 Gepost op: 2010/03/22, 17:55:54 »
Ik heb de Asus medio 10-2009 gekocht. Alleen Slackware met Mda-wifi wou draaien. Geen Debian en Ubuntu.
Ik kreeg jammer genoeg niet de video redelijk tot goed werkende.
Een paar dagen later kwam Ubuntu 9.10 uit. Heeft van meet aan goed gewerkt. Later door een werkende driver ook de video.

Misschien dat her-installeren helpt. De CD gecontroleerd?

roet,

Theo

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #14 Gepost op: 2010/03/22, 18:03:59 »
Ik heb Ubuntu meerdere malen opnieuw geïnstalleerd intussen, maar ben bang dat het een update kwestie is. Kan alleen niet updaten zonder internet.
Zowel 32bit als 64bit pakken de driver van Atheros niet "out-of-the-box". Hun handleiding klopt overigens ook niet, maar daar zijn alternatieven voor te vinden. (http://jan.ucc.nau.edu/wal2/atheros_attansic.html)

Het is raar dat Ubuntu de driver op een ASUS direct weet te vinden en op een Toshiba totaal niet. Heeft deze dan misschien toch een andere manier van aansturen?

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #15 Gepost op: 2010/03/22, 19:40:26 »
dhclient eth0:

Internet Systems Consortium DHCP Client V3.1.2
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth0: Error while getting interface flags: No such device
eth0: Error while getting interface flags: No such device
Bind socket to interface: No such device

Dit was weer een van de dingen die ik tegenkwam, misschien is er iemand die hier meer uit haalt als ik.  ;)

--- EDIT

Ander commando: ifup eth0:

Ignoring unknown interface eth0=eth0.
« Laatst bewerkt op: 2010/03/22, 19:46:08 door nicorp »

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #16 Gepost op: 2010/03/22, 22:19:05 »
De Atheros kaart werkt!
De oplossing die ik heb gevolgd, is op onderstaand adres te vinden.
http://www.ramoonus.nl/2010/02/25/linux-kernel-2-6-33-installation-guide-for-ubuntu-linux/

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #17 Gepost op: 2010/03/22, 23:31:44 »
De aanhouder wint.
2.6.33??
Ik moet de beta versie van Lucid nog uitpakken. Mogelijk dat deze de 2.6.33 bevat.

groet,

Theo

Offline nicorp

  • Lid
  • Steunpunt: Nee
Re: Toshiba T130-10V
« Reactie #18 Gepost op: 2010/03/22, 23:49:12 »
Haha, ik heb werkelijk geen idee. Ben nog helemaal "leek" op gebied van Ubuntu. Ik had wel ervaring met het bouwen van (web)servers in Linux (CentOS), maar dit blijkt dan toch weer totaal anders te zijn.
Heb er overigens geen spijt van dat ik naar de Ubuntu side ben overgewaaid, qua desktop is deze distributie echt veel mooier.

Goed, ik ga weer verder stoeien met mijn wireless. Zal ongetwijfeld een stuk makkelijker gaan nou de updates werken, haha. :D

--- EDIT

Dit berichtje type ik vanaf mijn laptop, DRAADLOOS! Na de update van de kernel wilde ook de standaard Realtek driver ineens werken.

Bron:
http://ubuntuforums.org/showpost.php?p=8723901&postcount=28
Actuele RTL8192SE driver van de website van Realtek gehaald, niet uit de downloads op deze website. Na de installatie even rebooten en klaar!  =D

Ik wil de personen die met me meegedacht hebben hartelijk bedanken voor hun tijd.
« Laatst bewerkt op: 2010/03/23, 02:16:20 door nicorp »