Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Opstarten 9.10 vreselijk traag  (gelezen 1202 keer)

Offline aartje

  • Lid
  • Steunpunt: Nee
[Opgelost] Opstarten 9.10 vreselijk traag
« Gepost op: 2010/03/15, 10:06:08 »
IK had op mijn reserve systeem (AMD Athlon 1440 XP+) al een jaar of tien
een dualboot win98/linux systeem staan. Het laatste prima werkende linux-
systeen was Ubuntu 8.10, maar ik wilde naar 9.10 wegens een niet
werkende TV-kaart (ALDI). Ik heb dat ge-installeerd (win98 op een 40GB disk,
ubuntu op een tweede 40 GB disk). De linux-disk heb ik gepartitioneerd
met oa een aparte /boot, swap, / en /home partitie (en de rest een aparte
datapartitie)
Wat me opvalt is dat het opstarten ontzettend traag geworden is, vooral bij
het opstarten blijft het systeem een minuut wachten met de melding
"GRUB loading" met continue disk-access (aan het disk-acces ledje te zien).
Daarna krijg je pas je keuzescherm.
Op een laptop (ook een oudje) waar ik ook 9.10 op heb ge-installeerd (het
enige operating system, dus niet dualboot) viel het me op dat het opstarten
wel sneller was geworden.

« Laatst bewerkt op: 2010/03/15, 11:07:17 door aartje »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Opstarten 9.10 vreselijk traag
« Reactie #1 Gepost op: 2010/03/15, 10:24:33 »
Mogelijk heeft hij moiete met het herkennen van je grafische kaarten. Mijn laptop start (veel) sneller op nu dan met vorige Ubuntu versies (scheelt meer dan de helft!). Als hij echter op een docking station aangesloten is, duurt het opstarten vier tot vijf minuten.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Opstarten 9.10 vreselijk traag
« Reactie #2 Gepost op: 2010/03/15, 10:32:06 »
De grafische kaart is een NVIDIA GeForce MX200 (of iets dergelijks),
toendertijd misschien wel de meest gebruikte kaart.

Offline Mark81

  • Lid
  • Steunpunt: Nee
Re: Opstarten 9.10 vreselijk traag
« Reactie #3 Gepost op: 2010/03/15, 10:41:52 »
Heb je ubuntu op dezelfde schijf als je MBR staan? Ofwel, staat in je BIOS dat je van disk 1 opstart terwijl op disk 2 ubuntu staat?

Zo niet, wat je kunt doen, is dan in ubuntu zelf grub installeren in de mbr van disk 2 (even ervan uitgaand dat daar ubuntu op staat). Dus stel, je start nu op van schijf A (/dev/sda), maar ubuntu staat op schijf B (/dev/sdb), installeer grub dan op die 2e: sudo grub-install /dev/sdb

Zet dan in je bios dat je systeem opstart van schijf 2 (!) en als het goed is, merk je echt een enorm verschil! Ik liep daar zelf ook al eens tegenaan (heb het als tip hier een keer gepost)...

Offline Mark81

  • Lid
  • Steunpunt: Nee
Re: Opstarten 9.10 vreselijk traag
« Reactie #4 Gepost op: 2010/03/15, 10:47:44 »
Nog even ter aanvulling:

Het probleem is bekend: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/420933

En de tip (2e post): http://ubuntugeek.com/forum/index.php?topic=15.0 (wat ik ook vertelde, maar dan iets beter (lees simpeler) uitgelegd!  ;)

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Opstarten 9.10 vreselijk traag
« Reactie #5 Gepost op: 2010/03/15, 11:28:06 »
Heel erg bedankt voor de reacties (supersnel).
"sudo grub-install /dev/sdb" deed het hem.
Nu komt wel gelijk het keuzemenu (het reageert alleen
lijkt wel niet meer op een ENTER, maar dat is secundair)
Er lijkt nog wel heel wat tijd in het mounten (en checken?)
van de fat32-filesystemen op sda (mijn win98 disk)
Het volgende beeld krijg ik een stuk 4 keer met lange
tussenposes. (zie bijlage). Maar hier zal ik zelf eerst
wat mee spelen (bv. veranderen van UUID naar /dev/sdb1 etc.
in fstab). En daar eventueel een andere topic van maken.