Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Grub.cfg wordt niet automatisch bijgewerkt  (gelezen 2804 keer)

Offline wowo

  • Lid
  • Steunpunt: Nee
[Opgelost] Grub.cfg wordt niet automatisch bijgewerkt
« Gepost op: 2010/03/13, 20:13:44 »
Grub.cfg wordt bij mij niet automatisch bijgewerkt. ???

Wat heb ik gedaan:
Ik heb mbv de start-up manager een aantal zaken aangepast:
1)Standaard besturingssysteem op Windows XP gezet
2) de wachttijd op 5 seconden gezet

De volgorde van mijn opstartscripts zijn:
Ubuntu, Linux 2.6.31-14-generic
Ubuntu, Linux 2.6.31-14-generic (recovery mode)
Memory test (memtest86+)
Memory test (memtest86+,serial code 115200)
Windows NT/2000/XP (on /dev/sda1)

Wanneer ik nu ga kijken in de /etc/default/grub zie ik dat dit correct is aangepast:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=4
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"

Wanneer ik echter in de grub.cfg ga kijken zie ik dat er niets is aangepast.
Wat als eerste opstart is default=0 (=Ubuntu, Linux 2.6.31-14-generic) en de wachttijd bedraagt 10 seconden.

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
  have_grubenv=true
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  saved_entry=${prev_saved_entry}
  save_env saved_entry
  prev_saved_entry=
  save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set ba194964-9d3f-40a9-9c35-2948a1303fa0
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-14-generic" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set ba194964-9d3f-40a9-9c35-2948a1303fa0
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro   quiet splash
initrd /boot/initrd.img-2.6.31-14-generic
}
menuentry "Ubuntu, Linux 2.6.31-14-generic (recovery mode)" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set ba194964-9d3f-40a9-9c35-2948a1303fa0
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro single
initrd /boot/initrd.img-2.6.31-14-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows NT/2000/XP (loader) (on /dev/sda1)" {
insmod ntfs
set root=(hd0,1)
search --no-floppy --fs-uuid --set 30348b5b348b2348
drivemap -s (hd0) ${root}
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

Wanneer ik de computer opnieuw opstart is dit natuurlijk ook wat grub uitvoert:
Besturingssysteem Ubuntu, Linux 2.6.31-14-generic na een wachttijd 10 seconden.

Wat is hier aan de hand ???
Hoe kan ik ervoor zorgen dat mijn wijzigingen doorgevoerd worden in de grub.cfg??

ps ik heb ook al "sudo update-grub uitgevoerd in een terminal-venster maar dat maakt ook niets uit. De grub.cfg wordt nog steeds niet gewijzigd.
« Laatst bewerkt op: 2010/03/14, 21:14:43 door wowo »
Desktop Ubuntu 16.04 LTS

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #1 Gepost op: 2010/03/13, 21:43:19 »
Allereerst even een andere vraag:
Waarom heb jij de -14 kernel? De -20 is al uit ???

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #2 Gepost op: 2010/03/13, 22:47:42 »
Allereerst even een andere vraag:
Waarom heb jij de -14 kernel? De -20 is al uit ???
Goede vraag, want dat zou er best mee te maken kunnen hebben.
Ik ben deze week een nieuwe ("dual boot") gebruiker van Ubuntu geworden en als ik het me goed herinner is er onlangs een update geweest met de melding dat -20 kernel niet geïnstalleerd kon worden. Toen heb ik de boel opnieuw opgestart in de recovery-mode en hier de gebroken packages hersteld.
Ook werd ergens in het proces de vraag gesteld of ik iets in de grub wilde laten staan.Hoewel ik de vraag niet echt begreep, heb ik hierop heb ja geantwoord.
Ik heb dan ook even gezien dat er in het grub opstartscherm de keuze gemaakt kon worden tussen 2 kernel versies: 20 en 14.
Nu zie ik deze keuze niet meer.
Er is volgens mij waarschijnlijk iets misgegaan tijdens de update.

De vraag is nu eerst:
Hoe kan ik mijn systeem updaten naar versie 20?
Wanneer ik update beheer draai, krijg ik als antwoord:
Uw systeem is up-to-date  ???
Desktop Ubuntu 16.04 LTS

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #3 Gepost op: 2010/03/14, 07:39:50 »
Zoek in Systeem-Beheer-Synaptic naar Linux-image-2.6.31-14-generic
Zoek daarna van hetzelfde type* de linux-image.....20-generic. Erop rechtsklikken en kiezen: markeren voor installatie. Daarna op Toepassen klikken.

Vervolgens synaptic sluiten en sudo update-grub uitvoeren. Daarna de opstartmanager opnieuw instellen (XP eerst en 5 seconden).

* x86 of x86_64 (dezelfde versie kiezen als die 14)

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #4 Gepost op: 2010/03/14, 10:20:54 »
Zoek in Systeem-Beheer-Synaptic naar Linux-image-2.6.31-14-generic
Zoek daarna van hetzelfde type* de linux-image.....20-generic. Erop rechtsklikken en kiezen: markeren voor installatie. Daarna op Toepassen klikken.

Vervolgens synaptic sluiten en sudo update-grub uitvoeren. Daarna de opstartmanager opnieuw instellen (XP eerst en 5 seconden).

* x86 of x86_64 (dezelfde versie kiezen als die 14)
Lexaldo bedankt voor je reactie, ik ben gelukkig nu al weer wat verder. :)

Ik heb in Synaptic gekeken en daar staan de beide images. ???
Linux-image-2.6.31-14-generic (Linux kernel image for version 2.6.31 on x86/x86_64)
Linux-image-2.6.31-20-generic (Linux kernel image for version 2.6.31 on x86/x86_64)

Ze zijn dus beiden al geinstalleerd, maar mijn computer ziet bij het opstarten alleen maar Linux-image-2.6.31-14-generic.
Hoe nu verder? ???
Desktop Ubuntu 16.04 LTS

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #5 Gepost op: 2010/03/14, 10:28:36 »
1. Open synaptic>Bewerken>Gebroken paketten repareren. Geeft dat winst?
2. Her-installeer -20
3. Staat de grub misschien op meerdere hdd's? Dat kan je checken door gparted te starten, en alle partities en hdds langs te gaan. Als het goed is, is er maar 1 met de boot flag.
4. Open eens een terminal (toepassingen>hulpmiddelen>terminalvenster) en type
sudo apt-get update && sudo apt-get upgradekrijg je dan updates te installeren?

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #6 Gepost op: 2010/03/14, 10:30:22 »
Ga naar Synaptic en selecteer in Status "installed".

Geef nu in Quick Search "2.6.31-20" in (zonder aanhalingstekens). Als deze kernel geinstalleerd is verschijnen er drie packages: headers, headers generic en image. Klik rechts op alle drie packages en selecteer "reinstall".

Als Synaptic begint te installeren open dan de terminal in Synaptic en houd in de gaten of op het einde van de installatie een "initramfs" wordt uitgevoerd.
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #7 Gepost op: 2010/03/14, 11:29:23 »
1. Open synaptic>Bewerken>Gebroken paketten repareren. Geeft dat winst?
Nee. :(

2. Her-installeer -20
Uitgevoerd, maar grub laat bij het opstarten nog steeds alleen Linux-image-2.6.31-14-generic zien.

3. Staat de grub misschien op meerdere hdd's? Dat kan je checken door gparted te starten, en alle partities en hdds langs te gaan. Als het goed is, is er maar 1 met de boot flag.
Grub staat niet op meerdere hdd's. Alsik gparted gebruik zie ik:
/dev/sda1 NFTS met de bootflag staan
/dev/sda2 extended met daarin /dev/sda5 (ext4) en /dev/sda6 (linux-swap). Al dezen hebben geen bootflag.
4. Open eens een terminal (toepassingen>hulpmiddelen>terminalvenster) en type
sudo apt-get update && sudo apt-get upgradekrijg je dan updates te installeren?
Neen. Er worden geen pakketen opgewaardeerd of nieuw geinstalleerd.

Bedankt voor je hulp tot dusver, maar er is helaas nog niets veranderd.
Grub blijft hardnekkig alleen Linux-image-2.6.31-14-generic zien
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #8 Gepost op: 2010/03/14, 11:46:26 »
Ga naar Synaptic en selecteer in Status "installed".

Geef nu in Quick Search "2.6.31-20" in (zonder aanhalingstekens). Als deze kernel geinstalleerd is verschijnen er drie packages: headers, headers generic en image. Klik rechts op alle drie packages en selecteer "reinstall".

Als Synaptic begint te installeren open dan de terminal in Synaptic en houd in de gaten of op het einde van de installatie een "initramfs" wordt uitgevoerd.
Als ik in het venster kijk bij de herinstallatie zie ik:
update-initramfs: Generating /boot/initrd.img-2.6.31-20-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.31-20.57 was configured last, according to dpkg)

Running postinst hook scripts /sbin/update-grub
Searching for default file ... found:/boot/grub/default
Testing for an existing GRUB menu.lst ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping...
Found kernel: /boot/vmlinuz-2.6.31-20-generic
Found kernel: /boot/vmlinuz-2.6.31-14-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done
(nb er kunnen wat typfouten instaan want ik kon de tekst niets kopiëren en plakken.)

Grub wordt, denk ik, op een of andere manier toch niet goed geupdated.
Hoe nu verder. ???
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #9 Gepost op: 2010/03/14, 11:54:32 »
Hopelijk helpt ook de inhoud van menu.lst tot het vinden van de oplossing voor mijn probleem:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=ba194964-9d3f-40a9-9c35-2948a1303fa0

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## specify if running in Xen domU or have grub detect automatically
## update-grub will ignore non-xen kernels when running in domU and vice versa
## e.g. indomU=detect
##      indomU=true
##      indomU=false
# indomU=detect

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 9.10, kernel 2.6.31-20-generic
uuid ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/vmlinuz-2.6.31-20-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro quiet splash
initrd /boot/initrd.img-2.6.31-20-generic

title Ubuntu 9.10, kernel 2.6.31-20-generic (recovery mode)
uuid ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/vmlinuz-2.6.31-20-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro  single
initrd /boot/initrd.img-2.6.31-20-generic

title Ubuntu 9.10, kernel 2.6.31-14-generic
uuid ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/vmlinuz-2.6.31-14-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro quiet splash
initrd /boot/initrd.img-2.6.31-14-generic

title Ubuntu 9.10, kernel 2.6.31-14-generic (recovery mode)
uuid ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/vmlinuz-2.6.31-14-generic root=UUID=ba194964-9d3f-40a9-9c35-2948a1303fa0 ro  single
initrd /boot/initrd.img-2.6.31-14-generic

title Chainload into GRUB 2
root ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/grub/core.img

title Ubuntu 9.10, memtest86+
uuid ba194964-9d3f-40a9-9c35-2948a1303fa0
kernel /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST
Desktop Ubuntu 16.04 LTS

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #10 Gepost op: 2010/03/14, 12:06:39 »
Testing for an existing GRUB menu.lst ... found: /boot/grub/menu.lst

Er staat nog een restantje van Grub en dat gaat Grub2 gebruiken  ??? Zijn wij nu met Grub of Grub2 bezig ?
« Laatst bewerkt op: 2010/03/14, 12:09:51 door timosha »
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #11 Gepost op: 2010/03/14, 12:16:48 »
Testing for an existing GRUB menu.lst ... found: /boot/grub/menu.lst

Er staat nog een restantje van Grub en dat gaat Grub2 gebruiken  ??? Zijn wij nu met Grub of Grub2 bezig ?
Tja, ik ben nog een Ubuntu-leek.
Maar zoals ik het tot nu toe begrijp, is er dus iets foutiefs in menu.lst geschreven wat Grub2 gaat gebruiken om een nieuwe Grub aan te maken.

Kan ik veilig de menu.lst verwijderen en dan de herinstallatie weer gewoon uitvoeren?
Dan zal Grub2 dit bestand niet vinden en alles vervolgens weer normaal zijn?
Desktop Ubuntu 16.04 LTS

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #12 Gepost op: 2010/03/14, 12:21:05 »
Hernoem dat bestand in menu.lst in menu.lstOUD (of zoiets) en voer nog een sudo update-grub uit
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #13 Gepost op: 2010/03/14, 12:24:56 »
Hernoem dat bestand in menu.lst in menu.lstOUD (of zoiets) en voer nog een sudo update-grub uit
Ik zal dit later gaan proberen,maar ik moet nu helaas weg.
Overigens als ik in Synaptic pakketbeheer kijk zie ik alsik zoek op Grub:
- grub
- grub-common
- startupmanager
- memtest86+
Desktop Ubuntu 16.04 LTS

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #14 Gepost op: 2010/03/14, 12:29:41 »
Dan gebruik je Grub en niet Grub2. Voor Ubuntu 9.10 is Grub2 de standaard.
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Grub.cfg wordt niet automatisch bijgewerkt
« Reactie #15 Gepost op: 2010/03/14, 21:04:08 »
Dan gebruik je Grub en niet Grub2. Voor Ubuntu 9.10 is Grub2 de standaard.
Je hebt gelijk.
Met "grub-install -v" in een terminal venster gaf hij GRUB versienummer 0.97 aan. Dit is dus Grub.
Vervolgens:
"sudo apt-get install grub-pc" uitgevoerd.
De configuratie-schermen die ik vervolgens te zien kreeg kwamen niet overeen met hetgeen ik in de documentatie Upgraden naar GRUB 2 zag.
Er kwam onder andere een melding dat er iets handmatig was aangepast en ik heb toen gekozen om de "versie van de pakketbeheerder" te installeren.
Na herstarten was alles in orde:
Kernel -20 en Kernel-14 zijn in het opstartscherm te zien en Grub2 reageert (weer) op de wijzigingen die ik aanbreng in de "Opstart-Manager"
Hoe het precies gekomen is weet ik niet, maar het belangrijkste is dat alles weer werkt zoals het hoort. :)
Hierbij bedank ik Timosha, TopGear en Lexaldo voor hun snelle en accurate hulp.
Ik heb er veel van opgestoken.

Op naar de volgende probleempjes: "Interne Laptop-Webcam en koptelefoonuitgang" aan de gang kolgende rijgen.
Maar daar zal ik pas over een week aan toe komen. Eerst even een weekje ertussenuit. :D

« Laatst bewerkt op: 2010/03/14, 21:11:07 door wowo »
Desktop Ubuntu 16.04 LTS