Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?  (gelezen 3727 keer)

Offline mamu76

  • Lid
  • Steunpunt: Nee
Hallo beste Ubuntugebruikers,

Na veel lezen en proberen is het me nog steeds niet gelukt om mijn beeldschermresolutie te veranderen naar 1024x768. Het maximale is 800x600. Na altijd Windows gehad te hebben ben ik sinds vorige week overgstapt op Ubuntu en tot nu toe tevreden alleen baal van de beeldschermresolutie.
Ben een nobody op het gebied van Ubuntu en probeer zo veel mogelijk te leren dus alle hulp is welkom.

Hoor graag van jullie.

Alvast bedankt,

Groeten,

Mark

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #1 Gepost op: 2010/03/05, 16:06:21 »
Allereerst een hartelijk welkom : )

De beeldresolutie kan afhankelijk zijn van de werking van de driver van de videokaart. Weet je misschien welke videokaart er in de computer zit? is er een driver ingeschakeld via Systeem -> beheer -> Hardwarestuurprogramma's ?

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #2 Gepost op: 2010/03/05, 16:47:29 »
Welke grafische chip of videokaart zit er in Uw computer? Zonder die informatie kan er niet geholpen worden.
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Geert Jalink

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #3 Gepost op: 2010/03/05, 22:00:15 »
Je kan kijken welke hardware in je computer zit, wat is de uitkomst van onderstaande commando's? Hoofdmenu->Systeem->Terminal
(ik zit op Kubuntu daar is het anders, zeg ik het goed?)

In de terminal:

  lspci

Dit geeft weer welke PCI devices je hebt waaronder je videokaart.

Voorbeeld van de uitvoer van dit commando:
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation GT200b [GeForce GTX 275] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
04:01.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)
motion@home:~$ sudo apt-get install steam

Offline mamu76

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #4 Gepost op: 2010/03/06, 10:20:19 »
Hallo,

Bedankt alvast voor jullie hulp. Heb via het commando wat ik van jullie doorkreeg het volgende doorgekregen.

00:00.0 Host bridge: nVidia Corporation nForce CPU bridge (rev b2)
00:00.1 RAM memory: nVidia Corporation nForce 220/420 Memory Controller (rev b2)
00:00.2 RAM memory: nVidia Corporation nForce 220/420 Memory Controller (rev b2)
00:00.3 RAM memory: nVidia Corporation nForce 420 Memory Controller (DDR) (rev b2)
00:01.0 ISA bridge: nVidia Corporation nForce ISA Bridge (rev c3)
00:01.1 SMBus: nVidia Corporation nForce PCI System Management (rev c1)
00:02.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
00:03.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
00:04.0 Ethernet controller: nVidia Corporation nForce Ethernet Controller (rev c2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce AC'97 Audio Controller (rev c2)
00:06.1 Modem: nVidia Corporation nForce AC'97 Modem Controller (rev c1)
00:08.0 PCI bridge: nVidia Corporation nForce PCI-to-PCI bridge (rev c2)
00:09.0 IDE interface: nVidia Corporation nForce IDE (rev c3)
00:1e.0 PCI bridge: nVidia Corporation nForce AGP to PCI Bridge (rev b2)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
02:00.0 VGA compatible controller: nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics] (rev b1)

Ik hoor graag van jullie hoe nu verder.


BVD.

Mark

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #5 Gepost op: 2010/03/06, 10:37:36 »
Probeer het volgende eens:

Open een terminal en geef het volgende commando in:

gksu gedit /etc/default/grub

Vervang de regel :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
door
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Wijziging opslaan.

Dan nog steeds in de terminal:
sudo update-grub

dan herstarten
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline jvd

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #6 Gepost op: 2010/03/06, 12:20:25 »
volgens mij gaat grub niet over beeldschermresoluties?

als je de nvidia drivers hebt geinstalleerd, kun je nieuwe resoluties uitproberen door nvidia-settings in de terminal in te voeren.

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #7 Gepost op: 2010/03/06, 12:32:21 »
volgens mij gaat grub niet over beeldschermresoluties?

Volgens jou niet, maar dat weet Grub helaas niet. Grub geeft bepaalde parameters door aan de kernel en die gaat wel over de beeldschermresolutie  :evil:

Kijk eens heel goed naar deze regel:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

en probeer je eens in te beelden wat "nomodeset" zoal zou kunnen doen.
« Laatst bewerkt op: 2010/03/06, 12:34:32 door timosha »
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline jvd

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #8 Gepost op: 2010/03/06, 13:57:38 »
Inbeelden doe ik liever niet. De eerste hit op google zegt:

Citaat
Specifying 'nomodeset' when the system boots basically tells the system to use an older set of software/drivers which does work (but may be slower or have some other issues that people would like to eliminate).

Kan dus wel werken, maar is niet de optimale oplossing.

Als je geen ideologische bezwaren hebt tegen het gebruik van proprietaire drivers, gewoon met de Nvidia software aan de slag gaan.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: waarom krijg ik mijn beeldschermresolutie in ubuntu 9.10 niet goed?
« Reactie #9 Gepost op: 2010/03/06, 16:33:24 »
Hallo

Maar ondanks dat je dan die proprietary drivers erop hebt staan, beland je waarschijnlijk nog
niet bij je gewenste resolutie. En dat heeft niet zozeer met je drivers te maken, als wel
met het feit dat X je monitor niet, of niet goed detecteert. Vandaar alvast die nomodeset
om te proberen om het automatische foute detectie te omzeilen. (zie ook andere zaken inzake
edid etc)
Maar wat ik steeds vaker moet toepassen; zelf een xorg.conf bij elkaar harken, zelf de
juiste modeline zien te vinden / online laten genereren en handmatig erin zetten, dat is nu niet
bepaald instapvriendelijk imho.  
Notabene op hardware die altijd juist gedraaid heeft op 8.04 (nu al verschillende machines met,
jawel een normale nvidia aan boord, go figure :rolleyes:)
Zolang er niet een tooltje net als vroeger (displayconfig-gtk) als backup bij een foute monitor detectie
wordt geleverd, blijft het modderen met alle zogenaamde verbeteringen in X.
Dit is dus niet specifiek ubuntu only; met fedora en opensuse hetzelfde ongemak.

Groeten Gerrit

edit;
om je even een idee te geven; ik zit nu achter zo'n onwillige machine waarbij ik het toch heb
goed gekregen. Ik ga er even van uit dat je de proprietary drivers intussen hebt geïnstalleerd. De machine
even herstarten om te zien of dat werkt (misschien, maar onwaarschijnlijk, staat je resolutie er tussen
als je nvidia-settings draait, dan hoeft onderstaande niet te gebeuren.)

Gegevens; Nvdia 7300 icm. Samsung breedbekmonitor 2233BW (1680x1050 native resolutie)
Om een min of meer geldige modeline te vinden;
open een terminal en tik in (copy/paste);
gtf 1680 1050 60 -x  ;  dus de gewenste resolutie en afbuigfreq even invoeren
in jouw geval ;
gtf 1024 768 60 -x voor een tft   (niet hoger dan 60Hz, heeft trouwens ook geen zin)
of
gtf 1024 768 75 -x voor een crt monitor met 75 Hz afbuigfreq., zoek anders de monitor specs en zet dat evt. op 80/85 hz
bij mij komt er na een enter uit;
Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
noteer dat en wijzig dat straks in je xorg.conf.
Ik heb hem trouwens iets netter(uniform gemaakt met; modeline "1680x1050@60" 147 bladiebla.
Nu als volgt weer vanuit die terminal;

gksudo gedit /etc/X11/xorg.conf  (wachtwoord invoeren, je wordt even root met sudo)
 
een (waarschijnlijk lege) xorg.conf wordt opengemaakt
kopieer en plak het volgende;
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel "
Horizsync 31.5-99.0
Vertrefresh 56.0 - 65.0
modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline  "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hSync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Virtual 1680 1050
Modes "1680x1050"
EndSubSection
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Device"
Identifier "Configured Video Device"
Busid "PCI:1:0:0"
Screen 0
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Zoals je ziet heb ik er 3 modelines in staan 2 fout gedetecteerde en degene die ik heb toegevoegd
in de section screen;
SubSection "Display"
      Depth   24
      Virtual   1680   1050
      Modes      "1680x1050"   
veranderen naar je wens, zorg dat de Virtual gelijk is aan de Modes
helemaal onderaan staat de driver in dit geval de proprietary nvidia
(anders de opensource nv (tenminste dat schijnt intussen ook veranderd?) of vesa)

oja, bij de Section "Monitor" even
voor een standaard 1024x768 TFT; Horizsync   31.5-48.0
                                                    Vertrefresh     56.0 - 65.0
voor een standaard 1024x768 CRT; Horizsync   31.5-61.0
                                                     Vertrefresh    50 - 75


Opslaan machine herstarten en zien wat gebeurt. Misschien dat ook nog die nomodeset er verplicht
bij moet, maar dat had ik op voorhand al gedaan en heb even geen tijd/zin om dat nogmaals te testen.
Mocht er iets in de soep zijn gelopen;
met ctrl+alt+F2 (of F1 of F3 whatever) krijg je een terminal buiten X om, login en met
sudo rm /etc/X11/xorg.conf haal je hem weg
met
sudo shutdown -r now
reset de machine netjes
(jaja ik weet ik weet  ;) met gdm-stop en gdm-restart zou je niet je machine te hoeven rebooten,
maar dat loopt niet altijd even soepel)

Succes





« Laatst bewerkt op: 2010/03/06, 18:50:38 door mrGee »
-- = >  simplify if you can   -- = >