Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OPGELOST: Hoofdtelefoongeluid appart aanzetten  (gelezen 4083 keer)

Offline krommenek

  • Lid
  • Steunpunt: Nee
OPGELOST: Hoofdtelefoongeluid appart aanzetten
« Gepost op: 2010/02/27, 19:32:43 »
Hoi,

Wie kan mij helpen!

Heb een ASUS Z53e laptop. Machting ding :) Ubuntu 9.10  installeert echt alles, zelf tot en met de webcam aan toe.

Maar ik heb nu een probleempje ontdekt: Ik kan de interne speakers niet uitzetten en dan toch met de hoofdtelefoon luisteren.

Als ik in Geluidsvoorkeuren kies voor Connector: analog Headphones gaat de hoofdtelefoon uit alsmede de interne speakers. In de standaard waarde van Connector (dat is  analog output) dan doen beide het het, zowel de interne speakeres als mede de hoofdtelefoon.

Ook met de ALSA mixer die ik geïnstalleerd heb kan ik deze interen speakers en de hoofdtelefoon niet separaat regelen.

Iemand een idee?

Greetz,
« Laatst bewerkt op: 2010/02/28, 23:42:01 door krommenek »

Offline krommenek

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #1 Gepost op: 2010/02/28, 18:50:10 »
Niemand een idee?

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #2 Gepost op: 2010/02/28, 19:14:38 »
Gaan de speakers niet uit als je een hoofdtelefoon  aansluit op de hoofdtelefoon aansluiting.  ???
Dit zou namelijk wel het geval moeten zijn...
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline krommenek

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #3 Gepost op: 2010/02/28, 19:36:35 »
Precies, als de mini jack ik de laptop gaat gaan de speakers van de laptop NIET uit.
Ik heb dan wel hetzelfde geluid op de koptelefoon, dus adt is goed.

Alleen de laptop speakers gaan dus NIET uit.

Greetz

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #4 Gepost op: 2010/02/28, 19:54:15 »
Toch moet dit omschakelen door een plug in de connector te steken omschakelen. Dit wordt niet softwarematig geregeld.
In mijn laptop heb ik een aansluiting voor luidsprekers en een aansluiting voor koptelefoon.
Als ik de luidspreker aansluiting gebruik blijf ik geluid houden op de laptop luidsprekers maar bij de hoofdtelefoon gaat het geluid alleen nog naar de hoofdtelefoon.
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline krommenek

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #5 Gepost op: 2010/02/28, 21:54:44 »
Hoi,

Heb nog gechecked, maar met WINDOWS7 werkt alles normaal. Heb een dubbelboot op deze laptop.

Lijkt me dat UBUNTU niet achter mag blijven nu.....

Dus wie zoekt het mee uit of heeft nog hints?

Greetz,

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #6 Gepost op: 2010/02/28, 22:26:53 »
Hallo

Kun je even een terminal openen (via Toepassingen-Hulpmiddelen-Terminalvenster)
en daar
aplay -l  (l= kleine letter L)
intikken en de chipset posten (iets van alc... vermoed ik)

Je hebt een probleempje met de zgn. jack sensing, een klein schakelaartje dat dit
doorgeeft aan de chipset en dan verwerkt moet worden. Staat soms als aan te vinken
optie vermeld in je voorkeuren bij de volumeregeling.

Misschien werkt dit ook al;

Open synaptic (software pakketbeheer) en type daar bij
het zoekvenster ; linux-backports in
Installeer de; linux-backports-modules-alsa-karmic-generic

Machine herstarten en controleren, check voor de zekerheid ook
even je mixersettings na de herstart.

Oja, post ook even de uitkomst van dit;

cat /etc/modprobe.d/alsa-base.conf |grep model

ingevoerd op een terminalvenster


Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline krommenek

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #7 Gepost op: 2010/02/28, 22:47:58 »
Zoals gevraagd, rest ga ik testen:

aplay -l  geeft:
~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC660-VD Analog [ALC660-VD Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

cat /etc/modprobe.d/alsa-base.conf |grep model
geeft:
options snd-atiixp-modem index=-2
options snd-via82xx-modem index=-2


En nu.... ??

Greetz

Offline krommenek

  • Lid
  • Steunpunt: Nee
OPGELOST Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #8 Gepost op: 2010/02/28, 23:01:53 »
Heb onderstaande gedaan en schijnt tot nu toe te werken.
Als ik nu de hoofdtelefoon stekker erin steek, gaan de laptop speakers automatisch uit  =D =D =D =D =D

Open synaptic (software pakketbeheer) en type daar bij
het zoekvenster ; linux-backports in
Installeer de; linux-backports-modules-alsa-karmic-generic

Machine herstarten en controleren, check voor de zekerheid ook
even je mixersettings na de herstart.


Bedankt voor de hulp...... MRGEE....

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Hoofdtelefoongeluid appart aanzetten
« Reactie #9 Gepost op: 2010/02/28, 23:09:58 »
Mooi zo,

Minder mooi was dat ik net een lap tekst die ik nog als toevoeging wou
posten heb moeten vernietigen, nu je de oplossing al hebt.  =D

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: OPGELOST: Hoofdtelefoongeluid appart aanzetten
« Reactie #10 Gepost op: 2010/03/01, 00:07:27 »
Ik ook weer wat geleerd.  ^-^
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!