Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NAS - Niet alle bestanden/mappen zichtbaar en mounten via de terminal onmogelijk  (gelezen 2672 keer)

Offline Robertos

  • Lid
  • Steunpunt: Nee
In het netwerk is een NAS aangesloten (Freecom), deze kan ik grafisch perfect benaderen via Locaties > Netwerk.
Het probleem is echter dat sommige mappen en bestanden spontaan onzichtbaar worden, de oorzaak is waarschijnlijk het cifs bestandssysteem. Onder XP zijn alle mappen/bestanden bijvoorbeeld wel gewoon zichtbaar. Ik heb al behoorlijk wat gegoogled en wat mogelijke oplossingen gevonden, het probleem is echter dat die bij mij op de een of andere manier niet werken.



Neem deze uitleg: http://ubuntuforums.org/showthread.php?t=288534 (Manual mount)

Resultaat:

robert@PCRWUBUNTU:~$ sudo mount -t cifs //fnd/robert /home/robert/mount/ -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
mount error: could not resolve address for fnd: No address associated with hostname
No ip address specified and hostname not found

of:

robert@PCRWUBUNTU:~$ sudo mount -t cifs //192.168.2.151/robert /home/robert/mount/ -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

of:

robert@PCRWUBUNTU:~$ sudo mount //192.168.2.151/robert /home/robert/mount/
Password:
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)


Ook op de betreffende errors heb ik gegoogled, maar ik zie onderhand door de bomen het bos niet meer.
Ergens doe ik iets verkeerd, maar wat.....

Wie zou mij kunnen helpen met de volgende vragen:

- Hoe kan ik d.m.v. de terminal mijn netwerk drive mounten?
- Hoe kan ik ervoor zorgen dat alle mappen en bestanden zichtbaar worden en blijven op de drive?
« Laatst bewerkt op: 2010/06/08, 23:48:35 door Robertos »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Op je eigen pc je mount map maken, de rechten aan jezelf toewijzen.
Dan pas mounten.

-o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
Dit moet je op de nas regelen of je toestemming hebt.
Voor de rest zou je gewoon moeten kunnen mounten.

Misschien heb je op de nas nog iets geblokkeerd zoals dns of netbios.(misschien firewall).

Offline Robertos

  • Lid
  • Steunpunt: Nee
Bedankt voor je reactie, jan11000.

De betreffende mount map was in eerste instantie in /home gemaakt, daar had ik dus alle rechten over. Op de NAS heb ik verder gewoon toegang en er is ook geen firewall die in de weg zit. Uiteindelijk heb ik na veel zoeken en uitproberen een oplossing gevonden, bij de opties moest ik nounix toevoegen. Vervolgens heb ik mijn NAS in /etc/hosts toegevoegd zodat ik 'm ook kan mounten op naam en niet alleen op IP, tevens maar even het mount punt aangepast naar /media/fndrobert.

De opdrachtregel wordt voor mij dus:

sudo mount -t cifs //fnd/robert /media/fndrobert/ -o guest,nounix,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
Dit was echter op 9.04, ik heb ondervonden dat dit dus niet op 9.10 werkt, deze bleek ook nog de optie noserverino nodig te hebben.

De opdrachtregel voor 9.10:

sudo mount -t cifs //fnd/robert /media/fndrobert/ -o guest,nounix,rw,noserverino,iocharset=utf8,file_mode=0777,dir_mode=0777
Het resultaat is dat ik nu wel alle mappen/bestanden kan zien, ook al is het d.m.v. deze omweg.


Edit: Teveel tekens in de titel, dus "opgelost" erbij plaatsen is niet mogelijk. Dan maar een "duim omhoog". ;)
« Laatst bewerkt op: 2010/02/26, 17:28:12 door Robertos »

Offline Robertos

  • Lid
  • Steunpunt: Nee
Toch problemen blijkbaar  ???

Ik kan de shares op de bovenstaande manier prima openen, ik kan bestanden naar de NAS kopiëren en hernoemen...enkel kan ik niet fatsoenlijk bestanden kopiëren met behulp van Nautilus van de NAS naar de PC. De voortgangsbalk blijft gewoon op 0 byte staan.



Het kopiëren is dan wel gewoon geslaagd en het bestand staat compleet op de PC. Als ik de map open in de terminal dan gaat kopiëren van de NAS naar de PC d.m.v. het cp commando prima.

Heeft iemand enig idee waarom die voortgangsbalk op 0 byte blijft staan terwijl de overdracht voltooid is, en hoe dit op te lossen is?

Edit: Net even op een andere PC met daarop openSUSE 11.2 getest, precies hetzelfde verhaal. Hier blijft de voortgangsbalk bij een andere file staan op 668,0 kb van 668,0 kb en sluit niet. Ik kan het niet rijmen...
« Laatst bewerkt op: 2010/06/09, 00:11:42 door Robertos »

Offline Robertos

  • Lid
  • Steunpunt: Nee
Toch nog even onder de aandacht brengen.