Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] handmatige mount werkt, maar via fstab niet  (gelezen 757 keer)

Offline jvd

  • Lid
  • Steunpunt: Nee
[opgelost] handmatige mount werkt, maar via fstab niet
« Gepost op: 2010/02/24, 13:20:34 »
Als ik in de terminal invoer:

sudo mount -t ext2 /dev/sda5 /media/data
dan wordt mijn harde schijf gemount.

Maar als ik dat via de fstab wil doen, krijg ik de volgende foutmelding:

wrong fs type, bad option, bad superblock on /dev/sda5
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try dmesg | tail  or so

En in mijn fstab staat de volgende lijn:

/dev/sda5 /media/data ext2 rw,suid,dev,exec,auto,user,async,uid=1000 0 0
Iemand een idee van wat er aan de hand kan zijn? Mijn dank is groot!
« Laatst bewerkt op: 2010/02/24, 15:10:40 door jvd »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: handmatige mount werkt, maar via fstab niet
« Reactie #1 Gepost op: 2010/02/24, 13:26:30 »
Dat klinkt heel raar.

Probeer eens of het lukt met "defaults" in plaats van "rw,suid,dev,exec,auto,user,async,uid=1000". Indien wel, dan ligt het aan de opties. Je kan ze dan één vooréén terug toevoegen om de schuldige te vinden.

Offline jvd

  • Lid
  • Steunpunt: Nee
Re: handmatige mount werkt, maar via fstab niet
« Reactie #2 Gepost op: 2010/02/24, 13:47:33 »
Thanks, al getest, maar met hetzelfde resultaat. 

heb ook geen handige zoektermen kunnen  vinden voor dit probleem, alle resultaten gaan over iets vergelijkbaars, maar iets anders...

Maar de fstab vindt op de een of andere manier dat de harde schijf corrupt is.

Optie is natuurlijk om deze handmatige mount toe te voegen aan de start-up sequence. Maar het zou toch op de conventionele manier moeten kunnen?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: handmatige mount werkt, maar via fstab niet
« Reactie #3 Gepost op: 2010/02/24, 14:42:00 »
Die uid=1000 optie is onzin als je een ext2 bestandssysteem hebt.
Weghalen dus.

Werkt het dan wel?

Offline jvd

  • Lid
  • Steunpunt: Nee
Re: handmatige mount werkt, maar via fstab niet
« Reactie #4 Gepost op: 2010/02/24, 15:10:08 »
Kijk kijk kijk... Nu heb ik door waar ik precies de idioot was...

Inderdaad: de uid optie was de boosdoener. En met de alternatieve default settings: Die blijkt in meervoud te zijn.

Dank voor jullie hulp!