Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters  (gelezen 1696 keer)

Offline psilin

  • Lid
  • Steunpunt: Nee
Gisteren heb ik de stoute schoenen aangetrokken omdat ik het zat was bij het inloggen om steeds de mededelingen te zien 'er zijn updates' en 'security updates'.
En omdat bij een upgrade toch alleen de eerst lagere versie wordt ondersteund, moest het er toch eens van komen. Voor mij een eerste keer om zo een upgrade uit te voeren.

Het resultaat kan ik niet onverdeeld positief over zijn: foutmeldingen bij opstarten ( oa een id fout bij nmbd terwijl samba wel werkt ), maar ook b.v. de sensors module die nu veel te weinig informatie blijkt te geven bij wat ik gewend was.

Maar voordat ik dat allemaal recht kan/ga zetten ( voor zover dat lukt ) zou ik graag een leesbaar console willen hebben. Om de een of andere idiote reden ziet Ubuntu nu de tekst console als een grafisch output ( 1600x1200 ). En op een 20" scherm is dat niet fijn leesbaar.

Google & forums hebben mij niet verder kunnen helpen tot zover. Het is ongetwijfeld weer eens een simpel dingetje, maar ik kom er niet uit.

Iemand een goede suggestie ?

Offline socialdefect

  • Lid
    • socialdefect
    • Socialdefect's Blog
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #1 Gepost op: 2010/02/20, 16:21:27 »
Ik heb eigenlijk nog nooit een distributie upgrade succesvol afgerond, echt van geen enkele distributie.
Heb voor mijn workstation dus ook maar Gentoo gekozen vanwege de rolling release, dat zou wel probleemloos voor eeuwig te upgraden moeten zijn.

Ik houd van zekerheid, wanneer er spontaan veel fouten opduiken kies ik er liever voor om opnieuw te installeren, dan weet je tenminste zeker dat je alle problemen hebt verholpen.

Wil je echt graag zelf de problemen opsporen dan raad ik je aan te gaan zoeken naar een log van de upgrade om te zien waar het fout is gegaan en welke veranderingen de upgrade heeft gedaan.

op http://tldp.org vind je alle howto's die je nodig hebt om een Linux probleem op te lossen.

(EDIT)
kijk ook eens in je grub.cfg (of wat je ook mag hebben) naar de vga instellingen
« Laatst bewerkt op: 2010/02/20, 16:27:17 door socialdefect »

Offline psilin

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #2 Gepost op: 2010/02/20, 18:24:23 »
Dank in ieder geval. Het probleem zit echt in de koppeling met de nieuwe kernel. De grub opties werken, juist na grub wordt de verkeerde resolutie ingeschakeld.

Na uren zoeken blijkt in de linux kernel dermate veel veranderd te zijn dat de optie vga= niet werkt ( en in ieder geval depreciated is).

Tav nieuwe install: dat is toch te gek voor woorden. Alle specifieke server config aanpassingen moeten dan handmatig opnieuw worden gemaakt. De standaard data is het probleem dus niet.
En alle nu niet werkende configs kom ik dan ook weer tegen aangezien de packages bij een nieuwe release toch de nieuwe zijn.

Probleem met sensors is ook een kernel probleem, daar is overigens een niet zo elegante oplossing voor in de vorm van een kernel parameter.


Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #3 Gepost op: 2010/02/21, 10:33:46 »
Je kan proberen te booten met
vga=askHierna kan je met de letters a-z kiezen welke resolutie passend is.
Dat werkt in ieder geval met de live-CD van Ubuntu 9.10.
Als met een nieuwere kernel de vga-optie niet meer of onvolledig zou werken, dan is dat ook voor mij nieuw.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline psilin

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #4 Gepost op: 2010/02/21, 15:34:58 »
op een ander systeem heb ik een nieuwe windows install gedaan van 9.10. Ook daar bij de nieuwe kernel wordt de optie vga=ask niet geaccepteerd.

Het lijkt dus echt een kernel issue, en minder systeem afhankelijk.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #5 Gepost op: 2010/02/21, 16:33:57 »
op een ander systeem heb ik een nieuwe windows install gedaan van 9.10.
Als je nu vertelt dat je met Wubi werkt, kan ik je geen tips meer geven. Ik ondersteun geen Wubi-systemen omdat ik daar geen verstand van heb. Zoals al eerder door verschillende gebruikers in het forum wordt gemeld, is Wubi leuk om te gaan kijken maar minder geschikt om er dagelijks mee te werken.
Als je met een soort VM/vbox-systeem werkt, dan worden de video-instellingen deels buiten het OS-venster om geregeld.

Maar misschien zijn mijn speculaties helemaal verkeerd. Dus even voor de goede orde: wat is een Windows install van 9.10?
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline psilin

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #6 Gepost op: 2010/02/21, 19:50:43 »
beide aannames zijn juist.

systeem 1: daar waar het mee begon was een native jaunty 9.04 install vanaf usb stick, welke ik dus heb geupgraded naar 9.10. Vervolgens heb ik via apt-get update & apt-get upgrade de nodige packages geupgraded.
systeem 2: dat is inderdaad een test laptopje met een windows xp install. Via wibu heb ik daar 9.10 op geinstalleerd.

vandaag viel mijn oog op een regel bij het booten die voorbijflitstte: iets met console en resolution. Nadere inspectie mbv dmesg levert op:
systeem 1:

Eerst:
[    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.31-19-server root=/dev/mapper/voyager-root ro quiet splash acpi_enforce_resources=lax
[    0.000000] SLUB: Genslabs=14, HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] NR_IRQS:4352 nr_irqs:440
[    0.000000] Fast TSC calibration using PIT
[    0.000000] Detected 1596.079 MHz processor.
[b][    0.001263] Console: colour VGA+ 80x25[/b]
[    0.001270] console [tty0] enabled
[    0.010000] allocated 20971520 bytes of page_cgroup
[    0.010000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.010000] hpet clockevent registered


Vervolgens:
[   12.694680] agpgart-intel 0000:00:00.0: Intel 945G Chipset
[   12.695226] agpgart-intel 0000:00:00.0: detected 7932K stolen memory
[   12.698808] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[   12.708278] parport_pc 00:07: reported by Plug and Play ACPI
[   12.708366] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[   12.774847] [drm] Initialized drm 1.1.0 20060810
[   12.819504] it87: Found IT8718F chip at 0xa10, revision 4
[   12.819524] it87: in3 is VCC (+5V)
[   12.819530] it87: in7 is VCCH (+5V Stand-By)
[   12.819617] ACPI: I/O resource it87 [0xa15-0xa16] conflicts with ACPI region SIOR [0xa15-0xa16]
[   12.819626] ACPI: This conflict may cause random problems and system instability
[   12.819633] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   12.892475] lp0: using parport0 (interrupt-driven).
[   12.897439] ppdev: user-space parallel port driver
[   12.980213] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   12.980234] i915 0000:00:02.0: setting latency timer to 64
[   12.998167] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   13.053681] EXT3 FS on dm-0, internal journal
[   13.053701] ip_tables: (C) 2000-2006 Netfilter Core Team
[   13.150884] [drm] fb0: inteldrmfb frame buffer device
[   13.150907] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   13.158332] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   13.158408] HDA Intel 0000:00:1b.0: setting latency timer to 64
[   13.233690] [drm] DAC-6: set mode 1600x1200 18
[b][   13.274943] Console: switching to colour frame buffer device 200x75[/b]
[   13.305618] hda_codec: Unknown model for ALC662 rev1, trying auto-probe from BIOS...
[   13.306968] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input4
[   13.608299] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input5

Systeem 2:

Eerst:
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=/dev/sda1 loop=/ubuntu/disks/root.disk ro vga=640x480

[    0.001378] Console: colour VGA+ 80x25
[b][    0.001383] console [tty0] enabled[/b]

Vervolgens:
[    0.077815] ACPI: bus type pnp registered
[    0.082748] pnp: PnP ACPI: found 11 devices
[    0.082799] ACPI: ACPI bus type pnp unregistered
[    0.082852] PnPBIOS: Disabled by ACPI PNP

[    1.199252] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:02/input/input5
[    1.199389] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    1.266299] Linux agpgart interface v0.103
[    1.271157] agpgart-intel 0000:00:00.0: Intel 855GM Chipset
[    1.272528] agpgart-intel 0000:00:00.0: detected 8060K stolen memory
[    1.322549] agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0xd8000000
[    1.379960] ACPI: PCI Interrupt Link [LNKF] enabled at IRQ 11
[    1.380047] ohci1394 0000:01:0e.0: PCI INT A -> Link[LNKF] -> GSI 11 (level, low) -> IRQ 11
[    1.416541] [drm] Initialized drm 1.1.0 20060810
[    1.435421] i915 0000:00:02.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
[    1.435500] i915 0000:00:02.0: setting latency timer to 64
[    1.440107] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[11]  MMIO=[d0215000-d02157ff]  Max Packet=[2048]  IR/IT contexts=[4/8]
[    1.440946] tg3.c:v3.99 (April 20, 2009)
[    1.441236] ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
[    1.441293] tg3 0000:01:0c.0: PCI INT A -> Link[LNKE] -> GSI 11 (level, low) -> IRQ 11
[    1.447479] i2c-adapter i2c-1: unable to read EDID block.
[    1.447552] i915 0000:00:02.0: LVDS-1: no EDID data
[    1.455714] tg3 0000:01:0c.0: PME# disabled
[    2.004142] eth0: Tigon3 [partno(BCM95788MT58) rev 3003] (PCI:33MHz:32-bit) MAC address 00:0b:5d:59:a7:c8
[    2.004218] eth0: attached PHY is 5705 (10/100/1000Base-T Ethernet) (WireSpeed[0])
[    2.004287] eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    2.004341] eth0: dma_rwctrl[763f0000] dma_mask[64-bit]
[    2.079865] [drm] DAC-6: set mode 640x480 0
[    2.553244] i2c-adapter i2c-1: unable to read EDID block.
[    2.553300] i915 0000:00:02.0: LVDS-1: no EDID data
[    2.563260] [drm] fb0: inteldrmfb frame buffer device
[    2.563325] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    2.653714] render error detected, EIR: 0x00000010
[    2.653720] [drm:i915_handle_error] *ERROR* EIR stuck: 0x00000010, masking
[    2.653737] render error detected, EIR: 0x00000010
[    2.663563] [drm] LVDS-8: set mode 1024x768 f
[b][    2.715069] Console: switching to colour frame buffer device 128x48[/b]

hier en daar heb ik wel regels weggelaten. zoals te zien is wordt tijdens de bootperiode het scherm qua framebuffer opnieuw geïnitialiseerd.

Systeem 2 vind ik verder niet bijster interessant, behalve dat ik dat nu even gebruik als terminal. Dit aangezien 200x75 karakters op een 20" beeldscherm niet echt fijn werkt.

Op systeem 1 kan ik vandaag niet even met een live cd gaan spelen aangezien ik daarin geen cd rom drive heb. En ook omdat downtime van dit systeem inhoudt dat de overige familieleden even niet kunnen interneteen aangezien alle dhcp/dns requesten door dit systeem worden afgehandeld. Dit naast bv opslag persoonlijke data.

Dank voor het meedenken in ieder geval!


Offline psilin

  • Lid
  • Steunpunt: Nee
Re: (9.4->9.10 upgrade ): server console text mode: veel te kleine letters
« Reactie #7 Gepost op: 2010/02/24, 17:00:16 »
zo, weer een stapje verder. Of eigenlijk terug om precies te zijn.

Het blijkt bij mij op beide machines dat de toevoeging van i915.modeset=0 aan de kernel startregel de console netjes 80x25 blijft geven.  Framebuffering wordt daarmee uitgeschakeld voor zover ik het heb begrepen.

Blijft over de wijze waarop dmv m├ęt framebuffering de tekstgrootte kan worden aangepast, zodat er bv 120x30 regels op een scherm passen oid.
Misschien komt dat ooit wel beschikbaar. Voor nu kan ik in ieder geval weer leesbaar console werk uitvoeren! Opgelost is het niet, maar werkbaar wel