Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: grub2 gaat niet automatisch door met booten  (gelezen 1705 keer)

Offline pahendriks

  • Lid
  • Steunpunt: Nee
grub2 gaat niet automatisch door met booten
« Gepost op: 2010/02/18, 22:15:15 »
Ik heb alleen Ubuntu 9.10 als besturingssysteem geinstalleerd.

Grub2 kwam nooit met een menu, ging vanzelf door met het booten. Prima.

Na wat geklooi met kernels komt Grub2 opeens wel met een keuzemenu aanzetten en wacht ie tot er een keuze gemaakt wordt. Het lukt mij niet om Grub meteen Ubuntu te laten booten, en als je geen keuze maakt blijft het menu staan tot je een ons weegt.

Wie o wie kan mij helpen om ervoor te zorgen dat ik geen keuze hoef te maken in Grub2 en zodat ie meteen boot?


Inhoud /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
GRUB_DISABLE_LINUX_RECOVERY="true"

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: grub2 gaat niet automatisch door met booten
« Reactie #1 Gepost op: 2010/02/18, 23:53:51 »
In Synaptic de oude kernels verwijderen, zodra je meer dan een kernel hebt, dan krijg je het grub menu.
In der Beschränkung zeigt sich der Meister.

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #2 Gepost op: 2010/02/19, 09:12:49 »
alle oude kernels zijn verwijderd, heb er nog maar 1 in staan...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: grub2 gaat niet automatisch door met booten
« Reactie #3 Gepost op: 2010/02/19, 09:50:10 »
De # moet je verwijderen voor #GRUB_HIDDEN_TIMEOUT=0 zie ook
http://wiki.ubuntu-nl.org/community/Grub2#Verborgen
En de timeout kan je ook op 0 zetten in de regel GRUB_TIMEOUT=10
Na dat je de veranderingen hebt opgeslagen, nog even het commando sudo update-grub uitvoeren en opnieuw opstarten. :)
In der Beschränkung zeigt sich der Meister.

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #4 Gepost op: 2010/02/19, 10:10:51 »
helpt niet. Heb slechts 1 kernel geinstalleerd, grub2 blijft wachten op keuze en gaat ook niet automatisch verder met booten na een aantal seconden.

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #5 Gepost op: 2010/02/19, 10:23:03 »
Je kunt ook ff "startupmanager" installeren via bijv. Synaptic. Hiermee kun je grub dingen klikkend instellen ;)
Ik weet niet zeker of het al 100% goed overweg kan met grub 2. Maar voor mij kan ie alles doen wat ik wil.
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #6 Gepost op: 2010/02/19, 10:27:27 »
Welke keuzes heeft U dan? Staat er misschien alleen nog maar die memtest bij? Indien ja, dan verwijder die.
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #7 Gepost op: 2010/02/19, 10:38:21 »
er staat nu nog maar 1 entry in de lijst, maar daar blijft ie op staan, en gaat niet automatisch verder.

inhoud /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
GRUB_DISABLE_LINUX_RECOVERY="true"

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #8 Gepost op: 2010/02/19, 11:04:02 »
Welke versie van Grub wordt er gebruikt? 1.97 of 1.98?
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #9 Gepost op: 2010/02/19, 11:08:59 »
1.97 beta 4

Overigens: tot voor kort werkte het gewoon goed.

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #10 Gepost op: 2010/02/19, 11:35:08 »
installeer startupmanager wat ook in een vorige post werd gezegd. Ga vervolgens naar "standaard besturing systeem" (kan best zijn dat het wat anders heet gebruik namelijk engelse versie). Daar kun je kiezen welke versie hij dan standaard moet opstarten. verander die dan ook daad werkelijk naar de juiste kernel al heb je maar 1tje :D. Hij wilt soms niet doorgaan aangezien je daarvoor een andere had geselecteerd en toen alle kernel verwijdert.

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #11 Gepost op: 2010/02/19, 12:12:39 »
ik kan er in de startup-manager maar 1 kiezen, en die is ook aanwezig. Helpt niet...

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #12 Gepost op: 2010/02/19, 12:16:44 »
je hebt 1 kernel maar daarbij heb je ook nog memtest, recovery enzo toch?

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #13 Gepost op: 2010/02/19, 12:18:00 »
nee, bij het booten staat er nog maar 1 entry. De recovery is uitgezet en de memtest heb ik ook verwijderd.

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #14 Gepost op: 2010/02/19, 12:19:02 »
in de toekomst is het handig dat je die 2 laat staan mocht er wat je systeem gebeuren (heb ervaring mee :P)
dit zag ik trouwens online.. https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/428570

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #15 Gepost op: 2010/02/19, 13:12:45 »
Ongelooflijk, het werkt nog steeds niet...

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT="2"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

sanderh79

  • Gast
Re: grub2 gaat niet automatisch door met booten
« Reactie #16 Gepost op: 2010/03/05, 13:46:34 »
Ik had ditzelfde probleem... loste het op via

sudo nano /etc/rc.local

concurrency=none bovenaan toegevoegd,  1e reboot gebeurt er niets maar daarna start grub automatisch de eerste entry. Probleem snap ik niet helemaal aangezien grub2 nieuw voor me is (grub was zoveel eenvoudiger), ubuntu start kennelijk niet goed op en voegt daarom een recordfail=1  aan grubenv, als dit 0 is dan loopt grub wel normaal door.

In dezelfde sessie had ik tevens de loopback toegevoegd aan /etc/network/interfaces:

auto eth0 lo
iface lo inet loopback
iface eth0 inet dhcp

Maar vanwege een andere issue, ik gok niet dat dat de oplossing was (heb ook geen zin om het verder uit te zoeken, het werkt). Zie ook https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/447725

Offline pahendriks

  • Lid
  • Steunpunt: Nee
Re: grub2 gaat niet automatisch door met booten
« Reactie #17 Gepost op: 2010/03/05, 13:54:41 »
Bedankt voor je reactie. Ik heb inmiddels Ubuntu 9.10 opnieuw geïnstalleerd, waarmee het probleem ook verholpen is. Voor een ieder die ook met het probleem kampt is jouw antwoord wellicht een uitkomst.