Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Geen geluid meer na pauzestand  (gelezen 1082 keer)

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
[OPGELOST] Geen geluid meer na pauzestand
« Gepost op: 2010/02/16, 15:35:47 »
De laatste tijd gebruik ik nogal vaak de pauzestand van mijn laptop. Ik heb nu gemerkt dat het geluid het nadien niet meer doet. Pas na een herstart werkt het terug. Alléén de X-server herstarten is niet voldoende (ook al geprobeerd).
Ik heb zo ongeveer al alle pakketten geherinstalleerd waar ik aan kan denken, niks gekort. Pauzestand=geluid weg.
Ik gebruik alleen Alsa, want PulseAudio pikt ie niet.

Iemand een idee welke instelling ik kan veranderen aan die pauzestand  ?
« Laatst bewerkt op: 2010/02/16, 22:51:13 door Prosper »
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid meer na pauzestand
« Reactie #1 Gepost op: 2010/02/16, 19:05:37 »
Als je in een terminal typt speaker-test hoor je dan eenruis,? In de terminal verschijnt ook wat er getest wordt.
gijs@gijs-karmic:~$ speaker-test

speaker-test 1.0.20

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 192 to 2097152
Period size range from 64 to 699051
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
 0 - Front Left
Time per period = 11,334141
 0 - Front Left
Time per period = 11,326517
 0 - Front Left
Time per period = 11,326908
 0 - Front Left
Time per period = 11,323521
 0 - Front Left
Time per period = 11,338435
 0 - Front Left
Time per period = 11,360523
 0 - Front Left
Time per period = 11,327184
 0 - Front Left
Time per period = 11,334311
 0 - Front Left
Time per period = 11,330037
 0 - Front Left
Time per period = 11,350224
 0 - Front Left
Time per period = 11,324332
 0 - Front Left
Time per period = 11,337960
 0 - Front Left
Time per period = 11,329600
 0 - Front Left
In der Beschränkung zeigt sich der Meister.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Geen geluid meer na pauzestand
« Reactie #2 Gepost op: 2010/02/16, 21:21:44 »
Ik krijg dit als uitkomst, en heb de terminal moeten sluiten omdat het maar bleef terugkomen...

ALSA lib pcm_dmix.c:975:(snd_pcm_dmix_open) unable to create IPC semaphore
Playback open error: -13,Toegang geweigerd

Voor een goed begrip: ik hoorde niks tijdens de test, maar omdat ik nu wel net vers ben opgestart, heb ik wèl geluid: Piano Man van Billy Joel speelt nu op de achtergrond...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid meer na pauzestand
« Reactie #3 Gepost op: 2010/02/16, 21:43:08 »
Kan je met sudo wel een geluid applicatie openen en wat afspelen?
Ik denk nl. als de computer in pauze stand gaat de geluidsmodule niet opgestart wordt.
Bijv. de geluidsmodule wordt in rc2 opgestart vervolgens kom je bij rc5 de xserver. Nu ga je in pauzestand terug naar rc3 waar het een en ander "uit" gezet wordt vervolgens ga je weer naar rc5 dan wordt de geluidsmodule niet ingeschakeld. Even zomaar een gedachte.
In der Beschränkung zeigt sich der Meister.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Geen geluid meer na pauzestand
« Reactie #4 Gepost op: 2010/02/16, 22:00:44 »
Hij wil hier altijd een code-tag in het begin zetten...


ikke@pjoeter:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
[color=red]# Power down HDA controllers after 10 idle seconds
options snd-hda-intel power_save=10 power_save_controller=N[/color]
Nog enige uitkomstjes:ikke@pjoeter:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Motorola Si3054
Codec: Realtek ALC880
ikke@pjoeter:~$ sudo lspci | grep -i 'Audio'
[sudo] password for ikke:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

In het volgende draadje vond ik voor mijn laptop-model volgende extra optie. Nu lijkt het wel dat dit enkel is om het gewoon werkend te krijgen, terwijl het dat eigenlijk wel doet. Misschien zou het ook wel lukken met model=auto. Enfin, ik ga het erinzetten en dan nog eens herstarten en pauze en zo...
options snd-hda-intel power_save=10 power_save_controller=N model=3stack-dig


« Laatst bewerkt op: 2010/02/16, 22:04:36 door Prosper »
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: [OPGELOST] Geen geluid meer na pauzestand
« Reactie #5 Gepost op: 2010/02/16, 22:52:54 »
OK,

in deze bijdrage vond ik een workaround voor mijn probleem...

Gijsbert, nog bedankt voor het meedenken, je zette me op het goede spoor... Een mens moet iets hebben om op te googelen.
Afspraak in de Stamkroeg. XD
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...