Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] GRUB - PROBLEMEN!!  (gelezen 1810 keer)

Offline dexterd

  • Lid
  • Steunpunt: Nee
[OPGELOST] GRUB - PROBLEMEN!!
« Gepost op: 2010/02/15, 18:27:36 »
hallo allemaal,
ik wou ubuntu 10.04 (alpha2) eens testen, dus heb ik die gedownload en naast ubuntu 9.04 gezet (de partitie had ik al een paar maanden eerder gemaakt, voor iets wat niet doorgegaan is).
nu bedacht ik dat ik het beter gewoon via virtualbox kon doen, dus verwijderde ik de partitie met 10.04 erop (en de swap partitie die erbij hoorde), dit geeft Gparted aan als ongebruikt.
Ik reboot mn pc en hij zegt:

GRUB LOADING
error: no such partition
grub rescue>

hij gaat niet meer naar uby 9.04...

Gparted geeft aan dat op partitie /dev/sda1 45 Gb gebruikt is, wat klopt (dit is de partitie van uby 9.04), er staat een boot flag bij.


Hoe krijg ik grub zo ver dat hij weer uby 9.04 opstart?

Al mn gegevens staan daar op...

Alvast bedankt,

dex
« Laatst bewerkt op: 2010/02/15, 20:40:42 door dexterd »
The box said: "Requires Windows XP or better."
So i installed Linux.


Steunpunt Leiden en omstreken

Offline Thijsg

  • Lid
  • Steunpunt: Nee
Re: GRUB - PROBLEMEN!!
« Reactie #1 Gepost op: 2010/02/15, 18:41:49 »
Start eens een livesessie van Jaunty.

Typ daarin in de terminal:
sudo grub
root (hd0,0)
setup (hd0)
quit

Offline dexterd

  • Lid
  • Steunpunt: Nee
Re: GRUB - PROBLEMEN!!
« Reactie #2 Gepost op: 2010/02/15, 20:36:23 »
ubuntu@ubuntu:~$ sudo grub
Probing devices to guess BIOS drives. This may take a long time.

       [ Minimal BASH-like line editing is supported.   For
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]
grub> root (hd0,0)
root (hd0,0)
grub> setup (hd0)
setup (hd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  17 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,0)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
Done.
grub>

ik ga nu kijken of hij reboot :P
The box said: "Requires Windows XP or better."
So i installed Linux.


Steunpunt Leiden en omstreken

Offline dexterd

  • Lid
  • Steunpunt: Nee
Re: GRUB - PROBLEMEN!!
« Reactie #3 Gepost op: 2010/02/15, 20:40:21 »
jeej!!!
hij doet t weer ;P

heel erg bedankt, was al bang dat ik niet meer bij mn bestanden kon komen!

groet,

dex
The box said: "Requires Windows XP or better."
So i installed Linux.


Steunpunt Leiden en omstreken

Offline Thijsg

  • Lid
  • Steunpunt: Nee
Re: GRUB - PROBLEMEN!!
« Reactie #4 Gepost op: 2010/02/15, 20:57:58 »
jeej!!!
hij doet t weer ;P

heel erg bedankt, was al bang dat ik niet meer bij mn bestanden kon komen!

groet,

dex
Graag gedaan, ik zie dat je ook al [Opgelost] ervoor hebt gezet. ;)

Offline dexterd

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] GRUB - PROBLEMEN!!
« Reactie #5 Gepost op: 2010/02/16, 09:22:17 »
idd :P

nogmaals erg bedankt :P
The box said: "Requires Windows XP or better."
So i installed Linux.


Steunpunt Leiden en omstreken