Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem toevoegen virtuele host  (gelezen 1561 keer)

Offline Erik66

  • Lid
  • Steunpunt: Nee
Probleem toevoegen virtuele host
« Gepost op: 2010/02/11, 07:10:13 »
Ik ben een beetje aan het experimenteren met de combinatie apache2, php, mysql.
Vooral voor het lokaal testen van websites.

Alle installaties zijn vlekkeloos verlopen.
Nu heb ik een website staan in mijn home-directory bijvoorbeeld /home/ikke/mysite.
Ik heb het bestand /etc/apache2/sites-available/default.conf gekopieerd naar /etc/apache2/sites-available/mysite.conf.
Daarin heb ik de Documentroot /var/www/ en <Directory /var/www/> aangepast naar Documentroot /home/ikke/mysite en <Directory /home/ikke/mysite>.

Vervolgens wil ik de site toevoegen met a2ensite maar krijg steevast de melding "Site mysite does not exist".
Ik heb de bekende handleidingen tot op de letter gevolgd.

Wat doe ik fout?

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #1 Gepost op: 2010/02/11, 11:15:25 »
Staat die config nu ook in sites-enabled?
Zo niet, doe ff:
cd /etc/apache2/sites-enabled
ln -s ../sites-available/mysite.conf

Verder moeten volgens mij ook de permissies op de bestanden in je DocumentRoot goed staan. Ik weet niet precies hoe. Maar kijk maar eens hoe ze staan in /var/www (kan met ls -l /var/www/)
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Erik66

  • Lid
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #2 Gepost op: 2010/02/14, 10:36:10 »
Bedankt voor de info Wazzzaaa.

De site is enabled.

Nu de volgende vraag.
Het lijkt erop dat ik telkens maar 1 site tegelijk actief kan hebben en benaderen.
Hoe kan ik nu bijvoorbeeld zowel de site webontwikkel als phpMyAdmin bijvoorbeeld actief hebben?

Ik heb in sites-available nu default, webontwikkel en phpMyAdmin staan.
Webontwikkel en phpMyAdmin heb ik succesvol met a2ensite kunnen enablen.
Daarna heb ik sudo /etc/init.d/apache2 reload gedaan.
Maar op dit moment kan alleen default benaderen.

Dit is de inhoud van mysite
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Dit is de inhoud van phpMyAdmin
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName phpMyAdmin

DocumentRoot /home/erik/phpMyAdmin
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /home/erik/phpMyAdmin/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/phpMyAdmin_error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

Wat moet ik nu invoeren als url om de sites op te vragen?
Of staat er iets nog niet goed in de conf-bestanden?

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #3 Gepost op: 2010/02/14, 13:47:54 »
Je moet voor elke host een symlink maken in sites-enabled
Daarna moet je apache herstarten. Dus: /etc/init.d/apache2 restart
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Erik66

  • Lid
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #4 Gepost op: 2010/02/14, 15:21:12 »
Je moet voor elke host een symlink maken in sites-enabled
Daarna moet je apache herstarten. Dus: /etc/init.d/apache2 restart

Dat heb ik gedaan.

Ik weet alleen niet wat ik nu in mijn webbrowser voor url moet opgeven om de sites op te vragen.

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #5 Gepost op: 2010/02/14, 15:34:43 »
hmm, bij mij werkt dit meestal gewoon standaard. Voor phpmyadmin hoef ik niets extra's te doen. Hoe heb je LAMP ge-installeerd?

Ik raad je aan dit op The Ubuntu(of debian?) Way te doen.
sudo tasksel en dan LAMP aanvinken. Als het goed is moet phpmyadmin dan ook gelijk goed ingesteld zijn zodat je gelijk naar http://localhost/phpmyadmin kunt
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Erik66

  • Lid
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #6 Gepost op: 2010/02/14, 16:27:13 »
Ik heb deze volgorde van installatie doorlopen:

1. Apache2
2. php5
3. mysql

Als ik phpMyAdmin in /var/www/phpMyAdmin zet dan kan ik phpMyAdmin benaderen met http://localhost/phpMyAdmin
Maar als ik phpMyAdmin in /home/erik/phpMyAdmin zet kan ik hem niet benaderen met http://localhost/phpMyAdmin.
Hetzelfde geldt voor mijn website op /home/erik/Web_ontwikkel welke ik als virtual host heb toegevoegd net als phpMyAdmin.

Als ik in mijn browser nu http://phpMyAdmin invoer gaat hij naar http://www.phpmyadmin.net/home_page/index.php.
Als ik http://localhost/phpMyAdmin invoer krijg ik de volgende melding:
Not Found

The requested URL /phpMyAdmin/ was not found on this server.


Ik snap er niks meer van. ???
« Laatst bewerkt op: 2010/02/14, 16:52:59 door Erik66 »

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #7 Gepost op: 2010/02/14, 16:59:42 »
Ik raad je aan dit op The Ubuntu(of debian?) Way te doen.
sudo tasksel en dan LAMP aanvinken. Als het goed is moet phpmyadmin dan ook gelijk goed ingesteld zijn zodat je gelijk naar http://localhost/phpmyadmin kunt
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Erik66

  • Lid
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #8 Gepost op: 2010/02/14, 17:17:23 »
Alles opnieuw installeren/configureren heb ik weinig trek in.
De installatie heb via een ubuntu tutorial gedaan dus daar kan niet echt iets mis mee zijn.
En het gaat me in de eerste plaats niet eens om phpMyAdmin aan de gang te krijgen maar eerder diverse ontwikkel sites die ik lokaal wil testen.

Maar toch bedankt voor de info Wazzzaaa.

Ik rommel voorlopig nog even door en als ik het dan echt zat ben installeer ik het misschien eens met tasksel.

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Probleem toevoegen virtuele host
« Reactie #9 Gepost op: 2010/02/14, 17:53:39 »
Als je net begonnen bent lijkt me opnieuw installeren niet zoveel werk. Gezien bij mij alles werkt met minimale instel dingen.
Je kunt ook gewoon alleen maar sub dirs maken in /var/www/. Dat werkt het makkelijkst. Bij een nieuwe site hoef je alleen maar een nieuwe dir aan te maken. Geen gezeur met apache verder ;)
/var/www/site1
/var/www/site2

Misschien heb je iets aan mijn phpmyadmin:
cat /etc/apache2/conf.d/phpmyadmin.conf
# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
Options Indexes FollowSymLinks
DirectoryIndex index.php

<IfModule mod_php5.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All
</Directory>
Zie die Alias ;)
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!