Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ftp server  (gelezen 1724 keer)

adrie

  • Gast
ftp server
« Gepost op: 2006/11/14, 21:19:21 »
Beetje dom maar ik kan niet terugvinden welke ftp server ik eigenlijk draai. Werken doet tie wel maar hoe stop ik hem.

breukkie

  • Gast
ftp server
« Reactie #1 Gepost op: 2006/11/14, 21:32:14 »
Umm type eens in de terminal het commando      w

breukkie@breukkie-desktop:~$ w
 21:32:01 up  1:00,  3 users,  load average: 0,69, 1,63, 1,93
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
breukkie :0       -                20:32   ?xdm?   3:09m  0.59s /usr/bin/gnome-session
breukkie pts/0    :0.0             20:51   38:28m  0.82s  0.70s /usr/bin/python /usr/bin/hellanzb.py
breukkie pts/1    :0.0             21:27    0.00s  0.13s  0.01s w

adrie

  • Gast
ftp server
« Reactie #2 Gepost op: 2006/11/14, 21:33:37 »
21:38:50 up 23 days,  4:50,  1 user,  load average: 0.70, 0.63, 0.30
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
root     pts/0    192.168.0.103    20:50    1.00s  0.35s  0.03s w

wr19026

  • Gast
ftp server
« Reactie #3 Gepost op: 2006/11/14, 21:42:45 »
Misschien eens een ps -ef | grep ftp doen?

breukkie

  • Gast
ftp server
« Reactie #4 Gepost op: 2006/11/14, 21:44:53 »
Hmm daar draait niet veel.
Met het commando pstree kan je zien welke processen er allemaal draaien op je bak.

breukkie@breukkie-desktop:~$ pstree
init─┬─QtDominate.exe─┬─explorer.exe───{explorer.exe}
     │                └─6*[{QtDominate.exe}]
     ├─acpid
     ├─artsd
     ├─atd
     ├─beryl-manager─┬─beryl
     │               ├─emerald
     │               └─2*[{beryl-manager}]
     ├─bonobo-activati───{bonobo-activati}
     ├─cron
     ├─cupsd
     ├─2*[dbus-daemon]
     ├─dbus-launch
     ├─dcopserver
     ├─dd
     ├─dhclient3
     ├─events/0
     ├─evolution-alarm───{evolution-alarm}
     ├─firefox-bin───6*[{firefox-bin}]
     ├─gconfd-2
     ├─gdm───gdm─┬─Xorg
     │           └─gnome-session───ssh-agent
     ├─6*[getty]
     ├─gnome-cups-icon───2*[{gnome-cups-icon}]
     ├─gnome-keyring-d
     ├─gnome-panel
     ├─gnome-power-man
     ├─gnome-screensav
     ├─gnome-settings-───{gnome-settings-}
     ├─gnome-terminal─┬─bash───hellanzb.py───{hellanzb.py}
     │                ├─bash
     │                ├─bash───pstree
     │                ├─gnome-pty-helpe
     │                └─{gnome-terminal}
     ├─gnome-vfs-daemo
     ├─gnome-volume-ma
     ├─hald───hald-runner─┬─hald-addon-acpi
     │                    ├─hald-addon-keyb
     │                    ├─6*[hald-addon-stor]
     │                    └─hald-addon-usb-
     ├─hcid
     ├─hpiod
     ├─kded
     ├─kdeinit───klauncher
     ├─khelper
     ├─klogd
     ├─kmess
     ├─knodemgrd_0
     ├─knotify
     ├─krfcommd
     ├─ksoftirqd/0
     ├─kswapd0
     ├─kthread─┬─aio/0
     │         ├─ata/0
     │         ├─kacpi_notify
     │         ├─kacpid
     │         ├─kblockd/0
     │         ├─kgameportd
     │         ├─khpsbpkt
     │         ├─khubd
     │         ├─kjournald
     │         ├─kpsmoused
     │         ├─kseriod
     │         ├─ondemand
     │         ├─2*[pdflush]
     │         ├─scsi_eh_0
     │         ├─scsi_eh_1
     │         ├─scsi_eh_2
     │         ├─shpchpd
     │         └─usb-storage
     ├─logd
     ├─mapping-daemon
     ├─migration/0
     ├─mixer_applet2
     ├─nautilus
     ├─perl
     ├─python
     ├─saa7134[0]
     ├─sdpd
     ├─sh───esd
     ├─sshd
     ├─syslogd
     ├─trashapplet
     ├─udevd
     ├─update-notifier
     ├─watchdog/0
     └─wineserver
breukkie@breukkie-desktop:~$

adrie

  • Gast
ftp server
« Reactie #5 Gepost op: 2006/11/14, 21:44:59 »
root@server:/var/log# ps -ef | grep ftp
root     28015 25206  0 21:48 pts/0    00:00:00 grep ftp

Ik snap het niet ik heb van alles geprobeerd maar ik kom er niet achter welke secure ftp server er nu eigenlijk draait.

adrie

  • Gast
ftp server
« Reactie #6 Gepost op: 2006/11/14, 21:47:33 »
root@server:/var/log# pstree | more
init-+-Xrealvnc
     |-acpid
     |-apache2---8*[apache2]
     |-atd
     |-bonobo-activati
     |-clock-applet
     |-courierlogger---authdaemond.pla---5*[authdaemond.pla]
     |-2*[courierlogger]
     |-2*[couriertcpd]
     |-cron
     |-cupsd
     |-2*[dbus-daemon]
     |-dbus-launch
     |-dd
     |-events/0
     |-gconfd-2
     |-gdm---gdm-+-Xorg
     |           `-gdmgreeter
     |-6*[getty]
     |-gksu---firestarter---{firestarter}
     |-gnome-cups-icon
     |-gnome-keyring-d
     |-gnome-panel---{gnome-panel}
     |-gnome-power-man
     |-gnome-screensav
     |-gnome-settings----{gnome-settings-}
     |-gnome-vfs-daemo---{gnome-vfs-daemo}
     |-gnome-volume-ma
     |-hald---hald-runner-+-hald-addon-acpi
     |                    |-hald-addon-keyb
     |                    `-2*[hald-addon-stor]
     |-hcid
     |-hpiod---{hpiod}
     |-inetutils-inetd
     |-khelper
     |-kjournald
     |-klogd
     |-krfcommd
     |-ksoftirqd/0
     |-kswapd0
     |-kthread-+-aio/0
     |         |-kacpid
     |         |-kblockd/0
     |         |-kgameportd
     |         |-khubd
     |         |-kseriod
     |         `-2*[pdflush]
     |-mapping-daemon
     |-master-+-pickup
     |        `-qmgr
     |-mdadm
     |-metacity
     |-2*[miniserv.pl]
     |-mixer_applet2
     |-mysqld_safe-+-logger
     |             `-mysqld---8*[{mysqld}]
     |-nautilus---{nautilus}
     |-nmbd
     |-python
     |-sdpd
     |-shpchpd_event
     |-smbd---2*[smbd]
     |-sshd---sshd---bash-+-more
     |                    `-pstree
     |-syslogd
     |-trashapplet---{trashapplet}
     |-udevd
     |-watchdog/0
     `-x-session-manag---ssh-agent

Offline jgoor

  • Lid
  • Steunpunt: Nee
ftp server
« Reactie #7 Gepost op: 2006/11/15, 12:31:41 »
Wat krijg je als je 'telnet 127.0.0.1 21` doet? (of i.i.g. naar de poort waarop je server zou moeten draaien?)

adrie

  • Gast
ftp server
« Reactie #8 Gepost op: 2006/11/15, 20:54:41 »
root@server:~# telnet 127.0.0.1 22
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
SSH-2.0-OpenSSH_4.2p1 Debian-7ubuntu3.1

adrie

  • Gast
ftp server
« Reactie #9 Gepost op: 2006/11/15, 21:04:29 »
huh is ssh een ftp server?
Als ik ssh stop kan ik geen verbinding meer maken met een ftp programma.

adrie

  • Gast
ftp server
« Reactie #10 Gepost op: 2006/11/15, 21:49:40 »
$ netstat -tulpn

het bovenstaande commando geeft weer dat sshd luistert op poort 22

schijnbaar verzorgt sshd mijn ftp server.

wr19026

  • Gast
ftp server
« Reactie #11 Gepost op: 2006/11/15, 21:51:44 »
Citaat van: adrie
huh is ssh een ftp server?
Als ik ssh stop kan ik geen verbinding meer maken met een ftp programma.
Je telnet was naar de verkeerde poort, 22, vandaar dat je een onverwacht resultaat kreeg. FTP gaat via poort 21.

Maar waarom herinstalleer je je FTP server niet gewoon?

adrie

  • Gast
ftp server
« Reactie #12 Gepost op: 2006/11/15, 22:22:36 »
Ik gebruik secure ftp onder poort 22 en dat werkt naar behoren.
Verder heb ik geen ftp server nodig op poort 21.

Waar het mij om ging is dat ik niet meer wist welke ftp server ik enige maanden geleden had geinstalleerd.

Het blijkt dus nu dat ik helemaal geen ftp server hoef te installeren omdat openssh-server dit schijnbaar al regelt.

Onderstaande vond ik nog ergens op internet.

I would recommend using SFTP over FTP. The reasons for this are security. FTP allows for a connection over an unencrypted channel, so anyone can sniff your username and password and compromise your machine.

To run SFTP, you can install the "openssh-server" package. This will provide you SSH, SFTP, and SCP utilities, and there is no additional configuration to do.