Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid meer in spel  (gelezen 954 keer)

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Geen geluid meer in spel
« Gepost op: 2006/11/14, 20:03:45 »
Na de installatie van: ubuntu-multimedia-gnome werk het geluid in een spel niet meer.  Voor de rest werken de geluiden wel. In de terminal krijg ik het volgende te zien:

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x0xaff62000 dma buffer
No background file.
----------------------

Ik heb geen idee waarom het Sound sytem is muted wordt aangegeven. Het geluid heeft het wel gedaan

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #1 Gepost op: 2006/11/14, 20:07:14 »
Kunt ge 't geluid niet regelen via alsamixer? (gewoon intypen in je terminal)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #2 Gepost op: 2006/11/14, 20:08:04 »
welk spel is dat, en probeer eens te achterhalen of dat spel OSS of ALSA gebruikt (of iets anders)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #3 Gepost op: 2006/11/14, 20:38:58 »
Het spel is enemy - territory

In alsa mixer staan enkele items op off, maar hoe zet je deze op on?

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #4 Gepost op: 2006/11/14, 20:43:24 »
Met links en rechts pijltjestoetsen balk selecteren.
Met 'm'-toets aan/uitschakelen
Met PageUp en PageDown volumes instellen

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #5 Gepost op: 2006/11/19, 14:46:46 »
Na een nieuwe installatie van ET deed deze het weer 1 keer met geluid en naar een herstart weer niet met geluid. Weer exact dezelfde melding:

----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x0xaff6b000 dma buffer
No background file.


Ik gebruik niet mijn onboard audio (disabled in bios) maar een audigy 2 kaart. Nu heb ik als testje de onboard audio weer enabled in de bios en tot mijn verbazing weer geluid in het spel (ik heb niet de snoertjes gewisseld, deze zitten nog aan mijn audigy)

Krijg overigens nog steeds een melding: sound system is muted, maar het werkt wel.

Ik snap het niet, wie wel?

Albert

  • Gast
Geen geluid meer in spel
« Reactie #6 Gepost op: 2006/11/19, 14:56:11 »
Kijk hier eens.

https://help.ubuntu.com/community/EnemyTerritory

Daar op de website staat.

Sound Issues

There are a few methods you can try if you are having problems with sound:
Method 1

You can try stopping the ESD sound server before running the game by running:

killall esd; et; esd

If this works for you then you can create a script to run it. To do this create a new text file called start-et and add these lines to it:

#!/bin/sh
killall esd
et
esd
exit 0

Now save the file and you will need to run these commands to make it executable and to put it somewhere in your user's $PATH variable (so that it can be executed by just typing it's name):

chmod a+x start-et
sudo cp start-et /usr/local/games

If you don't want to put it in /usr/local/games you don't have to, but remember to specify whatever path you decide to give it whenever you execute it (some paths can use shortcuts, like ./start-et for the current directory, ~/start-et for your Home directory, etc.)
Method 2

If you don't hear any sound and see the following error message in a terminal:

/dev/dsp: Input/output error
Could not mmap /dev/dsp

You will need to do the following in addition to the steps above:

sudo -i
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
exit

This makes the script slightly more complicated, since parts of it will need to be run with superuser priviledges. To use the above commands in the star-et script described in Method 1 you should make it look like this:

#!/bin/bash
gksudo echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
gksudo echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
killall esd
et
esd
exit 0

Then use the commands to give it execute permissions and to put it in /usr/local/games.
Making Startup Scripts More Friendly

If either of the above scripts fix your problem then you can add them to the system's menu using the Alacarte Menu Editor in Applications->Accessories. Go to a suitable location such as Games and make a new entry. It's Command should be start-et (as long as it is in /usr/local/games. If you put it somewhere else then put the whole path), set the icon, name, etc. to what you want then press OK. To avoid confusion you should also disable the old Enemy Territory entry which was added by the installer by unticking the box next to it in Alacarte.

Offline hang-oor

  • Lid
  • Steunpunt: Nee
Geen geluid meer in spel
« Reactie #7 Gepost op: 2006/11/19, 15:12:51 »
Bovenstaande heb ik allemaal geprobeerd, echter voor mij zonder resultaat. Alleen het aanzetten van de onboard audio (die ik dus niet gebruik) had het gewenste resultaat.