Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Microfoon niet werkend  (gelezen 2187 keer)

Offline (c)RJ

  • Lid
  • Steunpunt: Nee
[Opgelost] Microfoon niet werkend
« Gepost op: 2010/01/20, 12:52:49 »
Na een half jaar spelevaren met Ubuntu heb ik nog steeds geen oplossing gevonden voor mijn weigerachtige Sennheiser headset-microfoon, die onder Windows (op een andere notebook) overigens wèl gewoon werkt.

De door mij gebruikte Ubuntuversie is 9.10 Karmic Koala, maar de mic deed het in de vorige editie (8.10 voorgeïnstalleerd) ook al niet. De gebruikte pc is een Dell Inspiron 1545N. Deze Dell notebook beschikt niet over een ingebouwde microfoon: slechts de standaard jack-aansluitingen voor een headset aan de voorzijde.

Onder 'Multimediasystemen selecteren' heb ik in het tabblad 'Default input' de volgende opties:

ALSA- Advanced Linux Sound Architecture
OSS - Open Sound System
PulsaAudio Sound Server
Testgeluid
Stilte
Aangepast

Elke denkbare instelling heb ik bij mijn beste weten uitgeprobeerd doch zonder resultaat. De test-button levert bij voortduring slechts wat gekraak op. (Datzelfde effect krijg ik bij een opname met de 'Geluidsrecorder'.)

Onder 'Geluidsvoorkeuren' in het tabblad 'Invoer' staat de schuifregelaaar 'Input volume' op 'Unamplified', maar verhogen naar de maximale waarde sorteert ook geen effect. (Het selectievakje 'Dempen' is uiteraard niet aangevinkt...)

Bij 'Connector' heb ik twee keuzen:

Microphone 1
Microphone 2

Beiden leveren niet het gewenste resultaat op.

Tot slot het tabblad 'Hardware'; daar heb ik onder 'Instellingen voor het geselecteerde apparaat' de keuze uit deze 'Profiles':

Uit
Analog Stereo Input
Digital Stereo Duplex (IEC958)
Digital Stereo (IEC958) Output + Analog Stereo Input
Analog Stereo Output
Analog Stereo Duplex

...waarvan de laatse is gekozen als standaard-instelling.

Voor de volledigheid: oorschelpjes van de headset - alsmede de aangsloten luidsprekertjes - functioneren naar behoren.

Met excuses voor deze lange, gedetailleerde posting; ik had geen tijd om een kortere te schrijven ;) maar het voorkomt wellicht veel retourvragen.
« Laatst bewerkt op: 2010/01/24, 17:04:26 door (c)RJ »

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #1 Gepost op: 2010/01/20, 18:43:28 »
Eerlijk gezegd vraag ook ik mij af hoe ik mijn mic (een gewone, namelijk een Logitech Dialog 320) in een Linux omgeving aan de praat krijg.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #2 Gepost op: 2010/01/20, 21:12:50 »
Hallo

Misschien vind je hier;
http://forum.ubuntu-nl.org/hardware-en-drivers/ingebouwde-microfoon-doet-het-niet/msg527647/#msg527647
draadje vanaf daar naar onderen even doorlezen.

Wellicht ook toepasbaar icm. met jouw probleem, controleer na die acties
ten allen tijde even je geluidsmixer instellingen.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline (c)RJ

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #3 Gepost op: 2010/01/24, 12:54:40 »
Beste Gerrit,

Had jouw antwoord even gemist (geen notificatie ontvangen) waarvoor mijn verontschuldiging.

Het gaat alvast mis met het toevoegen van dat regeltje in alsa-base.conf: geen rechten... (eigenaar = root).

Offline Thijsg

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #4 Gepost op: 2010/01/24, 15:25:37 »
Beste Gerrit,

Had jouw antwoord even gemist (geen notificatie ontvangen) waarvoor mijn verontschuldiging.

Het gaat alvast mis met het toevoegen van dat regeltje in alsa-base.conf: geen rechten... (eigenaar = root).
gksu gedit /etc/modprobe.d/alsa-base.conf

Offline (c)RJ

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #5 Gepost op: 2010/01/24, 15:33:44 »
gksu gedit /etc/modprobe.d/alsa-base.conf

Kijk, Thijs... DIE zocht ik: ben na ruim twee decennia Microsoft-gemakzucht nog steeds een behoorlijke kluns met terminal-opdrachten. Bedankt!

Offline Thijsg

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #6 Gepost op: 2010/01/24, 15:37:35 »
Succes met het verder oplossen. ;)

Offline (c)RJ

  • Lid
  • Steunpunt: Nee
Re: Microfoon niet werkend
« Reactie #7 Gepost op: 2010/01/24, 16:51:49 »
http://forum.ubuntu-nl.org/hardware-en-drivers/ingebouwde-microfoon-doet-het-niet/msg527647/#msg527647

@Gerrit (mrGee),

Enkel en alleen het toevoegen van het regeltje options snd-hda-intel model=auto aan het bestandje alsa-base.conf bleek al voldoende om de microfoon aan de praat te krijgen. Nu nog een beetje regelen met de schuifjes en ik ben een happy camper.

Nogmaals dank dat je me op het goede spoor hebt gezet!