Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Verbindingsprobleem  (gelezen 2525 keer)

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Verbindingsprobleem
« Gepost op: 2010/01/19, 21:08:54 »
Hallo,

Ik ben nieuw hier en het is ook de eerste keer dat ik een server met ubuntu wil opzetten.
Aangezien ik van een oude pc een server wil maken is dit pakket het beste geschikt zodat ik niet aan cpu snelheid hoef in te boeten.

IK installeerde het pakket. Alles liep prima mits wat handleidingen. Maar nu is het probleem dat ik geen verbinding heb met mijn router. De poort van mijn router staat open maar ik krijg geen verbinding. Aangezien ik mijn server via andere pc wil benaderen met ietsofwat meer grafische interface heb ik deze verbinding dus wel nodig... Kan iemand mij helpen?

Grtz,
Zarathoustra

Offline jobvdnoort

  • Lid
    • Jobvandenoort.nl
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #1 Gepost op: 2010/01/19, 21:13:21 »
Wat voor router heb je? (wireless of via een kabel naar je pc)
Kan je wel op internet of heb je helemaal geen verbinding?
Gr,
Job
Van Ubuntu 6.10 naar Ubuntu 12.10 met een rare amazon bug.

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #2 Gepost op: 2010/01/19, 21:17:16 »
ik plug mijn server in m'n router (linksys wrt54g)
Ik heb helemaal geen verbinding... Als ik Ping c4 (IPadress router) dan krijg ik dat de host niet bestaat...
en uit ifconfig word ik ook niet wijzer...
Misschien moet ik nog iets bij configureren/installeren?

Offline jobvdnoort

  • Lid
    • Jobvandenoort.nl
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #3 Gepost op: 2010/01/19, 21:24:22 »
Wat staat er bij verbindingsinfotmatie? (icoontje rechts boven in met je r-muisknop)
Van Ubuntu 6.10 naar Ubuntu 12.10 met een rare amazon bug.

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #4 Gepost op: 2010/01/19, 21:28:20 »
euh ik gebruik ubuntu server das geen grafische interface dus ook geen icoontje?

Offline jobvdnoort

  • Lid
    • Jobvandenoort.nl
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #5 Gepost op: 2010/01/19, 21:32:06 »
Ah oke sorry ik dacht dat je een desktop editie gebruikte.
Ik kan je denk ik niet helpen...
Misschien is er iemand anders die er meer verstand van heeft.
Van Ubuntu 6.10 naar Ubuntu 12.10 met een rare amazon bug.

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #6 Gepost op: 2010/01/19, 21:44:35 »
ik plug mijn server in m'n router (linksys wrt54g)
Ik heb helemaal geen verbinding... Als ik Ping c4 (IPadress router) dan krijg ik dat de host niet bestaat...
en uit ifconfig word ik ook niet wijzer...
Heb je automatische DHCP aanstaan in je router? (dan krijgt elke computer automagisch een ip).

Wat zegt ifconfig? post dat even hier tussen [code ] [ /code] (het # knopje)
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #7 Gepost op: 2010/01/20, 18:07:29 »
inet addr: fe80: : 202 : a5ff : fe0a: f642/64 Scope: Link
UP BR0ADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:47 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:1000
RX bytes:5300 (5.3 KB) TX bytes:7496 (7.4 KB)

Link encap: Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:0
RX bytes:14697 (14.6kb) TX bytes:14697 (14.6 kb)

Link encap: Ethernet HWaddr a2:7f:7c:f2:44:c2
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BR0ADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0B) TX bytes:0 (0.0B)

Dit is wat ik krijg bij ifconfig. Mijn router staat zo geconfigureerd ieder krijgt ip toegewezen!

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #8 Gepost op: 2010/01/20, 19:48:52 »
Kun je de inhoud van /etc/network/interfaces eens posten?

Andere vraag heb je ooit op je router mac filtering geactiveerd?
« Laatst bewerkt op: 2010/01/20, 19:51:58 door tap »

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #9 Gepost op: 2010/01/20, 20:03:59 »
Neen, niet dat ik weet.
Ik werk zoals eerder gevraagt met DHCP
macfiltering heb ik nooit toegepast... De poort staat open want ik kan er een andere pc aanhangen die wel verbinding heeft.

Maar misschien moet ik iets configureren? Iets dat mijn server weet met wat ik hem verbind ofz? Ik heb geen ervaring met ubuntu server vandaar dat ik dit probleem niet kan oplossen..

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #10 Gepost op: 2010/01/20, 20:07:08 »
Okay,

Maar kun je de inhoud van /etc/network/interfaces laten zien.

Dit kan met nano /etc/network/interfaces
Het is altijd handig om de server een vast ip te geven, anders heb je een probleem als hij eens een ander ip toegewezen krijgt.
Ik denk dat ik je wel op weg kan helpen.

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #11 Gepost op: 2010/01/20, 20:20:57 »
Oké dit had ik in de handleiding ook gelezen... Maar als ik dit intyp dan zegt hij permission denied..
Wat doe ik fout?

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #12 Gepost op: 2010/01/20, 20:24:46 »
Probeer dit eens

sudo nano /etc/network/interfaces

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #13 Gepost op: 2010/01/20, 20:26:12 »
oké gelukt ;) die handleiding vertelde er die nano niet bij ;)
Oké nu zie ik files? wat moet ik er in aanpassen?

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #14 Gepost op: 2010/01/20, 20:27:05 »
post even wat er staat. Dan kijk ik er even naar.

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #15 Gepost op: 2010/01/20, 20:31:43 »
# This file discribes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5)

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #16 Gepost op: 2010/01/20, 20:38:49 »

iface eth0 inet dhcp vervangen door

iface eth0 inet static
          address 192.168.1.xxx
          netmask 255.255.255.0
          gateway 192.168.1.1

op de plaats van de xxx moet je zelf een getal kiezen, ik neem altijd een hoog getal iets van 100 is goed.
Nadat je het hebt aangepast sla je hem op.

Aansluitend het volgende commando geven

sudo /etc/init.d/networking restart

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #17 Gepost op: 2010/01/20, 20:48:23 »
oké ik pas dit aan in /etc/network/interfaces/

maar hoe graak ik daar terug uit?

Ik heb het stukje code daaringeplaatst, maar commando's geven zit er nu niet meer in...
ik mis hier de ervaring.

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #18 Gepost op: 2010/01/20, 20:51:07 »
okay, je sluit af met crtl-x
Hij vraagt dan of jij je wijzigingen wilt opslaan
kies voor ja / yes en dan kom je weer terug bij de commandline

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #19 Gepost op: 2010/01/20, 20:54:12 »
oké lukt, tot hij zegt : error permission denied
ik heb zo het gevoel dat er iets mis is met de rechten?
Ik las dat je dan voor een commando sudo moet plaatsen, maar hoe doe je dit als hij jou iets vraagt?

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #20 Gepost op: 2010/01/20, 20:55:48 »
voer het commando zo uit

sudo /etc/network/interfaces
als je langere tijd wilt werken met sudo kun je ook dit doen

sudo su
Je hebt dan voor langere tijd de super user rechten. Die kun je weer afsluiten met

exit

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #21 Gepost op: 2010/01/20, 20:59:51 »
gelukt! hij zegt dat het succesvol aangepast is.

Hoe kan ik dit nu testen?
ik ging met webmin te werk gaan of putty?

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #22 Gepost op: 2010/01/20, 21:03:12 »
Voer daarna dit commando uit.
Zoals ik al eerder schreef

sudo /etc/init.d/networking restart
Daarna kun je een ping uitvoeren vanaf de server

Offline Zarathoustra

  • Lid
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #23 Gepost op: 2010/01/20, 21:04:01 »
super!
Ik heb met putty kunnen verbinden, dus nu weet ik zeker dat hij verbonden is!

Hartelijk dank voor de hulp tap !

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Verbindingsprobleem
« Reactie #24 Gepost op: 2010/01/20, 21:35:35 »
Mooi dat het nu werkt!

Oké dit had ik in de handleiding ook gelezen... Maar als ik dit intyp dan zegt hij permission denied..
Wat doe ik fout?
Als je permission denied (toegang geweigerd) krijgt, heb je geen rechten om het bestand te lezen. Doe er dan sudo voor om dat commande als root uit te voeren. Onthoudt dit als je die fout weer eens tegenkomt ;)

Het is wel raar want juist dat bestand heeft bij mij altijd standaard leesrechten voor iedereen.
Zo ziet het er bij mij uit: ls -l /etc/network/interfaces
-rw-r--r-- 1 root root 32 2009-10-25 14:08 /etc/network/interfaces
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!