Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid  (gelezen 871 keer)

Offline steventh

  • Lid
  • Steunpunt: Nee
Geen geluid
« Gepost op: 2010/01/19, 18:40:19 »
Hallo,

Ik heb een HP Pavillion Dv7 laptop en heb geen geluid in ubuntu 9.10.
Vlak na de upgrade naar Ubuntu 9.10 had ik wel geluid, maar bij de eerstvolgende boot niet meer.

Onder systeem > voorkeuren > geluid, kan ik onder de tab "hardware" kiezen tussen "intern geluid" en "R7 Audio Device [Radeon HD 4000 series]".

Ik heb reeds op de forums gezocht en heb dit uitgeprobeerd: klik hier, maar dit werkte niet. /etc/modprobe.d/alsa-base was overigens ook een lege file bij mij.

Ook merk ik op dat bij de opstart van ubuntu mijn geluid opspringt, dat hoor ik aan een klein plopgeluidje. Het geluidlampje op mijn toetsenbord verandert ook van rood (uit) naar wit (aan), maar net voor het inlogscherm springt het weer uit (plopgeluidje en lampje wordt rood). Als ik erop duw om het geluid weer aan te zetten, blijft het lampje rood en krijg ik in ubuntu te zien dat ik mijn geluid heb uitgeschakeld. Als ik nog eens duw blijft het lampje rood, terwijl ik in ubuntu te zien krijg dat het geluid weer aanstaat.

Kan iemand helpen?
Mvg,
Steven

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geen geluid
« Reactie #1 Gepost op: 2010/01/19, 21:27:23 »
Hallo

Probeer dit eerst eens;
open synaptic (pakketbeheer) tik bij zoeken (niet snel zoeken) linux-backports
Installeer de linux-backports-modules-alsa-karmic.
Herstart je machine en controleer daarna even je mixersettings
Meestal schijnt dit afdoende te zijn, anders moet er evt. nog iets in je
alsa-base.conf veranderd worden.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline steventh

  • Lid
  • Steunpunt: Nee
Re: Geen geluid
« Reactie #2 Gepost op: 2010/01/20, 16:11:43 »
Ik heb linux-backports-modules-alsa-karmic-generic geïnstalleerd en herstart.
Het lampje blijft nu wit (=aan) op mijn toestenbord! Maar er komt nog geen geluid door de sprekers.
Ik heb de hardware op zowel op "intern geluid" als "R7 audio device" getest, maar geen van beide doet het.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geen geluid
« Reactie #3 Gepost op: 2010/01/20, 16:43:39 »
Hmm,

Dat van die alsa-base klopt wel, die draad is van een iets oudere distro; intussen heet
die file alsa-base.conf

Open ook even een terminal en tik in;
aplay -l    (l= kleine letter L)

en post de uitkomst hier (waarschijnlijk duikt daar ook die HD 4000 oid. op)

Andere regel in je terminal die je even kan proberen;
cat /etc/modprobe.d/alsa-base.conf |grep hda-intel

als het goed is geeft hij daar een optie bijv. auto.
Als daar niets opduikt, staat die regel nog niet in je als-base.conf
met;
Alt+F2  (;dit  niet in een terminal, maar gewoon vanaf je buroblad doen)
gksudo /etc/modprobe.d/alsa-base.conf
kun je dit;
options snd-hda-intel model=auto
er bij in zetten (je kan natuurlijk ook meteen die optie van dat draadje
erin kloppen ipv. auto dus; hp-dv5) opslaan en machine herstarten.
Controleer ten overvloede nogmaals je mixer; staat er niets gemute ed. na herstart machine

Groeten Gerrit


-- = >  simplify if you can   -- = >

Offline steventh

  • Lid
  • Steunpunt: Nee
Re: Geen geluid
« Reactie #4 Gepost op: 2010/01/20, 17:29:10 »
De uitkomst van het eerste commando:
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: STAC92xx Analog [STAC92xx Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: STAC92xx Digital [STAC92xx Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: HDMI [HDA ATI HDMI], apparaat 3: ATI HDMI [ATI HDMI]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

De uitkomst van het tweede commando:
options snd-hda-intel power_save=10 power_save_controller=N
Moet of kan ik daar "auto" zetten, dmv een edit dan?

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Geen geluid
« Reactie #5 Gepost op: 2010/01/20, 21:00:43 »
Hallo

Nee je moet die complete regel toevoegen;
probeer eerst deze;
options snd-hda-intel model=hp-dv5
opslaan, herstarten testen (ook de mixer); nog niet goed?

vervang die regel dan voor;
options snd-hda-intel model=auto
opslaan, herstart, controleer

Groeten Gerrit

-- = >  simplify if you can   -- = >