Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: HP Scanjet 5300C werkt niet onder Ubuntu 9.10  (gelezen 5398 keer)

Offline plek

  • Lid
  • Steunpunt: Nee
HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Gepost op: 2010/01/13, 20:19:23 »
Wat is de situatie?
1. Na schone installatie van Ubuntu 7.10 werkte de scanner direct en zonder problemen.
2. Na schone installatie van Ubuntu 8.04 heb ik de scanner niet werkend gekregen, ook niet via dit forum (http://forum.ubuntu-nl.org/software-en-configuratie/hp-scanjet-5300c-werkt-niet/msg395399/#msg395399)
3. Na schone installatie van Ubuntu 9.04 heb ik de scanner niet werkend gekregen, ook niet via dit forum (http://forum.ubuntu-nl.org/software-en-configuratie/hp-scanjet-5300c-werkt-nog-niet-(9-04)/msg464321/#msg464321)
4. Vanaf de cd met Ubuntu 9.10 deed de scanner het probleemloos. HOERA!
5. Te vroeg gejuicht: na schone installatie van 9.10 deed de scanner het niet.
- de pakketten hplip, libsane, sane-utils, xsane en xsane-common zijn geïnstalleerd.
- bij installatie de bestaande /home ongemoeid gelaten
6. Op http://www.sane-project.org/sane-mfgs.html#SCANNERS heeft de scanner status Complete.
 
Wat gaat er fout?
Toepassingen->Grafisch->Xsane geeft achtereenvolgens:
1. het venster 'xsane 0.996'
2. het venster 'Histogram HP Scanjet 5300C'
3. na enkele minuten het venster 'Voorvertoning HP Scanjet 5300C:003', dat verder leeg bleef

Omdat er daarna minutenlang niets meer gebeurde, sloot ik het venster met het X-je. Dat leverde een venster 'Voorvertoning HP Scanjet 5300C:003 reageert niet' op, met de keuzes 'wachten' en 'geforceerd afsluiten'. Ik heb het laatste gekozen.
 
Wat heb ik onderzocht/geprobeerd?
1. In de terminal de opdracht sane-find-scanner geeft:
found USB scanner (vendor=0x03f0 [Hewlett Packard], product=0x0701 [Hewlett Packard ScanJet 5300C]) at libusb:001:003
2. In de terminal de opdracht scanimage -L geeft:
device `avision:libusb:001:003' is a Hewlett-Packard ScanJet 5300C flatbed scanner
 
Met sudo voor beide opdrachten is het resultaat hetzelfde.
 
3. Bij Systeem->Beheer->Gebruikers en groepen de gebruikersrechten van de accounts - maar niet van de root - uitgebreid (al heeft m.i. geen enkel gebruiksrecht met scanners te maken). Dit loste het probleem niet op.
 
4. Bij Systeem->Beheer->Gebruikers en groepen in de groep saned het hokje vóór de groepsleden - maar niet van de root - aangevinkt. Dit loste het probleem niet op.

5. Het pakket sane geïnstalleerd. Ook dit loste het probleem niet op.

Oplossingen?
1. Iemand had zijn scannerprobleem opgelost door het apparaat op de USB-aansluiting aan de voorkant van z'n PC te zetten. Zal bij mij niet gaan, want ik heb zo'n aansluiting niet.
2. Iemand had in een ander topic het idee dat het misschien met USB-rechten had te maken. Is dat een optie en zo ja, waar kan ik daar in het systeem iets mee proberen?

Ik zou graag weten hoe mijn scannerprobleem misschien kan worden opgelost. Na ruim een jaar van vruchteloos lezen, zoeken en proberen en zonder scanner ben ik er goed ziek van.

Alvast erg bedankt voor jullie hulp.
Groet, Peter
« Laatst bewerkt op: 2010/06/07, 08:57:24 door plek »

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #1 Gepost op: 2010/01/13, 21:07:42 »
Hier vind je een paar postings waarvan ik begrijp dat het wel kan werken.


https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/221750


Maar misschien is het beter om eerst naar deze te kijken

http://newyork.ubuntuforums.org/showthread.php?p=8628983
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #2 Gepost op: 2010/01/13, 22:33:02 »
ivo, dank voor je reactie.
Je eerste link ben ik de na installatie van 8.04 en 9.04 al doorheen geweest, zonder resultaat.
Je tweede link geeft als oplossing het veranderen van de scanresolutie, maar er komen bij mij geen schermen/menu'tjes waarin ik de resolutie kan benaderen. Dat zal dus ook niet gaan werken.

Toch bedankt voor het meedenken.

Groet, Peter

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #3 Gepost op: 2010/01/13, 22:51:07 »
Doet u eens een reboot met de scanner zelf aan.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #4 Gepost op: 2010/01/14, 11:22:57 »
@Wanda. De scanner heeft zelf geen aan/uit-knop (ik begrijp tenminste dat je dat bedoelt).

Wat ik me trouwens afvraag is wat er gebeurt tijdens de installatie van 9.10 dat de scanner het wel vanaf de cd doet, maar na installatie niet vanaf de pc. Zit daar iets voor een oplossing?

Groet, Peter

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #5 Gepost op: 2010/01/14, 11:39:07 »
Citaat van: plek
3. Bij Systeem->Beheer->Gebruikers en groepen de gebruikersrechten van de accounts - maar niet van de root - uitgebreid (al heeft m.i. geen enkel gebruiksrecht met scanners te maken). Dit loste het probleem niet op.

Die gebruikersrechten hebben wel degelijk met de scanner te maken. Onder andere.
Wat bedoel je met "uitgebreid"?
Voor je "hoofdgebruiker" (degene die ook het systeem mag beheren) wil je alle hokjes aldaar aanvinken.
Voor elke andere gebruiker wil je dat ook behalve de optie "mag het systeem beheren".

Citaat van: plek
2. Iemand had in een ander topic het idee dat het misschien met USB-rechten had te maken. Is dat een optie en zo ja, waar kan ik daar in het systeem iets mee proberen?

Die usb-rechten geef je jezelf in het bovenstaande verhaal.

Groetend,

Steven

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #6 Gepost op: 2010/01/14, 20:25:25 »
Steven, dank voor je reactie.

Citaat
Wat bedoel je met "uitgebreid"?
Direct na installatie van 9.10 heb ik de scanner geprobeerd. Toen die het niet deed, heb ik oa in 'Gebruikers en groepen' gekeken. Bij alle drie de accounts waren in lijst in de tab Gebruikersrechten vrij weinig hokjes aangevinkt. Met 'uitgebreid' bedoel ik dat ik lege hokjes heb aangevinkt.

Ik heb gedaan wat je voorstelde, maar de scanner doet het nog steeds niet.

Overigens zijn bij 'Gebruikers en groepen' in de tab Gebruikersrechten van de account root alle hokjes niet aangevinkt. Hoort dat zo?

Groet, Peter

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #7 Gepost op: 2010/01/15, 11:26:55 »
Citaat van: plek
Overigens zijn bij 'Gebruikers en groepen' in de tab Gebruikersrechten van de account root alle hokjes niet aangevinkt. Hoort dat zo?
Dat hoort zo.
Het "root"-account bestaat namelijk niet.
Dat is standaard zo en het is ook een goede zaak.

Ik neem trouwens aan, dat je niet bij elk account ook heb aangevinkt "mag het systeem beheren", want dat wil je (denk ik) niet.


Wat je scanner betreft:
ik zoek nog even met je mee.
Maar op dit moment weet ik even niets zinnigs te melden.

Groetend,

Steven

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #8 Gepost op: 2010/01/15, 11:36:13 »
@ Plek,

Hier staat (volgens mij) het antwoord op je vraag:
https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/72089

Het is Engels; laat het me maar weten als dat een probleem is.

Het komt er in het kort op neer, dat het pakket libsane vervangen moet worden voor een oudere versie.

Lukt het hiermee?

Groetend,

Steven

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #9 Gepost op: 2010/01/15, 12:06:26 »
@ Plek,

Hier staat (volgens mij) het antwoord op je vraag:
https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/72089

Het is Engels; laat het me maar weten als dat een probleem is.

Het komt er in het kort op neer, dat het pakket libsane vervangen moet worden voor een oudere versie.

Lukt het hiermee?

Groetend,

Steven

Dat staat ook vermeld in de andere URL die ik eerder al postte in dit topic, maar Plek zegt dat ie daar al langs is geweest en dat dat niet helpt.
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #10 Gepost op: 2010/01/15, 14:07:26 »
@ Plek,
Hier staat (volgens mij) het antwoord op je vraag:
https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/72089
Het is Engels; laat het me maar weten als dat een probleem is.
Het komt er in het kort op neer, dat het pakket libsane vervangen moet worden voor een oudere versie.
Lukt het hiermee?
Groetend,
Steven
Dat staat ook vermeld in de andere URL die ik eerder al postte in dit topic, maar Plek zegt dat ie daar al langs is geweest en dat dat niet helpt.
Sorry, het is niet de bedoeling je ideeën te jatten ;)
Je hebt namelijk gelijk. In mijn link wordt domweg weer verwezen naar jouw link.
Excuus.

Echter:
Plek, je bent daar langsgeweest, met een installatie van 8.04 en 9.04.
Misschien kan het uitmaken dat je nu 9.10 hebt.....

Een ander idee:
haal de benodigde bestanden en libs uit de repo's van Gutsy, indien mogelijk. Het is een onwaarschijnlijke noodgreep, maar ik heb zoiets ooit moeten doen. In mijn geval werkte het.
Het enige is: hij wil dan elke dag gaan zeuren om updates, omdat je oude versies gebruikt. Maar er is vast iemand die daar wel weer een oplossing voor heeft..... ;)

En verder blijven we nog even zoeken.
« Laatst bewerkt op: 2010/01/15, 14:15:08 door Steven Klein Haneveld »

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #11 Gepost op: 2010/02/14, 12:55:04 »
Steven en Ivo, dank voor het meedenken.
De suggestie libsane te vervangen door een oudere versie ben ik al eerder tegengekomen bij mijn zoektocht naar een oplossing voor het scannerprobleem. Er waren toentertijd echter enkele m.i. ervaren Ubuntugebruikers die dat sterk afraadden: het kán goed gaan - zoals kennelijk bij Ivo - maar ook tot nieuwe problemen leiden waarvan het alleen maar lastiger wordt de oorzaak te achterhalen (je hebt immers meerdere versies door elkaar). Ik probeer dat dus maar liever niet.

Samengevat is het probleem dus als volgt:

1. de scanner doet het vanaf de live-cd
2. op http://www.sane-project.org/sane-mfgs.html#SCANNERS heeft de scanner status Complete
3. na installatie doet de scanner het bij mij - hoofdgebruiker - niet, maar...
4. als mijn zoon zich onder zijn naam+wachtwoord aanmeldt, doet de scanner het wel !!??

Dat laatste is nieuw voor mij en biedt misschien aanknopingspunten voor de oplossing.

Wie heeft een idee?

Alvast dank voor de suggesties. Groet, Peter

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #12 Gepost op: 2010/02/15, 00:16:38 »
Citaat van: plek
Samengevat is het probleem dus als volgt:
1. de scanner doet het vanaf de live-cd
2. op http://www.sane-project.org/sane-mfgs.html#SCANNERS heeft de scanner status Complete
3. na installatie doet de scanner het bij mij - hoofdgebruiker - niet, maar...
4. als mijn zoon zich onder zijn naam+wachtwoord aanmeldt, doet de scanner het wel !!??
Dat laatste is nieuw voor mij en biedt misschien aanknopingspunten voor de oplossing.

Het spijt me bijzonder, maar dan lijkt het er toch op, dat de gebruiks-rechten voor usb niet goed staan.... Eerder in dit draadje had je die al uitgebreid, schreef je. Even een citaat:

Citaat van: plek
Direct na installatie van 9.10 heb ik de scanner geprobeerd. Toen die het niet deed, heb ik oa in 'Gebruikers en groepen' gekeken. Bij alle drie de accounts waren in lijst in de tab Gebruikersrechten vrij weinig hokjes aangevinkt. Met 'uitgebreid' bedoel ik dat ik lege hokjes heb aangevinkt.
.....
Overigens zijn bij 'Gebruikers en groepen' in de tab Gebruikersrechten van de account root alle hokjes niet aangevinkt. Hoort dat zo?

Ik heb eens gekeken bij mijzelf hier.
Bij mij kan ik niet eens de gebruiksrechten van "root" bekijken - het feit dat jij dat wel kan, doet mij vermoeden, dat je een "root"-account hebt aangemaakt. Dat is niet echt handig..... en zelfs onveilig.
Of bedoel je met "root" de hoofdgebruiker (jijzelf)?

Het feit dat je zoon wél kan scannen, betekent dat er restricties aan het gebruik van de scanner zitten. Ergens moet er dus een vinkje verkeerd staan.....

Controleer die accounts nog eens.

En laat je zoon eens inloggen, en kijk dan eens in de eigenschappen van de scanner. Misschien dat daar ergens een instelling is, die de scanner voorbehoud aan zijn account.

Curieuze kwestie trouwens.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #13 Gepost op: 2010/02/20, 16:42:40 »
Steven, dank voor je reactie.
Eerst een citaat van jou.
Citaat
Bij mij kan ik niet eens de gebruiksrechten van "root" bekijken - het feit dat jij dat wel kan, doet mij vermoeden, dat je een "root"-account hebt aangemaakt. Dat is niet echt handig..... en zelfs onveilig.
Of bedoel je met "root" de hoofdgebruiker (jijzelf)?
Via Systeem>Beheer>Gebruikers en groepen verschijnt er een scherm Gebruikersinstellingen met een lijstje namen. In dat rijtje kom ikzelf voor (hoofdgebruiker) en ook de naam 'root'; over die root had ik het. Die heb ik overigens niet zelf aangemaakt.
Als ik in datzelfde scherm klik op de knop 'Klik om wijzigingen te maken', kan ik na invoer van mijn wachtwoord van ieder gebruiker de eigenschappen bekijken, ook van die root.

Het probleem is nog wat vreemder geworden. Eerder meldde ik dat mijn zoon had gezegd wel te kunnen scannen. Gisteren onder zijn account ingelogd, maar scannen ho maar. Dezelfde verschijnselen als onder mijn account. Hij verzekerde me dat hij onder 9.10 toch echt heeft gescand.

Ik vrees dat ik nog steeds even ver ben als september 2008... Heeft iemand het ei van Colombus?

Alvast erg bedankt voor jullie reactie.

Gr, Peter
« Laatst bewerkt op: 2010/02/20, 16:46:41 door plek »

Offline Dave

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #14 Gepost op: 2010/02/20, 19:22:04 »
Het is mijn ervaring dat wanneer mensen allerlei zelf proberen ze zelden terug gaan naar de uitgangspositie.
Vele goede oplossingen gaan zo de mist in.

De scanjet werkt dus wel is de ervaring.
soms is het een kwestie van net een type lager te selecteren bij de standaard installatie.
Tis me niet duidelijk of die genoemd wordt verder.


Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #15 Gepost op: 2010/02/27, 17:40:09 »
@Dave.
Citaat
Het is mijn ervaring dat wanneer mensen allerlei zelf proberen ze zelden terug gaan naar de uitgangspositie.
Ik probeer niet allerlei dingen zelf. Wat ik doe om het probleem proberen op te lossen, zijn ideeen die me op dit forum aan de hand worden gedaan. Blijkt een idee niet te werken, dan herstel ik de oorspronkelijke situatie.

Citaat
De scanjet werkt dus wel is de ervaring.
Dat vind ik toch wat te optimistisch. Sinds september 2008 (!) heeft het ding het precies één keer gedaan na installatie, en dat hebben we niets eens kunnen reproduceren.

Citaat
soms is het een kwestie van net een type lager te selecteren bij de standaard installatie.
Die opmerking begrijp ik niet. Bij de installatie heb ik helemaal geen scanner kunnen selecteren, sterker nog, waarom zou ik dat doen als mijn scanner het vanaf de live-cd gewoon doet.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #16 Gepost op: 2010/03/01, 18:35:21 »
Onlangs kwam ik van ik meen Johan van Dijk de suggestie tegen een nieuwe gebruiker aan te maken; die heeft immers geen oude instellingen die mogelijk het scannerprobleem veroorzaken.

Ik heb daarom:
- onder mijn account (hoofdgebruiker) gebruiker Test aangemaakt (alleen naam en wachtwoord ingevoerd, verder niets gewijzigd)
- mijzelf afgemeld
- aangemeld als Test
De scanner deed het!

Toeval of niet? Daarom heb ik daarna:
- gebruiker Test afgemeld
- mijzelf weer aangemeld
Scannerprobleem deed zich weer voor (na klik op X-je in het enige schermpje dat verschijnt, gekozen voor 'geforceerd afsluiten')

En vervolgens:
- mijzelf afgemeld
- aangemeld als Test
Dat gaf een scherm met de mededeling 'geen apparaat vrij' (misschien niet vreemd, want ik had onder m'n eigen account immers geforceerd afgesloten).

Daarna heb ik:
- de computer herstart
- aangemeld als Test
... maar nu deed het scannerprobleem zich ook voor!?

Brengt dit de oplossing misschien dichterbij?

Alvast dank voor de inbreng.
Gr, Peter

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #17 Gepost op: 2010/03/01, 19:25:30 »
Als ik door mijn oogharen naar dit topic kijk, zie ik een rechten probleem. Wanneer met de verkeerde rechten files e.d worden aangemaakt is het bijzonder lastig deze weer in de originele staat terug te brengen.
Toch lijkt het mij verstandiger om de rechten weer in originele staat terug te brengen. En dan pas verder te werken.
En daarna (indien nodig) met de hand /etc/group bij te werken. B.v de regel sane users toe te voegen.

groet,

Theo

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #18 Gepost op: 2010/03/01, 19:59:45 »
Ik had zo'n probleem met mijn Scanjet 2400. Het was bij mij idd een rechtenprobleem. Bij 8.04 deed hij het wel gewoon, maar niet bij 9.10. Mijn aantekeningen geven de volgende oplossing die bij mij werkte:
1. installeer de driver zoals aangegeven staat (Hoeft misschien niet bij jou?)
2. ga naar menu optie Beheer->Gebruikers en Groepen
3. Ontgrendel via de knop midden onder (wachtwoord ingeven)
4. Klik op "Groepen beheren"
5 Zoek de groep "saned" op en voeg je gebuiker eraan toe via "Eigenschappen"
Dit zou al een oplossing kunnen zijn. Als je niet behoort tot de groep "saned"dan kun je niet scannen.

Een ander probleem bij mij was de rechten voor USB gebruik. Dit kan veranderd worden in de 70-persistent-net.rules:

6. Type in de terminal: "sudo gedit /etc/udev/rules.d/70-persistent-net.rules" (zonder quotes)
7. Plak het volgende onderaan de file en sla op.:
# USB devices (usbfs replacement)
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666"
SUBSYSTEM=="usb_device", MODE="0666"

Bij mij werkte dit. Misschien heb je andere problemen, maar het is een poging waard. Mijn scanjet was natuurlijk een 2400, niet dezelfde als die van jou.
« Laatst bewerkt op: 2010/03/01, 20:02:21 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #19 Gepost op: 2010/03/07, 13:07:06 »
@softbart Dank voor je antwoord. Ik heb ook het gevoel dat het een rechtenprobleem is. Opvallend dat een nieuwe gebruiker bij eerste keer aanmelden kan scannen, maar daarna niet meer. Wat blijft er in welk bestand hangen?

Ik begrijp overigens niet wat je bedoelt met:
Citaat
Wanneer met de verkeerde rechten files e.d worden aangemaakt is het bijzonder lastig deze weer in de originele staat terug te brengen. Toch lijkt het mij verstandiger om de rechten weer in originele staat terug te brengen.
Eerder heb ik namelijk op suggestie van iemand anders het volgende gedaan:
Citaat
Direct na installatie van 9.10 heb ik de scanner geprobeerd. Toen die het niet deed, heb ik oa in 'Gebruikers en groepen' gekeken. Bij alle drie de accounts waren in lijst in de tab Gebruikersrechten vrij weinig hokjes aangevinkt. Met 'uitgebreid' bedoel ik dat ik lege hokjes heb aangevinkt.
Dat loste het scannerprobleem overigens niet op.

Nav deze opmerking van jou:
Citaat
En daarna (indien nodig) met de hand /etc/group bij te werken. B.v de regel sane users toe te voegen.

Het bestand group in de map /etc ziet er als volgt uit:
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:alpha
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:alpha,denise,stephan
fax:x:21:alpha,denise,stephan
voice:x:22:
cdrom:x:24:alpha,denise,stephan
floppy:x:25:
tape:x:26:alpha,denise,stephan
sudo:x:27:
audio:x:29:pulse,alpha,denise,stephan
dip:x:30:alpha,denise,stephan
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:alpha,denise,stephan
sasl:x:45:
plugdev:x:46:alpha,denise,stephan
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
libuuid:x:101:
syslog:x:102:
fuse:x:103:alpha
lpadmin:x:104:alpha,denise,stephan
ssl-cert:x:105:
messagebus:x:106:
crontab:x:107:
mlocate:x:108:
ssh:x:109:
avahi-autoipd:x:110:
avahi:x:111:
netdev:x:112:alpha
couchdb:x:113:
haldaemon:x:114:
admin:x:115:alpha
saned:x:116:
pulse:x:117:
pulse-access:x:118:
gdm:x:119:
alpha:x:1000:alpha
sambashare:x:120:alpha
denise:x:1001:denise
stephan:x:1002:stephan

1. De regel saned:x:116 heeft geen usernamen. Als ik via Systeem>Beheer>Gebruikers en groepen ga naar Groepen beheren en dan de groep saned kies, staat er in het hokje vóór de 4 genoemde gebruikers (alpha, denise, stephan en root; die laatste heb ik niet aan de groep toegevoegd) geen vinkje. Doe ik dat voor de eerste 3 genoemde wel, dan komen deze namen in het bestand group achter saned:x:116 te staan,overigens niet in de volgorde zoals bij andere regels in dit bestand. Maakt dat nog wat uit?

2. Bovendien vind ik de regel sambashare:x:120:alpha op een vreemde plaats staan. Moet die niet 1 regel omhoog?

Kun je hier nog iets mee? Alvast bedankt.
Groet, Peter
« Laatst bewerkt op: 2010/06/07, 10:51:06 door Wanda »

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #20 Gepost op: 2010/03/07, 13:20:51 »
@MKe Dank voor je reactie. Wat jij bij stappen 1 t/m 5 voorstelt heb ik al geprobeerd, zonder resultaat.

Groet, Peter

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #21 Gepost op: 2010/03/07, 14:38:04 »
heb je de 70-persistent-net rules al bekeken? Dat moet ook goed staan.

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #22 Gepost op: 2010/03/07, 15:07:21 »
@plek,

1. Zo ingevuld is ook goed. (met "users" bedoel ik de groep "users" dan heb je ook alle users in één keer)
2. Geen probleem samba wordt later in de installatie aangemaakt.

puntje 6 van @MKe al gecontroleerd? Wordt nogal eens genoemd bij problemen.

Paardenmiddel, wat doet sudo xsane?

groet,

Theo

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #23 Gepost op: 2010/03/11, 17:58:49 »
@MKe en softbart: dank voor jullie reactie.

1. Ik heb de suggestie van MKe "sudo gedit /etc/udev/rules.d/70-persistent-net.rules" geprobeerd. Dat bleek geen oplossing; het scannerprobleem deed zich weer voor.

2. Ik heb ook het paardemidel "sudo xsane" geprobeerd. Er kwam een venster met de waarschuwing xsane vooral niet als root uit te voeren. Dat heb ik toch gedaan, maar het scannerprobleem werd er niet mee opgelost.
Het commando leverde in het terminalvenster meerdere keren deze boodschap op:
"(xsane:1683): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated".

Mij zegt dat niets. Jullie wel?

Groet, Peter

Offline plek

  • Lid
  • Steunpunt: Nee
Re: HP Scanjet 5300C werkt niet onder Ubuntu 9.10
« Reactie #24 Gepost op: 2010/03/11, 21:04:11 »
Nog wat meer info.

Eerder heb ik iets gemeld over het aanmaken van een nieuwe gebruiker om te kijken of die kon scannen, zie post #16. Dat was echter met aan- en afmelden en herstarten. Hoe zou het zijn zonder die stappen?

Daarom heb ik als hoofdgebruiker een volgende nieuwe gebruiker aangemaakt, alleen naam en wachtwoord ingevuld. Daarna de pc herstart en aangemeld als die nieuwe gebruiker. Direct Toepassingen->Grafisch->Xsane en ja, het scannen lukte! Maar toen ik de verschillende scan-vensters netjes had gesloten en direct wéér koos voor Toepassingen->Grafisch->Xsane kwam het scannerprobleem naar voren.

Wat gaat er toch fout na die eerste keer dat het wèl lukt?!

Groet, Peter