Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009  (gelezen 1406 keer)

Offline darko

  • Lid
  • Steunpunt: Nee
Sinds gisteren krijg ik de melding in zowel Pidgin als Emesene: protocol not supported by server.

Nou wist ik van Tweakers dat MSN in december ofzo de ondersteuning van een bepaalde versie van het MSN protocol heeft laten vallen, maar ik heb er eigenlijk al die tijd geen last van gehad en de tussentijd heb ik ook al updates van libpurple (wat in ieder geval Pidgin op de achtergrond gebruikt) voorbij zien komen. Echter ik heb er sinds gisteren ineens last van. Googlend op internet vind ik alleen een incident van begin december. Maar niet iedereen schijnt er last van te hebben en ik vind verder niets op het internet dat meer mensen er recent last van hebben.

Dus mijn vraag: hebben meer mensen last met Pidgin en Emesene in met name Hardy Heron 8.04 LTS. Of is er iets anders aan de hand is?
Voor alle duidelijkheid ik kan via een browser op dezelfde pc gewoon in mijn account en van een (andere) windows pc met de meest recente AMsn (dus een andere niet Live Messenger) kan ik er ook op. Dus het ligt niet aan het feit dat ik mijn wachtwoord ben vergeten of dat mijn account is geblokkeerd.

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #1 Gepost op: 2010/01/13, 22:29:58 »
Ik gebruik Emesene in Hardy. Heb net geprobeerd het te openen en krijg inderdaad ook die foutmelding. Eergisteren kon ik nog zonder problemen inloggen. ???

Dat protocol dat gewijzigd is was per 1 september, dus dat zal hier niets mee te maken hebben. 't Kán een fout in Emesene zijn, maar jij hebt het óók met Pidgin, dus............

Hmmm......... klik ik in Emesene op 'Nieuw account' in menu Bestand, kom ik uit op een site van Windows Live ID?! :o  Kan me helemaal niet herinneren dat ik daar geweest ben toen ik Emesene installeerde en instelde. ???
Ik heb het donkerbruine vermoeden dat het probleem niet aan Emesene of Pidgin ligt, maar aan Microsoft. >:(


Edit: weer 'ns te snel geweest. Op de site van Emesene: http://www.emesene.org/ staat dat versie 1.0.1 niet meer ondersteund wordt. En dat is nou net de enige versie die in Synaptic te vinden is. Dus dat wordt dan denk ik een nieuwere versie ophalen van emesene.org
Ben niet zo weg van installeren buiten Synaptic om, maar er zal niet veel anders opzitten als je Emesene wilt blijven gebruiken. :|
Toevallig dat ook Pidgin bij jou dan die foutmelding geeft.
« Laatst bewerkt op: 2010/01/13, 22:45:22 door Mikkel »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #2 Gepost op: 2010/01/13, 22:58:17 »
Vraagje aan 'de kenners':
op http://packages.ubuntu.com/karmic/all/emesene/download staat een kader met instructies voor het aanpassen van de sources.list, waarin wordt gesproken over Karmic (zie schermafdruk). Betekent dit dat de nieuwste Emesene-versie niet geschikt is voor Hardy (en kunnen we Emesene dus niet meer gebruiken), of kunnen wij het woord karmic simpelweg vervangen door hardy?

Offline darko

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #3 Gepost op: 2010/01/15, 11:01:47 »
Dank voor je reactie.
Ik heb in de tussentijd verder zitten Googlen, maar ik ben bang dat we ook geen update in Hardy hoeven te verwachten. In de LTS komen alleen updates voor ernstige security issues. En dit valt niet onder het kopje security issue.  Zo vind je een aantal work-arounds om de laatste versie van Pidgin in Hardy te installeren nav de protocol-wijziging van Yahoo vorig jaar.

Wat betreft upgraden naar latere versies buiten de repos om: mijn ervaring is dat dit niet altijd eenvoudig mogelijk is. Als er afhankelijkheden zijn met nieuwe versies van systeem libraries Libc e.d. dan weet ik niet wat dan wijsheid is: Proberen die systeem libraries naar nieuwere versies te krijgen?
Ik heb geen idee of dat kan of dat ze vast zitten aan een recentere Linux-kernel. En als het wel kan weet ik niet wat het voor gevolgen heeft voor de andere pakketten die afhankelijk zijn. Wat dat betreft weet ik niet in hoeverre het mogelijk is meerdere versies van systeemlibraries naast elkaar te draaien. Voor zover ik weet kan het niet, maar ik weet het niet zeker.

Maar in zijn algemeenheid ik heb ook geen zin om het uit te proberen en dan uren bezig te zijn met repareren en trouble shooten.
Ik denk dat ik binnenkort maar gewoon upgrade naar de laatste versie van Ubuntu.
Ik dacht dat ik het mezelf makkelijk maakte door dit keer bij de LTS te blijven, maar het is toch niet zo simpel in de praktijk.


Offline chaos7

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #4 Gepost op: 2010/01/15, 11:18:49 »
@ darko

zou dit je oplossing kunnen zijn?
http://forum.ubuntu-nl.org/server-en-netwerk/verbinding-email-via-pidgin-verbroken/

en dan het antwoord van gandyman, heeft mij maar ook anderen goed geholpen.
« Laatst bewerkt op: 2010/01/15, 11:20:50 door chaos7 »
leven is wat je overkomt terwijl je andere plannen maakt

Offline darko

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #5 Gepost op: 2010/01/15, 11:42:19 »
Dank voor je reactie. Dit draadje had ik zelf niet gevonden toen ik eerst op dit forum ging zoeken.
Maar het bevestigt nog eens wat ik zelf ook had gevonden elders op het web.
Maar te zien aan de reacties van jou en anderen gaat het zonder problemen werken voor Pidgin. Dus misschien probeer ik het vanavond toch wel uit. Ik kijk wel even wat ik ga doen.


Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #6 Gepost op: 2010/01/16, 13:58:19 »
........... ik ben bang dat we ook geen update in Hardy hoeven te verwachten. In de LTS komen alleen updates voor ernstige security issues. En dit valt niet onder het kopje security issue.

.......... in zijn algemeenheid ik heb ook geen zin om het uit te proberen en dan uren bezig te zijn met repareren en trouble shooten.

Een upgrade naar de nieuwste Emesene-versie verwacht ik ook niet in Hardy, nee. Het is jammer dat er niet een paar maanden gewacht is met het stoppen van het ondersteunen van de Emesene-versie die in Hardy aangeboden wordt, voor die Ubuntu-gebruikers die van LTS- naar LTS-versie gaan. :( 
Als ook Pidgin niet meer werkt zonder daarvoor eerst het een en ander te moeten installeren/wijzigen, doe ik het de komende maanden dan wel met aMSN.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #7 Gepost op: 2010/01/16, 14:35:20 »
........... ik ben bang dat we ook geen update in Hardy hoeven te verwachten. In de LTS komen alleen updates voor ernstige security issues. En dit valt niet onder het kopje security issue.

.......... in zijn algemeenheid ik heb ook geen zin om het uit te proberen en dan uren bezig te zijn met repareren en trouble shooten.

Een upgrade naar de nieuwste Emesene-versie verwacht ik ook niet in Hardy, nee. Het is jammer dat er niet een paar maanden gewacht is met het stoppen van het ondersteunen van de Emesene-versie die in Hardy aangeboden wordt, voor die Ubuntu-gebruikers die van LTS- naar LTS-versie gaan. :( 
Als ook Pidgin niet meer werkt zonder daarvoor eerst het een en ander te moeten installeren/wijzigen, doe ik het de komende maanden dan wel met aMSN.
Zou niet mogen vind ik.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Offline chaos7

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #8 Gepost op: 2010/01/16, 16:48:00 »
op die manier wat gandyman zegt kan je wel weer verder in de LTS met pidgin.
ik vindt pidgin ook fijner dan aMSN, emesen of wat voor ander progje.
en als ik het zo red tot de volgende LTS versie. vindt ik het helemaal goed.
zolang je maar weet dat het zo is, en er ook naar handelt is er toch niks aan de hand?

heb zat meegemaakt dat er bij andere O.S.-en veel vaker dingen niet ge-update worden waar je zo vaak achter aan moet om het weer voor elkaar te krijgen.
komt er een nieuwe versie werkt vaak het oude niet meer en een trammelant wat je hebt om het goed voor elkaar te krijgen!!!!!!!

ik ben erg blij met Ubuntu en dit forum met de hulpvaardige mensen hier.

een goede oplossing tot de volgende LTS vindt ik
leven is wat je overkomt terwijl je andere plannen maakt

Offline darko

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #9 Gepost op: 2010/01/19, 18:59:04 »
Vandaag (maar kan ook al paar dagen beschikbaar zijn) is er een update van libpurple in Hardy die naast een hele reeks security issues ook terugschakelt naar v8 van het MSN protocol. Hierdoor werkt Pidgin weer in de LTS.

Ik dacht laat dit nog even weten.


Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: Pidgin + Emesene in Hardy: Protocol not supported dd.12-1-2009
« Reactie #10 Gepost op: 2010/01/19, 20:05:44 »
Dan duim ik maar dat er voor Emesene binnenkort ook nog iets dergelijks komt.