Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] 2de harddisk mount probleem  (gelezen 944 keer)

Offline davy.vereycken

  • Lid
  • Steunpunt: Nee
[OPGELOST] 2de harddisk mount probleem
« Gepost op: 2010/01/11, 18:29:21 »
Ik heb onlangs een 2de harddisk toegevoegd aan men pc.

Ik heb onder men userfolder een subdirectory aangemaakt en in fstab een mountpoint gemaakt naar deze subdirectory:
/dev/sdb6  /home/davy/slave           ext4    defaults        0       2

Dit werkt allemaal. Enige probleem is dat op men desktop een icoon verschijnt voor deze nieuwe harddisk, net alsof ik bvb een usb stick ofzo toegevoegd heb. Weet iemand de reden en hoe dit niet meer te laten verschijnen. Ik weet dat je dergelijke desktop iconen kan weglaten via gconf-editor maar dit wil ik niet daar usb sticks en camera's wel moeten verschijnen.

Ik snap niet waarom dit gebeurd daar het geen externe hd is maar gewoon een ide schijf.
« Laatst bewerkt op: 2010/01/19, 10:27:36 door davy.vereycken »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #1 Gepost op: 2010/01/11, 18:46:18 »
Het verwondert mij sterk, want vroeger was dit niet zo. Vroeger werden alleen schijven die onder je /media aangekoppeld werden, getoond op de desktop. Schijven, aangekoppeld elders, worden niet getoond op de desktop.

Kan je eens controleren met het commando "mount" of de schijf wel gemount is zoals je verwacht?

Offline davy.vereycken

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #2 Gepost op: 2010/01/11, 21:46:47 »
Alles lijkt me normaal via mount: sdb6 is correct gemount

/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda1 on /mnt/winxp type vfat (rw,utf8,umask=007,gid=46)
/dev/sda6 on /mnt/winxpdata type vfat (rw,utf8,umask=007,gid=46)
/dev/sda8 on /home type ext4 (rw)
/dev/sdb6 on /home/davy/slave type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/davy/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=davy)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #3 Gepost op: 2010/01/11, 22:18:54 »
Ziet er inderdaad normaal uit. Als je toch een icoon krijgt op de desktop, dan lijkt er iets veranderd in 9.10 in vergelijking met vroeger, en ik vind het vast geen vooruitgang. Ik kan dit evenwel zelf niet testen.

Offline davy.vereycken

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #4 Gepost op: 2010/01/12, 08:32:48 »
En in het linkerpaneel van nautilus krijg je ook een eject icoon naast de schijf dus hij ziet het precies echt als externe schijf.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #5 Gepost op: 2010/01/12, 11:39:15 »
Wat zegt het commando

sudo mount -a

Als je op de eject knop drukt, wordt hij dan effectief afgekoppeld? Zoals hij nu in /etc/fstab is aangemeld, zou je dat niet mogen kunnen.

Het icoon blijft er ook na een herstart?

Probeer voor de aardigheid de schijf in /etc/fstab eens te mounten met de UUID inplaats dan met de device name. De UUID vind je in de uitvoer van het commando "sudo blkid". Kopieer het gedeelte "UUID="#cijfers en letters#" en plak dat in de plaats van "/dev/sdb6" in je /etc/fstab.


Offline davy.vereycken

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #6 Gepost op: 2010/01/12, 20:39:13 »
Nee, de eject knop werkt inderdaad niet :
Error unmounting: umount exited with exit code 1: helper failed with:
umount: only root can unmount UUID=d08b4df9-d537-4481-81c3-96cb08607b94 from /home/davy/slave

fstab aanpassen met uuid geeft geen verschil

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #7 Gepost op: 2010/01/13, 09:30:28 »
Je schijf is normaal en correct gemount. Dat een icoon verschijnt, verbaast me. Het laatste wat je nu nog eens kan proberen, is eens aan te koppelen onder /mnt. Nu koppel je aan onder je home, en misschien werkt het mechanisme zo, dat niet alleen de schijven aangekoppeld onder /media, maar ook die in je home, als icoon getoond worden. Hierna ben ik aan het einde van mijn latijn.

Offline davy.vereycken

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #8 Gepost op: 2010/01/13, 17:40:22 »
Als ik ze onder /mnt aankoppel... toont hij inderdaad het icoon niet. Thanx, probleem opgelost dus... alhoewel ik het toch geen goeie feature van ubuntu vind om alles onder /home eveneens als externe schijf te zien

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: 2de harddisk mount probleem
« Reactie #9 Gepost op: 2010/01/13, 17:57:43 »
Dan heb ik nu ook bijgeleerd over de werking van dat systeem.

Om toch aan de schijf te kunnen waar je dat wil, gebruik je natuurlijk een symbolische link. Hou Ctlr+Shift ingedrukt, en sleep het koppelpunt van de schijf naar je home. Hierdoor wordt er een symbolische link gemaakt. Hernoem die naar "davy" en je kan net als voorheen die schijf in /home/davy/ terugvinden en gebruiken.

Conventioneel gebeurden alle mounts in /mnt. Overzichtelijk voor de systeembeheerder en handig voor handmatige mounts: je typt "mount /mnt/" en dan tab, en je krijgt een lijstje van mogelijke aankoppelingspunten. Invullen, <enter> en klaar.