Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Applet probleem in firefox (Karmic), werkt wel op andere PC  (gelezen 504 keer)

Offline foobar

  • Lid
  • Steunpunt: Nee
Applet probleem in firefox (Karmic), werkt wel op andere PC
« Gepost op: 2010/01/06, 14:15:46 »
Ik heb hier een web server met een java applet.
Op mijn ene PC werkt het feilloos.
Op de andere PC krijg ik hetvolgende:

Exception in thread "cvcs applet" java.lang.NoClassDefFoundError: xplug$SI
   at java.lang.Class.getDeclaredConstructors0(Native Method)
   at java.lang.Class.privateGetDeclaredConstructors(Class.java:2406)
   at java.lang.Class.getConstructor0(Class.java:2716)
   at java.lang.Class.newInstance0(Class.java:343)
   at java.lang.Class.newInstance(Class.java:325)
   at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:572)
   at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:532)
   at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:711)
Caused by: java.lang.ClassNotFoundException: xplug$SI
   at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:264)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332)
   ... 8 more
java.lang.NullPointerException
   at net.sourceforge.jnlp.NetxPanel.runLoader(NetxPanel.java:99)
   at sun.applet.AppletPanel.run(AppletPanel.java:380)
   at java.lang.Thread.run(Thread.java:636)
java.lang.NullPointerException
   at sun.applet.AppletPanel.run(AppletPanel.java:430)
   at java.lang.Thread.run(Thread.java:636)

De browser toont "Applet not initialized".

Beide PCs draaien in princiepe dezelfde configuratie (Karmic, firefox-3.5).

Er moet ergens een subtiel configuratieverschil zijn maar ik vind het dus niet.
Op beide PCs wordt de IcedTea Java Web Browser plugin gebruikt.

Iemand enig idee waarom het wel werkt op de ene en niet op de andere?
Zou het iets kunnen te maken hebben met bepaalde Java settings?