Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: film database  (gelezen 2233 keer)

Offline jootn

  • Lid
  • Steunpunt: Nee
film database
« Gepost op: 2009/12/30, 12:33:09 »
Hallo allemaal,

ik ben hier bezig met een film database aan het aanleggen...

ik heb in mijn /var/www een map series, dat wordt dan dus: /var/www/series
en ik wil vanuit de index.php pagina naar mijn serie map verwijzen. Maar daar slaag ik niet echt in.

series staan hier: /media/LaCie/series/serie.avi

ik wil dus vanuit de index.php pagina van mijn /var/www/series naar die serie.avi verwijzen en laten afspelen in een divx web player.
(series staan hier op de server, en ik wil ze makkelijk allemaal beschikbaar stellen voor al mijn pc's in netwerk)

het volgende heb ik geprobeerd:
...<embed type="video/divx" src="../../../media/LaCie/SERIES/serie.avi" cust...

hij doet hierbij niets :(

weet iemand raad hierover?

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
Re: film database
« Reactie #1 Gepost op: 2009/12/30, 12:57:18 »
Euhm ja. Dat is namelijk heel eenvoudig te verklaren. Apache is zo ingesteld dat je niet buiten de map /var/www kan. Dit is om veiligheidsredenen die je zelf ook wel kan bedenken.
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: film database
« Reactie #2 Gepost op: 2009/12/30, 13:01:40 »
Euhm ja. Dat is namelijk heel eenvoudig te verklaren. Apache is zo ingesteld dat je niet buiten de map /var/www kan. Dit is om veiligheidsredenen die je zelf ook wel kan bedenken.
Dus om mogelijk te maken wat jij wilt zul apache leesrechten moeten geven op de map die jij wilt.

Misschien is het makkelijker om de DocumentRoot (nu /var/www/) te veranderen in /media/series. En ervoor zorgen dat apache leesrechten heeft.

Je kunt ook een Alias (HOSTNAME/series/) aanmaken die dan naar die ene dir verwijst...)

Er zijn verschillende manieren om te doen wat jij wilt jootn ;)
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline jootn

  • Lid
  • Steunpunt: Nee
Re: film database
« Reactie #3 Gepost op: 2009/12/30, 14:21:40 »
Onderstaande heb ik toegevoegd aan mijn /etc/apache2/sites-enabled/000-default:

Alias /view_serie/ /media/LaCie/series/
<Directory "/media/LaCie/series/">
Options FollowSymLinks Indexes Multiviews
IndexOptions FancyIndexing
</Directory>

dan /etc/init.d/apache2 restart

en nu krijg ik het volgende als ik surf naar http://localhost/view_serie/

Forbidden

You don't have permission to access /view_serie/ on this server.
Apache/2.2.12 (Ubuntu) Server at localhost Port 80

heb een chmod -R 777 gedaan op de series map, maar maakt geen verschil

edit: er zit een index.php bestand in de Lacie/serie directory ;)
« Laatst bewerkt op: 2009/12/30, 14:33:13 door jootn »

Offline jootn

  • Lid
  • Steunpunt: Nee
Re: film database
« Reactie #4 Gepost op: 2009/12/30, 17:49:22 »
ik heb hier dus al een hele tijd zitten op klooien, en het is me nog niet gelukt, en ik vrees dat het me niet gaat lukken.

Ik heb dus die alias toegevoegd aand apache2.conf bestand van apache, ik heb die alias toegevoegd aan een nieuw bestand (alias) in de map config.d ik heb vanalles geprobeerd xD

ik heb geprobeerd te chmodden, maar mijn ls -la blijft altijd hetzelfde, ik heb de ownder van de map proberen te veranderen in www-data:www-data, ook mislukt


en toen.... kwam ik opeens op het idee dat het een externe hdd is (hoogstwaarschijnlijk ntfs dus) en ik vrees dat het daardoor is dat ik er geen permissies kan opzetten?

Klopt mijn redenering?

Groeten

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: film database
« Reactie #5 Gepost op: 2010/01/04, 10:31:34 »
ik heb geprobeerd te chmodden, maar mijn ls -la blijft altijd hetzelfde, ik heb de ownder van de map proberen te veranderen in www-data:www-data, ook mislukt

en toen.... kwam ik opeens op het idee dat het een externe hdd is (hoogstwaarschijnlijk ntfs dus) en ik vrees dat het daardoor is dat ik er geen permissies kan opzetten?
Dat zou goed kunnen. Wanneer je externe HD gemount wordt, zullen permissies toegewezen worden.
Dus volgens mij kun je dat niet zomaar chmodden als het NTFS is. Je kunt wel ergens instellen hoe de HD gemount moet worden. Dat kan in /etc/fstab, en pysdm is een grafisch programma daarvoor.

Hiermee zou je kunnen instellen dat de files op je NTFS worden gemount met group www-data.
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!