Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hardeschijf niet bereikbaar hoe automatisch mounten (opgelost)  (gelezen 4209 keer)

Offline L.P.

  • Lid
  • Steunpunt: Nee
Ik kan niet bij mijn 2e hardeschijf komen wil niet mounten niet formateren helemaal niks schijf is nog goed kan er alleen niet opkomen

Wie kan mij helpen ben al dagen aan het zoeken op het forum maar kan niks vinden
« Laatst bewerkt op: 2009/12/27, 21:05:09 door L.P. »

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #1 Gepost op: 2009/12/27, 15:28:23 »
Heb je al geprobeerd met de live cd met Gparded
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #2 Gepost op: 2009/12/27, 15:29:38 »
Ja werd het alleen maar slechter van maar zal het nog een keer proberen

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #3 Gepost op: 2009/12/27, 15:41:08 »
Nu doet hij het alleen mount hij niet automatisch dit is heel vervelend aangezien hij in een server zit hoe kan ik dit voorelkaar krijgen dat ik dit niet meer hoef in te voeren

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #4 Gepost op: 2009/12/27, 16:11:27 »
"pysdm" installeren en schijf mounten aan welke map jij wilt.
Zo starten "gksudo pysdm"

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #5 Gepost op: 2009/12/27, 16:20:10 »
Geinstaleerd nu heb ik sda en sdb sdb is mijn opstart schijf hier kan ik alles aan veranderen alleen sda kan ik niks aan veranderen hier blijft alles grijs

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #6 Gepost op: 2009/12/27, 16:24:55 »
Ik ken niet veel van pysdm, maar je beschrijving likt me te wijzen op een rechten/eigenaar-probleem. Dat is best op te lossen, maar ik zou niet direct weten welke parameters er mee moeten...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #7 Gepost op: 2009/12/27, 16:31:10 »
Ik kan de schijf alleen maar benaderen via het UUID misschien dat dit wat helpt

Offline Lexaldo

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #8 Gepost op: 2009/12/27, 16:38:19 »
Misschien kun je met gksudo nautilus wel op die schijf komen.
Dan erop rechtsklikken en dan eigenschappen->rechten->eigenaar.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #9 Gepost op: 2009/12/27, 16:46:14 »
Al gedaan wil alleen maar dat hij automatisch word gezien zit op een server en dit is niet makkelijk

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #10 Gepost op: 2009/12/27, 19:36:21 »
Weet niemand het ? want ik heb die hardeschijf nodig

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #11 Gepost op: 2009/12/27, 20:08:55 »
Je zal in de file /etc/fstab een lijntje moeten toevoegen.

Misschien is er in deze link iets te vinden.

http://www.marcus-furius.com/?p=25

Overigens hoort dit onderwerp thuis in de afdeling "netwerken en servers".
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar
« Reactie #12 Gepost op: 2009/12/27, 20:13:33 »
Die link is voor een NAS deze heb ik niet ik heb de hardeschijf intern zitten en welke catagorie dit hoort weet ik nie precies het heeft met hardware en drivers te maken maar je oke ook met servers en netwerk
Maar met die link schiet ik niet veel op ik hoop dat er een antwoord komt want begin er aardig ziek van te worden er zal vast wel iemand wezen die dit weet

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten
« Reactie #13 Gepost op: 2009/12/27, 20:32:50 »
Ok, ik heb het draadje nog eens doorgenomen. Je benadert de PC via een server (vandaar mijn verwarring), maar dat zou verder eigenlijk geen verschil moeten uitmaken.
Doe eens in een terminal, achtereenvolgens,sudo blkid en cat /etc/fstaben post die twee uitkomsten hier. Doe er ineens ook maar cat /etc/mtabbij, daarin zou je schijf moeten te vinden zijn als je ze eerst handmatig hebt gemount.

Staat er overigens iets op, op die schijf ?
En heb je een mountpoint voorzien in je eigen bestandssysteem ?
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten
« Reactie #14 Gepost op: 2009/12/27, 20:48:19 »
Hier de uitslag van je verzoek

luite@PROLIANT:~$ sudo blkid
[sudo] password for luite:
/dev/sda1: UUID="37de5c72-5c18-4f0e-8db2-6bd77478e7b9" TYPE="ext3"
/dev/sdb1: UUID="65162df2-6a66-4bf0-b455-09a536a9499f" TYPE="ext3"
/dev/sdb5: UUID="59432df7-b4ca-40e1-993b-7165980cdf03" TYPE="swap"
luite@PROLIANT:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc         defaults                    0  0 
# / was on /dev/sdb1 during installation
UUID=65162df2-6a66-4bf0-b455-09a536a9499f  /media/disk2    ext3         relatime,errors=remount-ro  0  2 
# swap was on /dev/sdb5 during installation
UUID=59432df7-b4ca-40e1-993b-7165980cdf03  none            swap         relatime,errors=remount-ro  0  0 
/dev/scd0                                  /media/cdrom0   udf,iso9660  user,noauto,exec,utf8       0  0 
/dev/fd0                                   /media/floppy0  auto         rw,user,noauto,exec,utf8    0  0 
# /dev/sda                                   /media/disk     ext3         relatime                    0  2 
/dev/sda1                                  /media/disk
# aankoppelen sda1
#UUID=37de5c72-5c18-4f0e-8db2-6bd77478e7b9 /home ext2
luite@PROLIANT:~$ cat /etc/mtab
/dev/sdb1 / ext3 rw 0 0
proc /proc proc rw 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
/dev/sdb1 /media/disk2 ext3 rw,relatime,errors=remount-ro 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
/dev/sda1 /media/disk ext3 rw 0 0
gvfs-fuse-daemon /home/luite/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=luite 0 0
luite@PROLIANT:~$

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten
« Reactie #15 Gepost op: 2009/12/27, 20:50:35 »
Het volgende heb ik in fstab zelf gezet

/dev/sda1                                  /media/disk

met sudo mount -l /dev/sda1 /media/disk kan ik wel op de hardeschijf komen herstart ik de server dan is het verdwenen daarom die regel in fstab
Het bestadsysteem is ext3


Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten (opgelost)
« Reactie #16 Gepost op: 2009/12/27, 21:08:08 »
Heb de volgende regel toegevoegd

/dev/sda1            /media/disk            ext3            auto,exec,rw                 0   2

auto = automatisch aankoppelen hier zocht ik na
exec = dat er programma┼Ť mogen opstarten van de schijf
rw   = lezen en schrijven

Hier staat het ook dit heeft heel erg geholpen

http://wiki.ubuntu-nl.org/community/Fstab

Bij algemene opties kijken opties met een , scheiden

Bedankt iedereen voor de hulp kan ik eindelijk verder

Offline djurny

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten
« Reactie #17 Gepost op: 2009/12/27, 21:13:47 »
# /dev/sda                                   /media/disk     ext3         relatime                    0  2  
/dev/sda1                                  /media/disk
ik zou hier sowieso de eerste regel uitcommentarieren, en de 2e regel weghalen.. er is niet gegarandeerd dat als je een onvolledige fstab entry heb staan, dat die dan ook correct uitgevoerd wordt tijdens boot.. na wat speurwerk in /etc/init.d/mountall.sh / /lib/init/mount-functions.sh wordt er expliciet gekeken naar alle opties die een fstab entry behoort te hebben..
kijk anders even in de manpage naar wat er allemaal gespecificeerd hoort te worden..

edit;
zag dat je er al uit was.. kan zijn dat 'auto' al bij 'defaults' hoort, dus misschien kan je daar nog wel iets simplificeren :)
echo "Ka Me Ha Me Ha Me Ha!" | tr [A-Z] [a-z]

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hardeschijf niet bereikbaar hoe automatisch mounten (opgelost)
« Reactie #18 Gepost op: 2009/12/28, 10:58:01 »
Beter nog is de schijfverwijzing vervangen door de UUID van de schijif, (zie je output van "sudo blkid" hierboven)

UUID="37de5c72-5c18-4f0e-8db2-6bd77478e7b9"        /media/disk            ext3            auto,exec,rw                 0   2

In plaats van je huidige opties kan je gewoon "defaults" nemen: wat je aangeeft zijn immers al de defaults.