Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Calibreren touchpad Genius Wizardpen  (gelezen 1558 keer)

Offline arnoldijzermans

  • Lid
  • Steunpunt: Nee
Calibreren touchpad Genius Wizardpen
« Gepost op: 2009/12/16, 12:12:48 »
Lotgenoten :-)

Ik maak gebruik van een Genius pen (G-pen 450).
Bij de installatie van Karmic heb ik de driver gebruikt die op deze website staat (https://help.ubuntu.com/community/TabletSetupWizardpen).
De pen op zich werkt prima, maar ik zou de touchpad graag wat gevoeliger zien.
Hierin staat dat er ook een callibreer functie voor de pad inzit, maar die heb ik nog niet gevonden.

Iemand enig idee waar ik deze moet zoeken?

cheerio
Arnold


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Calibreren touchpad Genius Wizardpen
« Reactie #1 Gepost op: 2009/12/16, 16:00:23 »
Zoeken hoeft niet, je moet wat commando's in de terminal geven
1 cd calibrate Waarschijnlijk moet het langer zijn, zoek eerst met Bestanden zoeken waar het mapje staat Bijv. cd /usr/Gpen/calibrate. Als je in de map staat type dan eerst dir Nu zie je wat er in staat en zie je of je de goede map te pakken hebt.
2 Vervolgens type je make
3 Nu dit commando let op het . en de sudo voor het commando, na de ENTER je wachtwoord invullen, je ziet geen sterretjes of balletjes, helemaal niets, na intypen van je ww, op ENTER drukken. sudo ./wizardpen-calibrate /dev/tablet-event bewaar een kopie van de lijst die je ziet.
4 Sla de voorbeelden over als de calibratie werkt, zo niet moet je de waarden aanpassen zoals in de voorbeelden staan.
X configureren
1 sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup Dit maakt een kopie, als er iets niet gaat zo als het moet gaan
2 sudo vim /etc/X11/xorg.conf als je een makkelijker tekstverwerker wilt
  sudo gedit /etc/X11/xorg.conf wat jij het makkelijkste vind.
3 Plak de inhoud van de calibratie onder de muis regels.
4 Plaats dit InputDevice "WizardPen Tablet" "AlwaysCore" onder de ServerLayout.
  Bestaat deze laatste regel niet bij jou, moet je deze er handmatig bij zetten.
5 Sla het bestand op, gewoon op opslaan klikken.Sluit de tekstverwerker af.
6 Herstart X zonder een aan gesloten tablet.
7 Nu open dit bestand sudo vim /etc/rc.local of met sudo gedit /etc/rc.local vind ik iets makkelijker werken.
8 Zet nu de volgende tekst erin, boven exit0
XORG_CONF=/etc/X11/xorg.conf
if [ -e /dev/tablet-event ]; then
  sed -ie 's/^\(\s*\)\#\(\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\1\2/' "$XORG_CONF"
  echo "Udev created /dev/tablet-event = Tablet present! - Tablet-driver enabled"
else
  sed -ie 's/\(^\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\#&/' "$XORG_CONF"
  echo "Udev did NOT create /dev/tablet-event = tablet NOT present! - Tablet-driver disabled"
fi
Het beste kan je dit kopiëren en plakken.
9 Sla het bestand op en sluit het af.
Sluit je Tablet aan, is niet hotplugged vandaar eerdere script en voer dit commando uit.
sudo /etc/init.d/rc.local start

Kom je er zo uit? Anders post je maar weer. :)
In der Beschränkung zeigt sich der Meister.

Offline arnoldijzermans

  • Lid
  • Steunpunt: Nee
Re: Calibreren touchpad Genius Wizardpen
« Reactie #2 Gepost op: 2009/12/16, 17:04:54 »
Ik ga het eens proberen.

Dank in ieder geval. Als ik tegen problemen aanloop klop ik virtueel weer even aan :-)


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Calibreren touchpad Genius Wizardpen
« Reactie #3 Gepost op: 2009/12/16, 18:33:21 »
Prima, niet te hard kloppen op mijn beeldscherm. ;)
In der Beschränkung zeigt sich der Meister.

Offline arnoldijzermans

  • Lid
  • Steunpunt: Nee
Re: Calibreren touchpad Genius Wizardpen
« Reactie #4 Gepost op: 2009/12/18, 16:52:02 »
Wil niet helemaal zoals ik wil

Het lijkt er op, dat de geniusdriver niet gebruikt wordt.
Ga nu beide drivers even verwijderen en opnieuw installeren. Dan kan ik zien of de oplossing van Gijsbert ook werkt

cheerio

Offline arnoldijzermans

  • Lid
  • Steunpunt: Nee
Re: Calibreren touchpad Genius Wizardpen
« Reactie #5 Gepost op: 2009/12/30, 23:06:59 »
Ola

Voor wie het willen weten. Mijn G-Pen 450 werkt nu perfect.
De overgevoeligheid van de pad is voorbij.
Mocht je net als ik last hebben van het continue verslepen van allerlei zaken als je gebruik maakt van de pen, voeg dan de volgende regels toe aan het bestand:
/etc/hal/fdi/policy/99-x11-wizardpen.fdi

 <merge key="input.x11_options.TopZ" type="string">10</merge>
 <merge key="input.x11_options.BottomZ" type="string">511</merge>
 <merge key="input.x11_options.MaxZ" type="string">511</merge>

Pad niet meer overgevoelig en de boel werkt prima de luxe.

groet