Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met dual monitor setup  (gelezen 2463 keer)

Offline B3rt

  • Lid
  • Steunpunt: Nee
problemen met dual monitor setup
« Gepost op: 2009/12/11, 17:36:13 »
Ik heb vandaag een 2de monitor aangesloten, deze werkt maar niet zoals ik het wens.
Ik heb aal diverse configuraties geprobeerd maar zonder resultaat.

Mijn setup:
- ubuntu 9.10
- nvidia G98 (GeForce 8400 GS)
- driver "nivdia"
- ik gebruik ook compiz
- rechts (primairy) monitor Toshiba PA3553 (22") @1680x1050
- links (secondary) monitor Samsung Syncmaster 940w @1440x900

Ik heb nu op beide monitoren een eigen desktop omgeving, ik kan dus geen schermen van de ene naar de andere monitor verplaatsen. OOk kan ik bv niet op elke monitor firefox starten, de ene monitor geeft een error dat firefox al draait.

Wat ik wil is 2 aparte schermen, ik bedoel hiermee dus dat als ik een scherm maximaliseer dit programma alleen op de actieve monitor maximaliseert, ook moet ik programma's van de ene naar de andere monitor moeten kunnen verplaatsen. Zoals al gemeld heb ik diverse opties gebruikt maar niets werkt, geen enkele optie geeft het gewenste effect.

Wie kan me een tips geven of mijn xorg.conf aanpassen zodat deze wel werkt zoals ik wil?

Dit is mijn huidige xorg.conf:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 1440 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Toshiba PA3553"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT-0: 1680x1050 +0+0, CRT-1: nvidia-auto-select +0+0; CRT-0: 1680x1050 +0+0, CRT-1: nvidia-auto-select +240+75"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: problemen met dual monitor setup
« Reactie #1 Gepost op: 2009/12/11, 22:45:01 »
Heb je nvidia-settings al geinstalleerd of is deze al geinstalleerd?
Dan in een terminal gksudo nvidia-settings Daar kan je van alles instellen en dan wegschrijven naar je xorg.conf, daarom gksudo ervoor anders wordt het bestand niet opgeslagen. Succes.
In der Beschränkung zeigt sich der Meister.

Offline B3rt

  • Lid
  • Steunpunt: Nee
Re: problemen met dual monitor setup
« Reactie #2 Gepost op: 2009/12/11, 22:51:14 »
nvidia-settings is standaard al geïnstalleerd, hiermee krijg ik het dus niet werkend
Je kunt niet veel instellen, alleen twinview en seperate X screen, beide zijn niet wat ik wil.
Bij twinview krijg ik 1 grote desktop, als ik maximize wordt alles over de 2 schermen gemaximaliseerd en bij seperate X screen 2 geheel aparte desktops waarmee ik dus geen programma's van de ene naar de andere monitor kan verplaatsen. (dit laatste is een absolute **must have** voor mij, dit is de reden van de 2de monitor)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: problemen met dual monitor setup
« Reactie #3 Gepost op: 2009/12/11, 23:18:15 »
Lees dit eens door http://en.gentoo-wiki.com/wiki/HOWTO_Dual_Monitors hopelijk kan je er iets mee.
In der Beschränkung zeigt sich der Meister.

Offline Wybren

  • Lid
  • Steunpunt: Nee
Re: problemen met dual monitor setup
« Reactie #4 Gepost op: 2009/12/12, 12:34:34 »
Moet je dan niet gewoon Twinview kiezen en dan xinerama uitzetten? Dan kan je gewoon vensters maximaliseren op uitsluitend 1 monitor. Werkt hier goed. Behalve dan dit onopgeloste probleem.

Offline B3rt

  • Lid
  • Steunpunt: Nee
Re: problemen met dual monitor setup
« Reactie #5 Gepost op: 2009/12/14, 12:40:51 »
Nee dat werkt niet goed.
Het probleem is dat de 2 monitors van 2 verschillende formaten zijn.

De rechter is 1680x1050 en de linker 1440x900
Als ik twinview activeer mis ik bij de linker monitor het onderste gedeelte.

Bij twinview laat ie bij mij dus de desktop op hetzelfde formaat zien.
Ook de achtergrond wordt gerekt over 2 schermen, de linker scherm heeft ook geen panels en ik kan er ook geen toevoegen.

Ik wil dus eigenlijk 2 aparte desktops met eigen panels en achtergrond maar ik moet wel programma's kunnen verslepen van de ene naar de andere monitor.