Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: WLAN problemen met Fonera 2.0n router  (gelezen 2093 keer)

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
WLAN problemen met Fonera 2.0n router
« Gepost op: 2009/12/09, 12:52:24 »
Beste nieuwsgroepers,

Ik heb problemen met de WLAN-verbindingen met mijn nieuwe Fonero 2.0n router onder HH 8.04 LTS op mijn Medion Akoya MD96360,
model SAM 2010.

lspci toont o.a.:
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g
uit de WICD.log:2009/12/09 11:33:26 :: Connecting to wireless network BINNEN2
2009/12/09 11:33:27 :: Putting interface down
2009/12/09 11:33:27 :: Releasing DHCP leases...
2009/12/09 11:33:27 :: Setting false IP...
2009/12/09 11:33:27 :: Stopping wpa_supplicant
2009/12/09 11:33:27 :: Flushing the routing table...
2009/12/09 11:33:27 :: Putting interface up...
2009/12/09 11:33:27 :: Attempting to authenticate...
2009/12/09 11:33:28 :: Running DHCP
2009/12/09 11:33:28 :: There is already a pid file /var/run/dhclient.pid with pid 134519072
2009/12/09 11:33:28 :: Internet Systems Consortium DHCP Client V3.0.6
2009/12/09 11:33:28 :: Copyright 2004-2007 Internet Systems Consortium.
2009/12/09 11:33:28 :: All rights reserved.
2009/12/09 11:33:28 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/12/09 11:33:28 ::
2009/12/09 11:33:28 :: wmaster0: unknown hardware address type 801
2009/12/09 11:33:29 :: wmaster0: unknown hardware address type 801
2009/12/09 11:33:29 :: Listening on LPF/wlan0/00:1d:92:13:4d:e4
2009/12/09 11:33:29 :: Sending on   LPF/wlan0/00:1d:92:13:4d:e4
2009/12/09 11:33:29 :: Sending on   Socket/fallback
2009/12/09 11:33:30 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
2009/12/09 11:33:30 :: DHCPOFFER of 192.168.10.236 from 192.168.10.1
2009/12/09 11:33:30 :: DHCPREQUEST of 192.168.10.236 on wlan0 to 255.255.255.255 port 67
2009/12/09 11:33:30 :: DHCPACK of 192.168.10.236 from 192.168.10.1
2009/12/09 11:33:30 :: bound to 192.168.10.236 -- renewal in 20673 seconds.
2009/12/09 11:33:30 :: DHCP connection successful
2009/12/09 11:33:30 :: Connecting thread exiting.
2009/12/09 11:33:30 :: Sending connection attempt result Success

Dat lijkt dus allemaal succesvol te verlopen. Maar ik krijg maar geen internettoegang. Bedraad via deze router of de daarvoor hangende Fritz! Modem/router is er geen probleem.
De Fonero-router is ingesteld met DHCP als instelling. Het IP-adres dat door wlan0 wordt ontvangen deugt ook (192.168.10.236)
Ik heb allerlei instellingen ook al geprobeerd.
Maar het lukt me niet een systematische analyse te maken van wat er mis gaat.

Daarbij komt dat het wlan-kaartje voorheen altijd gewerkt heeft met 10Hex WEP op mijn vorige FONERA+-router. Het is me met dat kaartje nooit gelukt iets met WPA(2) te doen.

Op de Fonera site is voor de 2.0n is een apart verhaaltje te vinden als je met WEP wilt werken. Dat heb ik gevolgd. De hexcode is op de router ingevoerd. Alleen weet ik niet wat ik nu bij WICD in moet vullen, hoewel ik volgens mij alle mogelijke combinaties al geprobeerd heb.

ifconfig:
eth0      Link encap:Ethernet  HWaddr 00:1d:92:4b:ac:d0 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Base address:0x4000

eth0:avahi Link encap:Ethernet  HWaddr 00:1d:92:4b:ac:d0 
          inet addr:169.254.8.227  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:16 Base address:0x4000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1755 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1755 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:88537 (86.4 KB)  TX bytes:88537 (86.4 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1d:92:13:4d:e4 
          inet addr:192.168.10.236  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:92ff:fe13:4de4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:657 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10571 (10.3 KB)  TX bytes:110170 (107.5 KB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1D-92-13-4D-E4-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Bij voorbaat dankend,

pablo k

Offline rja

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #1 Gepost op: 2009/12/10, 01:22:15 »
Wat voor output geeft iwconfig in een terminal ??


Offline skynetbbs

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #2 Gepost op: 2009/12/10, 15:45:37 »
get RC1 from http://nbd.name/test/20091209_FON2303_2.3.5.0-RC1_DEV.tgz
which should fix your wifi

This evening there will be an RC2 which will fix the "Iptables Nat SIP" issue that reboots the fonera when you have eg Ekiga running...

you can find more about it on IRC (www.fonosfera.org)



Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #3 Gepost op: 2009/12/10, 18:01:53 »
De iwconfig laat het volgende zien:
~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"BINNEN2" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:18:84:88:22:1E   
          Bit Rate=1 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality=72/100  Signal level=-48 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Offline track

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #4 Gepost op: 2009/12/10, 21:15:26 »
Hoi Pablo,

dit is een enigzins parallele draad:
http://forum.ubuntu-nl.org/internet-en-draadloos/na-update-ubuntu-9-10-geen-draadloze-verbinding-met-laptop-meer/
Het gaat om hetzelfde wlan-toestel, niet ?   Zij hebben ook een "rev.B".

Misschien kun je daarmee verder ?

track
« Laatst bewerkt op: 2009/12/10, 21:18:14 door track »

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #5 Gepost op: 2009/12/10, 21:43:44 »
@track:
Ja, lijkt gelijksoortig. Maar, eh, mijn wlan-kaartje (rt61)  heeft het altijd gedaan, totdat ik die nieuwe router eraan hing. En volgens wicd maak ik nog wel verbinding met de router. Mijn probleem lijkt meer een DNS-probleem te zijn. Ik kom niet voorbij de GW, wat zeg ik, ik kom al pingend niet tot de gw.

Ik geloof dat ik van het weekeind mijn oude Fonera+ maar weer terugzet en kijk of ik dan weer draadloos het interpret kan bewonderen.

Bedankt voor het meedenken.

@skynetbbs:
zie hierboven en wat kort door de bocht. met een tgz. Moet ik dan eerst nog leren dat bakje te hakken. Voel meer voor een bijl.

Bedankt,
en ik weet dat het belegen is, maar ik voel dan meer voor een lijstje met uit-doos-herkende usb-wlan-adapters. Dat scheelt dan toch een hoop gezeik, kost helaas iets meer. Maar ik heb naast de computer ook nog een leven.
Als ze vroeger vroegen hoe ik toch in de it terecht was gekomen dan was mijn antwoord dat er een tijd in mijn leven was dat ik te weinig problemen had. Da's nu wel anders...

groeten,

pablo k




Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: WLAN problemen met Fonera 2.0n router
« Reactie #6 Gepost op: 2009/12/10, 22:23:42 »
Eerder dan verwacht heb ik mijn oude Fon+-routertje weer op zijn plek gezet. En binnen 3 minuten had ik verbinding, draadloos, met het bakje en internet. Wel met armzalige WEP-encryptie, maar liever iets dan niets.
Iets meer dan WEP-encryptie met dat kaartje en de router is mij nooit gelukt. Misschien voor het andere draadje....

garoeten,

pablo k