Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: windiws mount niet automatisch  (gelezen 931 keer)

Offline HKAK

  • Lid
  • Steunpunt: Nee
windiws mount niet automatisch
« Gepost op: 2009/12/04, 12:57:39 »
Hallo,

ik moet telkens  handmatig mounten.

fstab zegt dit;

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sdb1 :
UUID=ba51737a-fdf9-4ab4-8314-4d80e256fa7f / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid,relatime 0 1
# Entry for /dev/ !! UNKNOW DEVICE !! :
UUID=309188ea-2d40-458f-8179-0ed7bac35fa6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/sda1 /media/windows auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sda7 /media/mandy auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0
/dev/sdg2 /media/DSL auto nouser,noauto,atime,rw,nodev,noexec,nosuid 0 0

wat doe ik hier aan?

groet, harald
Kubuntu 10.04, Mandriva 2010, XP,
core 2 duo 2024Rm 2x 160gb sata
2.6.32-22-generic / 2.6.26-7mdv
http://sites.google.com/site/sitehkak/

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #1 Gepost op: 2009/12/04, 13:06:06 »
Op de regel
/dev/sda1 /media/windows auto users,atime,noauto,rw,nodev,noexec,nosuid 0 0noauto veranderen in auto.

En die eerste auto weghalen....
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #2 Gepost op: 2009/12/04, 13:11:06 »
Ohnee, dat is nog niet voldoende. Je moet ook aangeven als welk file systeem het gemount moet worden. Windows moet als NTFS gemount worden. Die van mij ziet er ongeveer zo uit:

/dev/sda2  /media/windows     ntfs-3g      noexec,nosuid,noauto,defaults,locale=en_US.UTF-8  0  0  Jij wilt dan nog even de noauto in auto veranderen.
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #3 Gepost op: 2009/12/04, 14:29:41 »
ik moet telkens  handmatig mounten.

fstab zegt dit;
.............

Wat ik in jouw fstab mis zijn de UUID's, de 'partitienamen', dus. Die hóéven er dacht ik niet beslist te staan, maar mét UUID's werkt het volgens mij altijd.
In mijn fstab staat bijvoorbeeld dit:
# /dev/sda1
UUID=3323-14DE /media/sda1 vfat defaults,uid=1000,utf8,umask=077  0  0
en die (FAT32-)partitie wordt zonder problemen gemount.

De UUID's van de betreffende partities kun je vinden m.b.v. het terminalcommando:
sudo blkidVoer de juiste UUID-nummers in in jouw fstab-bestand, op de manier zoals in mijn voorbeeld staat, waar bij mij vfat staat zet je het door jou gebruikte bestandsformaat (bijvoorbeeld ntfs), daarna opslaan en het terminalcommando mount -atypen en het zou moeten werken.
Staat er nog een fout in fstab, dan krijg je dat te zien in het terminalvenster.

Edit: behalve een juist ingevulde fstab, moet er voor alles wat je wilt mounten, wél een map zijn aangemaakt waar dat 'alles' aan gekoppeld moet worden.
Dus in jouw geval moeten er in de map /media mappen staan met de namen:
cdrom0
windows
mandy
DSL
« Laatst bewerkt op: 2009/12/04, 14:44:24 door Mikkel »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #4 Gepost op: 2009/12/04, 14:55:34 »
fstab zegt dit;

# Entry for /dev/ !! UNKNOW DEVICE !! :
UUID=309188ea-2d40-458f-8179-0ed7bac35fa6 none swap sw 0 0

Nog even dit, in jouw fstab staat de partitie waarop swap staat, aangegeven als:  !! UNKNOW DEVICE !! :
Daar moet nog de juiste partitienaam ingevuld worden. Ook die vind je via het commando sudo blkid
« Laatst bewerkt op: 2009/12/04, 19:30:57 door Mikkel »

Offline HKAK

  • Lid
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #5 Gepost op: 2009/12/04, 15:17:56 »
bedankt voor de bijdragen....

ik heb het idee dat mn installatie nogal brak is;

in het begin had ik Kubuntu geinstalleerd, toen dat niet goed werkte (na enige upgrades) ben ik in Gnome verder gegaan....

ik ga denk ik eerst maar een schone installatie van Kubuntu doen en ga lekker een dagje alles opnieuw instellen....

nogmaals bedankt!!!!
Kubuntu 10.04, Mandriva 2010, XP,
core 2 duo 2024Rm 2x 160gb sata
2.6.32-22-generic / 2.6.26-7mdv
http://sites.google.com/site/sitehkak/

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: windiws mount niet automatisch
« Reactie #6 Gepost op: 2009/12/04, 19:26:12 »
Als je toch opnieuw gaat installeren. Dan zou ik je /home op een aparte partitie zetten. Deze kan dan blijven staan als je in de toekomst weer opnieuw gaat installeren.
Je kunt hier tijdens de installatie voor kiezen. Bij handmatige partities...
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!