Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?  (gelezen 1591 keer)

Offline chicky

  • Lid
  • Steunpunt: Nee
Gegroet, als nieuwkomer op dit forum hoop ik dat ik alles goed doe. Als dat niet zo is hoor ik het graag.

Situatie:
Na een lange tijd Ubuntu onder een VM op windows XP te hebben gedraaid heb ik vandaag de stap genomen op Ubuntu echt te installeren.
Ging allemaal heel soepel, maar nu heb ik het probleem dat bij opstarten Windows XP wel zichtbaar is in Grub2 maar verder niets doet ?!?

De schijf indeling is als volgt (volgens Palimpsest Disk Utility)
sda MBR
sda1 WinXP NTFS (bootable)
sda2 Data NTFS
sda3 Swap
sda4 Linux Ext4

In Grub2 wordt Windows aangegeven met /dev/sda1
Als ik in Grub2 (met e) naar de settings ga krijg ik het volgende te zien:
insmod ntfs
setroot =(hd0,1)
search .... blabla
drivemap -s (hd0) ${root}
chainloder +1

ik heb al geprobeerd om de settings te editten, maar dat werkt niet waarom weet ik niet, ik blijf terug komen op de settings zoals hierboven.

Moet ik Grub2 aanpassen? of moet ik iets anders doen? (Ubuntu verwijderen en opnieuw installeren, ik mag het niet hopen toch)

Ik hoop dat er iemand is die mij kan helpen!!
« Laatst bewerkt op: 2009/11/26, 12:35:29 door chicky »

Offline ruujan

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #1 Gepost op: 2009/11/25, 00:33:26 »
Gebeurt er helemaal niks of krijg je een foutmelding?

Offline Ward De Ridder

  • Lid
    • http://leerubuntu.org
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #2 Gepost op: 2009/11/25, 12:14:02 »
Je zou eens kunnen proberen om 
sudo update-grub2
uit te voeren vanuit de terminal, het zou kunnen dat dan alles automatisch in orde wordt gemaakt.
http://leerubuntu.org (ubuntu zonder moeilijke woorden)
VoidWarranties (Hackerspace) Antwerpen
Microsoft isn't evil, they just make really crappy operating systems. - Linus Torvalds

Offline chicky

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #3 Gepost op: 2009/11/25, 13:50:30 »
Hoi,

@ruujan
Er gebeurt helemaal niets, geen foutmelding of wat dan ook. Het Grub2 verwijnt en linksboven in het scherm komt "Grub2 loading" (geloof ik) te staan voor ongeveer een halve seconden en dan kom ik terug in het startv enster.

@Ward De Ridder
sudo update-grub2 heb ik ook al geprobeerd, maar dit levert ook niets op.

Ik ben het spoor een beetje kwijt.

Kan ik niet op de een of andere manier de procedure die je tijdens de install doorloopt, opnieuw doorlopen om grub helemaal opnieuw op te bouwen?

Offline tiemenhakvoort

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #4 Gepost op: 2009/11/25, 15:48:25 »
probeer dit eens:

in ubuntu in terminal scherm typen:

sudo os-prober
daarna:

sudo update-grub
en daarna herstarten en kijken of alles wel werkt
It ain't me, it ain't me, I ain't no fortunate one, no.

Offline chicky

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #5 Gepost op: 2009/11/25, 21:58:41 »
Net even sudo os-prober uitgeprobeert.
Ik krijg netjes te lezen:

/dev/sda1:Microsoft Windows XP Professional:Windows:chain

Hierna sudo update-grub

Opnieuw opgestart en jammer genoeg niets nieuws. Precies zoals eerst;
Er gebeurt helemaal niets, geen foutmelding of wat dan ook. Het Grub menu verdwijnt en linksboven in het scherm komt "Grub loading" te staan voor ongeveer een halve seconden en dan kom ik terug in het start menu.


Offline verhelsttje

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #6 Gepost op: 2009/11/25, 22:01:46 »
probeer eens wat er hier staat :
http://wiki.ubuntu-nl.org/community/Grub2#HerstelGrub2meteenLiveCD
is mij ook gelukt

Offline chicky

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #7 Gepost op: 2009/11/25, 22:28:57 »
net even de tip van verhelsttje  geprobeerd, maar ook geen effect.
De partitie met windows bestaat nog gewoon.
Ik kan de bestanden gewoon benaderen vanuit ubuntu, maar booten ho maar.

Ik denk dat ik Grub of de MBR maar eens helemaal ga verwijderen en dan kijken of ik windows weer aan de gang krijg. Hierna grub opnieuw installeren ?!?!?
Iemand nog andere idee├źn?

Offline chicky

  • Lid
  • Steunpunt: Nee
Re: Windows XP start niet op na instal Ubuntu 9.10, foutje in Grub2?
« Reactie #8 Gepost op: 2009/11/25, 22:59:20 »
nou, uiteindelijk met een windows xp cd opgestart. in recovery mode fixboot en fixmbr uitgevoerd.
hierdoor kon ik weer gewoon bij windows komen. pphhh

nu weer de tip van verhelsttje  geprobeerd, en nu werkt het, gelukkig.

wat mij aangaat probleem opgelost.

iedereen bedankt voor de input.
« Laatst bewerkt op: 2009/11/25, 23:04:04 door chicky »

Offline verhelsttje

  • Lid
  • Steunpunt: Nee
allee ben blij voor u dat het gelukt is ..