Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: PC hangt soms vast in de BIOS  (gelezen 3564 keer)

Offline Robertos

  • Lid
  • Steunpunt: Nee
PC hangt soms vast in de BIOS
« Gepost op: 2009/11/23, 23:47:24 »
Soms loopt de PC bij het opstarten in de BIOS fase vast (niet bij een reboot), een harde reset is dan de enigste oplossing.
Af en toe krijg ik de melding "Reboot and select proper boot device or insert boot media in selected boot device and press a key"
Meestal krijg ik echter niet eens een melding, maar hangt de PC gewoon vast op een willekeurig moment in de BIOS.
Dit gebeurd enkel en alleen als er via Ubuntu (9.10) afgesloten is, bij XP heb ik hier geen last van.
Omdat er in de BIOS fase geen OS actief is, heb ik ook bitter weinig aan de logs vrees ik.

Om hardware uit te sluiten heb ik de harde schijf gecontroleerd met een tooltje van de fabrikant (Hitachi), en tevens heb ik Memtest laten lopen. Volgens de uitkomst van beide testen is er niets loos, en (nogmaals) als ik XP afsluit en daarna de PC opstart heb ik nergens last van. De BIOS heb ik al gereset naar de standaard waarden. De temperatuur en stroomvoorziening is ook in orde.

Ik weet even niet meer waar ik het probleem moet zoeken, maar ik heb een vermoeden dat Ubuntu op de een of andere manier niet correct/te snel afsluit. Buiten dit draait 9.10 prima, dus het zou helemaal perfect zijn als dit ook nog op te lossen is. Weet iemand misschien een (mogelijke) oorzaak/oplossing?


Edit: Topic maar op "opgelost" gezet.
Het probleem is niet echt opgelost, maar op de betreffende PC heb ik weer 9.04 geïnstalleerd.
Aangezien er niets wordt gelogd in de BIOS fase is het verdomd lastig om achter de oorzaak te komen.
Met 9.04 heb ik geen enkel probleem meer, op de overige PC's draait 9.10 overigens vlekkeloos.
« Laatst bewerkt op: 2010/03/24, 18:06:58 door Robertos »

Offline Robertos

  • Lid
  • Steunpunt: Nee
PC hangt soms vast in de BIOS
« Reactie #1 Gepost op: 2010/03/24, 18:06:46 »
Aangezien ik XP (ja die heb ik soms nog nodig) opnieuw wilde installeren heb ik dit ook gedaan bij Ubuntu. In dit geval maar weer 9.10 erop gezet aangezien ik met 10.04 nog even wil wachten. Wederom heb ik hetzelfde probleem dat de PC af en toe blijft hangen in de BIOS. Het lijkt er wel op dat Ubuntu op de een of andere manier slordig wordt afgesloten en dat dat de veroorzaker zou kunnen zijn. Ik weet momenteel even niet waar ik het zou moeten zoeken in ieder geval, maar dit is echt hopeloos...  :(

Heeft iemand misschien tips voor dit probleem op te lossen, mochten er logbestanden nodig zijn dan geef ik die graag.
« Laatst bewerkt op: 2010/03/24, 18:08:21 door Robertos »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: PC hangt soms vast in de BIOS
« Reactie #2 Gepost op: 2010/03/24, 20:12:09 »
Indien pc hangt in de bios, dan is er iets aan de hand met je hardware.

In de bios de de reclame uitzetten, dan zie je waar hij blijft hangen, welk apparaat dus of waar?
Geen boot gevonden betekend dat je hd niet is opgestart.
Ik zou de voeding uitwisselen om te testen of het dan weg is. Vaak geeft een voeding problemen en dit is niet na te meten.
Daarom is bij een pc kopen het allebelangrijkste, de voeding, en dit word altijd vergeten.

1 voeding wisselen(lenen om te testen).
2 andere hd proberen.

Altijd alle hardware vermelden, sommigen kunnen dan betere conlusies trekken.
Is de voeding sterk genoeg? Misschien te oud.

Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: PC hangt soms vast in de BIOS
« Reactie #3 Gepost op: 2010/03/24, 21:33:53 »
Bedankt voor je reactie, jan11000.

Tot gisteren had ik een multiboot systeem (XP, Ubuntu 9.04 en openSUSE 11.2) waarmee ik totaal geen problemen had. Geen enkele keer is de PC blijven hangen in de BIOS fase. Ik installeer Ubuntu 9.10 en het is weer opnieuw raak. Aan een hardware probleem zou je normaal gesproken inderdaad als eerste denken, ik heb de HDD in ieder geval getest en als het de voeding zou zijn dan zou ik het toch ook moeten hebben merken bij die multiboot?

Het lijkt er gewoon op dat er iets niet goed/te snel wordt afgesloten en dat dit bij het booten problemen veroorzaakt. Eerlijk gezegd had ik de hoop dat dit inmiddels niet meer het geval zou zijn bij 9.10 na verschillende updates, jammer genoeg dus wel. Of versie 10.04 uiteindelijk dan wel zal draaien is ook nog maar de vraag.  :( Het gaat trouwens om een samengestelde PC (Qmotion), de harware is te vinden in de bijlage.

Edit: Precies hetzelfde probleem als wat ik nu ondervind: http://ubuntuforums.org/showthread.php?t=1347654
Edit 2: Ik ben even de logs an het doorneuzen, verdachte items wil ik best even hier plaatsen:

Mar 24 18:17:47 PCRWUBUNTU kernel: [    0.169082] ACPI: Interpreter enabled
Mar 24 18:17:47 PCRWUBUNTU kernel: [    0.169090] ACPI: (supports S0 S1 S3 S4 S5)
Mar 24 18:17:47 PCRWUBUNTU kernel: [    0.169114] ACPI: Using IOAPIC for interrupt routing
Mar 24 18:17:47 PCRWUBUNTU kernel: [    0.177633] ACPI Warning: Incorrect checksum in table [OEMB] - A0, should be 92 20090521 tbutils-246
Mar 24 18:17:47 PCRWUBUNTU kernel: [    0.177770] ACPI: No dock devices found.


Mar 24 21:40:56 PCRWUBUNTU kernel: [    0.177602] ACPI Warning: Incorrect checksum in table [OEMB] - A0, should be 92 20090521 tbutils-246
Mar 24 21:40:56 PCRWUBUNTU kernel: [    0.471594] ACPI Warning: Incorrect checksum in table [SSDT] - 0F, should be 16 20090521 tbutils-246


Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.179782] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.179929] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P2._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.180003] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.180146] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.180224] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P8._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.180292] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P9._PRT]
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.183458] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.183574] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *10 11 12 14 15)
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.183688] ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 6 7 10 11 12 14 15)
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.183801] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 10 11 12 14 15)
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.183915] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.184042] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.184158] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 *5 6 7 10 11 12 14 15)
Mar 24 22:15:32 PCRWUBUNTU kernel: [    0.184271] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 10 11 12 14 *15)
« Laatst bewerkt op: 2010/03/24, 22:45:37 door Robertos »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: PC hangt soms vast in de BIOS
« Reactie #4 Gepost op: 2010/03/25, 16:59:30 »
Zoek op je merk moederbord/pc of meer mensen problemen hebben.

Je zou kunnen proberen te installeren met noacpi of force ascpi of andere die je vind. Zoek hoe anderen zo installeren.
Vermoedelijk is je moederbord acpi niet in orde waardoor problemen ontstaan.

Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: PC hangt soms vast in de BIOS
« Reactie #5 Gepost op: 2010/03/25, 17:33:22 »
Ubuntu is al geïnstalleerd dus dat was het probleem niet, de installatie verliep vlekkeloos. Ik was al wat aan het experimenteren en heb grub aangepast van GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" naar GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off", vervolgens heb ik geen problemen meer. Het enigste nadeel is dat ik de PC handmatig moet uitzetten nadat Ubuntu is afgesloten. Het lijkt me eerder een probleem met de huidige kernel i.p.v. met de ACPI op het moederbord, mocht deze niet meer in orde zijn dan had ik dat toch ook moeten merken bij de vorige installaties lijkt me?

Ik vraag me trouwens af waarom dit gedeelte in het bijgevoegde hardware overzicht rood gekleurd is: product:    82801G (ICH7 Family) SMBus Controller ? Zijn er verder trouwens nog nadelen aan het uitschakelen van ACPI buiten dat ik de PC handmatig moet uitzetten?



Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: PC hangt soms vast in de BIOS
« Reactie #6 Gepost op: 2010/03/25, 18:33:07 »
In de BIOS zijn nog wat instellingen te vinden voor ACPI, ik heb enkel geen flauw idee of die goed staan en de handleiding zegt er ook niets over. Dit zijn de instellingen:

Suspend To RAM   [Disabled]
Restore On AC/Power Loss   [Power Off]
Ring-In Power On   [Disabled]
PCI Devices Power On   [Disabled]
PS/2 Keyboard Power On   [Disabled]
RTC Alarm Power On   [Disabled]
ACPI HPET Table   [Disabled]

Moet ik hier misschien een aanpassing doen?