Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: apache 2 mod_rewrite  (gelezen 3570 keer)

Offline jootn

  • Lid
  • Steunpunt: Nee
apache 2 mod_rewrite
« Gepost op: 2009/11/15, 22:13:59 »
Goede middag samen...

ik probeer hier gallery2 te integreren in drupal,

maar het probleem is dat de mod_rewrite module daarvoor moet aanliggen...

heb de module geladen in mijn httpd.conf bestand, en ik wilde apache opnieuw opstarten en kreeg het volgende:

Citaat
Restarting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
maar mijn apache draait nog altijd, want kan mijn drupal nog altijd aanspreken via localhost

iemand oplossing?

Groeten

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #1 Gepost op: 2009/11/16, 13:47:07 »
Kennelijk draait Apache nog of gaat er iets anders fout:
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80

En staat rewrite.load in /etc/apache2/mods-available? En heb je een symlink aangemaakt naar dit bestand in /etc/apache2/mods-enabled?
Hier kan je ook nog wat aan doen:
Restarting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Kennelijk kan je servernaam niet geresolved worden, wat staat er nu?
Ook zou ik, als je tijd en zin hebt, op zoek gaan naar eventuele alternatieven voor Gallery2. Persoonlijk vind ik het een onding, maar dat is mijn mening.
« Laatst bewerkt op: 2009/11/16, 13:49:17 door AutoStatic »

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #2 Gepost op: 2009/11/16, 13:57:50 »
Bij dit soort veranderingen moet je apache herstarten... Maar soms werkt een restart niet helemaal goed. Om echt zeker van je zaak te zijn kun je eerst stop, en dan start doen. Om nog zekerder te zijn moet je na een stop ff checken of er ECHT geen apache processen meer draaien. Bijv. middels ps -e | grep apache Als ze nog draaien handmatig killen. Bijv. met
sudo killall apache2 ofzo.

En staat rewrite.load in /etc/apache2/mods-available? En heb je een symlink aangemaakt naar dit bestand in /etc/apache2/mods-enabled?
Hier kan je ook nog wat aan doen:
Als je dit hebt gedaan moet je volgens mij ook nog ergens Rewrite aanzetten. in default van sites-available misschien? De precieze regel weet ik niet zo...
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #3 Gepost op: 2009/11/16, 15:29:42 »
Door het rewrite pakket te installeren en de symlink aan te maken zet je mod_rewrite aan.
Tenminste, op Debian. Ik mag er toch wel vanuit gaan dat het onder Ubuntu hetzelfde gaat.

Edit: je hebt gelijk :) Je moet sites-available/default aanpassen en AllowOverride None veranderen in AllowOverride All.
« Laatst bewerkt op: 2009/11/16, 15:39:09 door AutoStatic »

Offline jootn

  • Lid
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #4 Gepost op: 2009/11/16, 16:49:36 »
Bedankt voor de reply's
even kijken en antwoorden op jullie replys...

Heb het volgende gedaan:
Citaat
/etc/init.d/apache2 stop

als ik ps -e | grep apache uitvoerde kreeg ik een aantal regels met vraagtekens in.
dan heb ik sudo killall apache2 gedaan en nog eens dat grep commando uitgevoerd, en toen kreeg ik niets meer.

Nu heb ik mijn apache terug opgestart met
Citaat
/etc/init.d/apache2 start

en krijg ik nog toegang tot mijn webserver (http://localhost/) nog regels met processon als ik het grep commando doe... :s

--------

In /etc/apache2/mods-available staat het bestand rewrite.load met volgende inhoud:
Citaat
LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so

Citaat
En heb je een symlink aangemaakt naar dit bestand in /etc/apache2/mods-enabled?
??? :rolleyes: ??? ;)
(ben beginnend linux gebruiker :) )

Citaat
Kennelijk kan je servernaam niet geresolved worden, wat staat er nu?
Ik heb ergens gevonden dat je je hostname moet aanpassen... Mijn hostname is nu "jootn-linux"
Ik dacht dat je dat vroeger moest aanpassen in het httpd.conf bestand, maar blijkbaar is dat nu leeg. En heb ook al ergens gelezen dat dit nu volledig vervangen is door het apache2.conf bestand. Moet ik dat in 1 van die bestanden ook zetten misschien?

Hieronder mijn sites-available/default bestand:
Citaat
<VirtualHost *:80>
   ServerAdmin webmaster@localhost

   DocumentRoot /var/www
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes FollowSymLinks MultiViews
   AllowOverride all
   Order allow,deny
   allow from all
    </Directory>

</VirtualHost>

Hopelijk verstaan jullie mijn post ;)

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #5 Gepost op: 2009/11/16, 17:04:48 »
Je bent vrij duidelijk hoor, maar..
en krijg ik nog toegang tot mijn webserver (http://localhost/) nog regels met processon als ik het grep commando doe... :s
ik weet niet zeker wat je hiermee bedoelt. Maar als je (apache) server weer draait dan zie je weer processen draaien ja, dat is goed!

Citaat
En heb je een symlink aangemaakt naar dit bestand in /etc/apache2/mods-enabled?
??? :rolleyes: ??? ;)
(ben beginnend linux gebruiker :) )
Ik neem aan dat je in de terminal werkt. Ga naar de map mods-enabled en doe: sudo ln -s ../mods-available/rewrite.load
Je hebt nu een symlink gemaakt naar rewrite.load. Kijk maar middels 'ls -l'.
Als je nu apache herstart worden alle mods (modules) ingeschakeld die in de map, 3 keer raden, mods-enabled staan :-P

Hieronder mijn sites-available/default bestand:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
Hier moet je dus die AllowOverride aanpassen zoals AutoStatic zei. Let op die <Directory / >

« Laatst bewerkt op: 2009/11/16, 17:06:36 door Wazzzaaa »
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline jootn

  • Lid
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #6 Gepost op: 2009/11/16, 17:15:47 »
ok

IK DANK U :p

heb alles gedaan zoals je zegt, en inderdaad, mijn drupal wil nu zijn 'schone url's' uitvoeren :D

woohoo :p

alleen nog het volgende:

Citaat
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

groeten ;)

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: apache 2 mod_rewrite
« Reactie #7 Gepost op: 2009/11/17, 10:22:54 »
Mooi dat het werkt! En in je default config staat helemaal geen ServerName, vandaar de melding. Als je onder de ServerAdmin regel het volgende zet zou dat ook opgelost moeten zijn:
ServerName localhost